I cannot get Laptop/Lubon via USB to work

This is my first 3d printer and I’m frustrated.

According to Extruder Calibration a must, I need to calibrate my extruder. Also according to that post, and I have confirmed, you cannot use the WiFi connection to do so. (Huge bug! This needs to be fixed ASAP!)

I connected a laptop with the included USB cable to the SM2 port next to the screen port (the only spot the cable would connect). I started up Luban, and the only connection choices are serial port and wifi. I refreshed both and no SM2 came up.

I honestly have no clue how to calibrate my extruder at this point. I’m very frustrated at this point.

Did you load the drivers?


1 Like

Sorry to hear your having problems, when connecting with the usb. You use the serial connection. When you hit refresh it should show a new com port (ex com 3). Select the new port (it will disappear again if you unplug the USB and hit refresh, just in case you want to make sure you have the right one) and then hit the “connect” button. It should report back “connected”. After that continue with the calibration.

Also this is not a bug, simply a feature that was not implemented. And while many have mentioned that it should be added, SM has not commented on if or when they will allow console commands over Wi-Fi.

Let us know if you have further problems,

I have Luban 3.8.0. I updated the firmware on SM2 to V1.10.0_2020723. I did not know about Snapmakerjs for Windows 64-bit. I’ll install that. It may help the constant connect/disconnect I’m getting using Luban.

I did what you describe and I did not have any luck with Serial. I refreshed a bunch of times and did not see any port show up on in the drop-down. I made sure I had Luban 3.8.0 on the laptop. Any other ways I can check?

Do you have any other devices that you could test the USB cable on (I have an external hard drive that I test that style of cable on)? Is it possible that the USB port your using is not working? Also what version of Windows are you using?

Do not use snapmakerjs it is no longer supported. Not sure why he linked that topic, maybe he intended this one?

Ah that makes sense. I do have 3.8.0. I’ll see if I have something else I can try. The USB port is working on laptop. I even heard the connection sound when I plugged in the cable.

For most macs and some PCs you the drivers from that page, not the snapmakerjs

Or from here:



Then like @sdj544 is saying it sounds like a driver issue. Make sure to download and install the drivers (that is separate from luban) and try again.

I finally had success. I installed the snapmakerjs software. I made sure the SM2 was off, connected my USB, then turned it on. I was then able to connect with the Luban software.

As an aside, the WiFi commands do work with the window. You just get no response with M503. I know it either because I had updated the extruder via the WiFi command, and that was set with the USB.

If SM made M503 display the settings, then I think everything works be great with WiFi.

1 Like


I also had the same issue @Reefay had with connecting to SM2 via the serial connection until I downloaded the drivers separately as @Atom suggested, restarted my PC (running Win7 btw), and connected/restarted my SM in the same order. However, while the COM port now shows up in Luban, when I click the connect button it comes back with the message “The machine is not ready”. I have tried several different orders of physical/software connection (i.e. plugging cables before/after software startup), but nothing seems to help. I can also connect fine via Wifi (which as mentioned above doesn’t help for doing the extruder calibration) so that means the machine isn’t actually ‘busy’. Anyone have any ideas? (Btw this is for SM2 A350, but I don’t think that makes a difference)


Also as a secondary question: If I can’t get Luban to work to use the terminal to issue the calibration commands for some reason, can you use a separate terminal program (like TeraTerm) to issue the g-code commands? Has any tried this? And if so, what would the baud rate and other related serial connection settings be? Thanks.

not sure what could be causing the error, maybe try reinstalling luban? as for other terminals, yes i have used ponterface and 3d fox (android) many others use have use simplify 3d so it will accept any terminal.

Thanks. Yeah maybe I’ll try reinstalling then. For the terminal program, I was specifically wondering if maybe my port settings are wrong, and that’s why it can’t connect (for both programs). See pic below. I just used generic settings cause I don’t know what else to use. But for example, the industrial controllers I use every day use 115200 baud instead.

not sure about the rest, but the baud rate i use is 115200, i generally use 3d fox (android) as my machine is not close to my PC. that gives far les options.

Alright, well I changed to 115200 in TeraTerm, typed in M503, and still got no response. So what is 3d fox? Is it an app I can run on my android phone to connect to the SM?

exactly, its a free app, you just need an OTG cable and you can connect just like you would on the computer. if you wanted to wait others may be able to provide more information about connection with the PC. @ITmaze, @brent113 do either of you know the connection settings for connecting to the SM2?

1 Like

115200 baud, most everything else default. That’s weird.

1 Like

@SldWrksGod are you sure your using the right com port? com30 seems awfully large.

Lol, yes I’m sure. I just happen to work with a lot of serial devices (my work laptop is up to COM49 now I think). Btw I’m running SM firmware version 1.10.1. The ‘not ready’ message appears after it trying to connect for a few secs. I feel like Luban recognizes the COM port, tries to connect, and then it times out after a while when it doesn’t receive a response from the controller (The same thing as my terminal program). It then issues a generic error message cause it doesn’t know what to do next. This is just my guess of course.