Extruder Calibration a must

Did it adjust it to a new updated setting of the extruder back to 212.21 or a new setting? It doesn’t look like its off by much, not like before, just a faint under extrusion that is visible during the initial layer where the bottom/top shell meets the inner shell.

I’ll have to test and adjust when I get home

After a firmware update you can do the M503 command again to confirm if your adjustments have been reset. With latest update it didn’t change mine.

-S

I am trying to follow these procedures. I am getting strange results. When I initially sent the extrude command G1 E100 F300; it seemed to work and moved in the right direction. I tried to do several small moves in a row E040 for example and it stopped moving. I thought maybe it was not allowing me to send the same command several times in a row. Then I noticed it was going backwards. Now each G1 Exxx F300; command I send causes it to retract instead of extrude. What am I doing wrong?

Edit: I seems somehow interacting with the control panel took it out of relative mode. I entered M83; to return to relative mode and it’s working again!

1 Like

OK got my calibration set. Using SM PLA it is better than a fraction of a mm over a 100 mm extrusion. Initially it was way off. I tried the value from the OP and it was far better but still needed a little tweaking for me.

My value is 243.33.

Mine is exactly same with yours, 235.79

1 Like

I thought a summary of everything you guys listed in the previous messages would be helpful for us newbies getting started. I struggled with some basic things, so I thought I would share a detailed set of steps to help us get through the extruder calibration.

  1. On the touchscreen, swipe and tap Controls, preheat the nozzle to 200C and load the filament
  2. While the nozzle is heating, connect a computer via the USB cable and connect with Luban (as of 7/31/2020 trying to send commands via WiFi doesn’t work, I wasted a lot of time finding this out)
  3. In the terminal inside of Luban, type in M83 to enable Relative Mode
  4. With some calipers or a ruler, measure 100mm of filament from the top of your extruder and cut it or mark with tape (I cut it since it’s so easy to load/unload filament with the SM2)
  5. In the terminal, enter G1 E100 F300
  6. After the command finishes (extruder stops moving), measure the remaining filament you have left in millimeters. We will call this measurement “R”
  7. In the terminal, enter M503. In the response you get back, look for the text M92 and find the E value. We will call this value “E”
  8. Calculate “S” with the following equation, S = E * 100/(100-R). As an example, if you measured R = 11mm, and found E = 212.21, then S = 212.21 * 100/(100-11) = 238.44
  9. Update your “S” value or the new steps/mm value to the SM2 by sending the following command in the terminal, M92 E###.##. For the example above, it would be M92 E238.44
  10. To save this value permanently send the M500 command
  11. You can verify everything is updated by resending M503 and look for the E value in the M92 line.

This info is basically from chazr33gtr and rojaljelly. Thank you all for sharing your knowledge with us!

42 Likes

Tonight I’m trying to calibrate and every time I enter G1 E100 F300 it runs backwards and unloads. When I load or unload it runs the right way - whether I use the control pad or from my computer. I’ve tried restarting everything.
Anyone else have this happen?

-S

did you make sure to use M83 (relative mode) first?

1 Like

That was it. That’s what I get for trying to do stuff while I’m tired.
Thanks!!!
-S

1 Like

we have all been there. glad to hear you got it working.

Happy making,
-Atom

*Wide eyed *
My R value (filament remaining after extrusion was 49.38mm…)
That gave me an S=419.22!?!?!?
Doing a test print now to see if it fixed the issue I was having with little to no extrusion.

  • Update: IT WORKS!!! It even seems to have fixed numerous issues I was having with first layer adhesion.
  • Update 2: It kinda worked. I think it is defenitly over extruding now but I am not sure if that is due to this setting or another issue with printer settings.

First layer viewed from the bottom

Third layer

This is not normal, the most people in the forum have between 230 and 250.
Did you calibrate correct?- It looks overextruding OR too near to the bed.

If yes, I think you have a partial clogged nozzle. May you try to swap the hotend with the replacement and check the extrusion again?

1 Like

It should only be off 10-15%. That means if you tell it to extrude 100mm it only extrudes 90mm or so. Something else is wrong if you’re changing it that much. Bad filament or clogged nozzle or something in feed path?

-S

1 Like

The first time I ran the extrude code it only feed about half way through. After I changed it to 419.22 I tried again and it did about the same. I changed it to the value chazr33gtr said to change it to and after testing it feed exactly 100mm.

After setting all that I went to do another print and it wasn’t extruding enough to adhere to the bed and at that point I was done failing for the day and will come back to it later.

I’ll try recalibrating the bed for the millionth time but every time I calibrate to 0.1mm it never seems to make a difference when printing the first layer. I wonder if it was the model I was printing though, but I’ve had the same thing happen with other models and have been been able to get a good first layer.

Are these extruder calibrations only applicable for Luban or do they transfer over if I were to switch to Cura? I’m honestly very annoyed with settings in Luban not being consistent with any other slicer program.

The extruder E-steps are stored in the firmware so the slicer has no effect.
A value of 400 is really not normal. As suggested I would try to swap out the nozzle.
Mine is about 251 for PET-G.

For me the extruder calibration was a real game changer!
The bed adhesion is SO MUCH BETTER now. I had no big problems in the past but on some places the filament just wasn’t sticking well and I had to lower the nozlle so much that I always had an “elephant foot” on my prints. My Snapmaker Originals wasn’t as bad calibrated as the A250 but since I’ve calibrated all my 3 Snapmaker machines all of them are producing even better prints and I don’t have to even look if the first layer sticks to the bed. Only the leftovers from purging sometimes are hanging on the nozzle and I have to pull them away with some tweezers.

I’ve been ignoring this important step of printer preparation for years since my prints did look ok and I just thought that the Snapmaker print sticker simply isn’t as good as the glass bed of my Ultimaker 3 (I’m now selling!). Oh thank you god for letting me read this forum post a few weeks ago!

2 Likes

Thanks for explaining this. I was wondering the same regarding E value as I am still waiting on my A350.

Between 10 and 11 above you’re missing a power cycle. The machine must be turned off and on again for the saved firmware settings to be applied, and to read back correctly. (In my case I tried reading them back before power cycling, they were old, told myself oops I needed to power cycle, did so, and upon re-powering found the settings had not applied, either, perhaps because of the check before cycling[?]).

So to be safe, make the change, power cycle, then get back in with Luban and check. Repeat as necessary until it does echo back the right value.

This is mostly true, but the “flow” value does affect the extruder steps per mm. I I only mention because a lot of people mess with his setting rather then calibrating the machine.

A power cycle should not be necessary, m500 saves the current settings. M503 reports saved settings.

You just love correcting me :wink:
The slicer has no effect on the E-step value stored in the machine except:

  • flow rate
  • custom G-code where new E-step values can be set (maybe usefull for different materials)
1 Like

@rojaljelly its not just you, i love correcting everybody :upside_down_face: but never trust an Atom, we make up everything :joy:

5 Likes