Luban issues - also after updating to 4.7

I’m doing laser cutting only, Snapmaker 2.0 A350T, connected via USB cable.

  • Camera capture doesn’t work, option is just greyed out. This has worked but cannot remember when.
  • Since 4.7 Luban doesn’t auto detect the type of Snapmaker I have (2.0 350T). Also updated firmware to latest, no difference.
  • Cannot start a job in Workspace. The head goes to work origin and stayes there. Same file via flashdrive works fine.
  • Transfering a file to the device over USB doesn’t work, has worked over Wifi but since I use the cable this option is greyed out.
  • Importing a SVG file made with Illustrator in a certain dimension imports in Luban about 3 times bigger.

Any suggestions are appreciated.

Camera capture only works over wifi.
It’s a physical limitation of SM hardware.


Ok thanks. So how to get the wifi working?
My Snapmaker won’t even respond to a ping from the network, but has internet itself.

As I said before, lack of professional software management is the main problem here. Old problems reappear!

I guess so, so what is the solution? How do you deal with it?

Its probably your router which blocks the connection in your wifi.
I dont have such a behaviour in my network with latest firm (1.15.21) and software (4.7 not sure about the number).
Restarting the router is a good point to start.

Could be, but why has it worked before? Can you ping to the snapmaker? Or does the snapmaker block pings?

Dont know sry, my snapmaker appears in Luban for connection.
I could imagine a block of snapmaker because of the half android interface…

But you could simply roll back the luban version.

Remove the hobbyist programmer!

1 Like