Enclosure not being recognized

Hey guys, we just got our snapmaker and enclosure and installed everything. The 3d printer works great haven’t tried the other two modules just yet, but we can’t get the screen to give us the enclosure options. Everything seems to be plugged in appropriately and we have turned everything off and back on again. Not sure what to do.

Found the updates section on here, after doing that, it found the enclosure!

I have same problem. Ran 3D print and CNC; maybe for 40 hours with the enclosure never being recognized, nothing operating. Returned to a print job that failed (filament broke) and lo & behold, the Enclosure lights were turned on (first time). Turned machine off (as instructed) to unload/reload filament. Upon turning it on there was no lights, no recognition of any sort that there was an enclosure. As with AJ… I triple check all connections. no luck; no light, no evidence it had an enclosure (even though, unattended, it turned on the LED lights until I had to our the power on & off.

Have you updated your machine to the latest firmware from the forum, now we are at 1.10, i guess.
Have you plugged the enclosure to the add on port 3?

Yep, well maybe. Running 3.7.0.331 (MacOS) of SnapMaker Luban… available info indicates that is the latest. Upon starting the machine a few days ago it suggested firmware update and I ran that; BUT
https://snapmaker.com/download/snapmaker2 shows its “Firmware: Snapmaker2_V1.9.0”
Yet
Snapmaker 2.0 Firmware Updates and Downloads shows latest is " Feb 27 2020: Snapmaker2_V1.6.1.0"

Whoops… yes, latest firmware and yes to plugged in correctly. It’s really curious lights came in after it homes following a faulty, but not otherwise. Tried CNC and it seemed enough to refuse to start until enclose Dior was closed. So some small recognition but it’s sporadic. I’m going to unplug everything and plug back in from scratch.

Curious, no idea…

Sir/Ma’am… you fixed me. Thank YOU! Indeed, it was the missing firmware update (to 1.10). As soon as it installed I had access to a 5th module (Enclosure), was able to turn lights on/off, and turn on the cooling fan. I believe I’m 100% now. Two observations: I thought I had automatically updated the Firmware during the build/startup process… don’t remember exactly what was required and what I did so it must have been something else. And if one is a simple sailor like me… finding the firmware update, figuring out to install it on the USB drive and where to plug the USB in, Forethought to turn machine off first, then on, then refer to the touchscreen (vice I’m used to doing this type activity through the 'outer software), etc, etc. Many times I find one of three things… only one is good. 1. There are clear directions that lead the too smart/familiar as well as the true novice (wish it were always this way); 2. It assumes way too much familiarity because, well the person writing the instructions has, in fact, too much familiarity, and what should be 3 steps, 4 observations, and 2 choices comes out as “Start xx and observe yy while turning zz.” That leaves simple sailors like me in the dark. Or 3. It doesn’t anticipate the really, truly familiar and forgets to tell them "don’t do what every fiber in your being wants you to do because this one is different (better) (great example applicable and in fact covered in instructions here is "don’t tighten the thingamajig that your screwing, nailing, bolting, tiring, etc., until sometime later because if you do it now… oh, well!. Clear and universal instructions are an art.

But let me NOT override my appreciation to xchrisd… you saved my bacon.

2 Likes

I am no snapmaker staff…- There is a video about setting up the enclosure, unfortunatelly the video about how to use the enclosure is not ready yet, i guess,- i think this would be what you where looking for.
All the Best, Chris

Haha Chris, good guess and you are right. We are in the process of making a video on how to use the enclosure and it will be released on our YouTube channel soon.

I just got my snapmaker A350 with enclosure. I can’t get the screen to give me the enclosure options. Everything seems to be plugged in appropriately and I do the update.

1 Like

Hi there,

same problem here. Enclosure is not recognized.
Latest firmware is installed (V1.10.1) and everything plugged in correctly.
Also started everything again and plugged in again… nothing happened.
Can you PLEASE help me? What can i do? Really need the enclosure for some laser works.

Hi

I’m having the same issue. I’ve made sure that everything is up to date but the screen is still blank.