Snapmaker refuses to work with enclosure

hi, have done some laser and cnc (worked well)
enclosure was delivered (so that is the only thing new) and refuses to cnc saying the door is open (which it isen’t) “enclosure recovery program” “the door is open…”
have tried swapping the cable around and
changing the enclosure door in settings - was “off” to start with, and if i tried to turn it “on” and press “save”, it switches back to “off”

don’t know if this is relevant - but the fan or the lights have not come on, i assumed they would come on when the job started.

i can move the cnc module and the wasteboard, but the job just wont start.
have put the enclosure on 4mm pads (4 corners and one under each foot of the snapmaker (to save the table from being scratched)

any help appreciated (i am at a loss)

i think i have worked it out, there is no enclosure software (missing the enclosure icon on the touch screen)

looking into how to get it now

you need to update the machine’s firmware to enable the enclosure features. The following link should provide you with a link to download a newer version of FW that enables the enclosure.

thanks harris, greatly appreciated :slight_smile:

:slight_smile: i think the link you gave is for the software on the computer (its all good) this is the link for the machine software

1 Like


finally managed to update the machine (problem with my usb), update via the touch screen will be good in the future :slight_smile:

everything is working (YAH) the led strips (which look amazing to see the job working), the fan and the door being closed. it is truly an amazing machine.

thanks for the help