My dual extruder is not showing its connected on my snapmaker 2.0 A350T touch screen, any ideas?

Ok ive been dealing with snapmaker to help solve this issue, they sent me a replacement board for the dual extruder after a bunch of testing, that didnt work, tryed different firmwares to see if any would work, nothing worked, they sent me another dual extruder still same issue, it doesnt detect that it is connected, not sure if this has happened to any of you, if so what did you do to fix this issue.

There was a post a while ago, this person had to downgrade and update to the first working dual extruder firmware. Maybe from one version earlier to the working firmware.
Like in this post:

Here firmware:

Here similar topic:

1 Like

Sorry you feel that way but im not going anywhere untill i find a solution to get my dual extruder to work with or without your help, so there we are then.

Ive tried down grading to version 1.15 , didnt work for my A350T still shows not connected, tried version 1.16 and 1.17 , none seem to be working, single extruder and 10w laser have no issues they work fine, so i dont know, but thanks .

For clarification, did you downgrade to 1.14.x firmware and then upgrade to 1.15.2?
Maybe disconnect the tool head to downgrade and connect it after upgrade and install firmware again to get the module upgrade?
Did you ever try a M502 to get the factory machine settings and save with M500 in console?
Complicated issue…

Im gonna try the m502 and m500 next, snapmaker just hit me up today about trying m502 and m500, havent got to try it yet but i hope it solves the issue, ive tryed from 14 to 15 to 16 ,17, new 18 version and still nothing. Crazyvcause my single extruder and 10w laser have no issues, thanks for your help.

Just to make sure. Controller has no power when you plug the tool head. Right?

Everything is plugged in how it should be, display shows start button and thats all doesnt detect dual extruder showing left and right side temps or even the heated bed connection, but when i plug in my single extruder it shows head connection heated bed connection and shows the temps at the start screen, so what was your question i didnt quite understand what you were talking about.

Can you share a picture of how your Touchscreen looks like after completed boot?

1 Like

I didn’t ask if it’s plugged in how it suppose to be. But if the machine is completely Off when you plug in the tool heads.
Image of the touchscreen would help, like Wyphorn mentioned.


This is dual extruder , as it shows nothing connected.


This is single extruder, showing its connected.

So i think somthings up with my A350T, theres no way i can get two bad dual extruders back to back. But i tryed reseting touch screen by entering developer mode and that didnt work, ive loaded Luban and entered in command prompt M502 and M500, then updated by usb to version 18 again, and still the same, not showing dual extruder head connected. Snapmaker will get back to me , i sent them an Export Log to figure out the issue im having, i dont get it, never had an issue with my A350T before , i guess it doesnt like the dual extruders, lol

I told you exactly how it is and explained what it was doing , cant visualize? Its ok heres some pics , look at it, and then look what i wrote, does it make sense now?

Why would someone connect cables when machines on?

I didnt disconnect dual extruder while performing downgrades and touchscreen reset through developer mode, or when i entered in comand prompt M502 and M500, after that i upgraded firmware to 1.18, checked again and still shows nothing connected.


Dual extruder is showing nothing connected.


single extruder showing its connected.

I dont get it, i guess my A350T is anti dual extruder, lol

Is there light in it when dual extruder connected (maybe push the nozzle up) ?

Not pretty sure if it work but I guess it should:
Once again, disconnect your dual extruder and downgrade to 1.14.x .
Now upgrade to 1.15.2. Then connect your dual extruder module and perform the upgrade to 1.15.2 again.

The blue light is on and when i push the nozzles up it goes off and back on when its down, also with the level sensor same light goes off when up and on when down, ill try firmware one more time with dual head disconnected, and what head should i connect while updating? Also when updating my A350T never finishes on its own it says at 100% or on the screen it says “UPDATING…” and will stay like that untill i turn it off manually is that normal?

No head connected while updating.

Wait till the machine does reboot on its own. This probably needs up to 10 minutes.

It wont reboot on its own, it will stay on 100% or say updating… untill i turn it off manually, after i turn it of i get a sucessful update message everytime, heres a pic of what it says after i down graded to version 1.14.2 and had dual head connected. Then i turned off and connected single extruder with same firmware and second picture is good, so i think im getting bad dual heads.

I’m having this exact issue. I’m on firmware version 1.18….before I actually added the dual extruder. It does appear that other tool heads are detected correctly. I’ve connected with Luban and set my machine settings as indicated (although I didn’t see much point in that on the machine side).

I don’t think it’s relevant, but I did the new tool head immediately after adding the quick swap kit. I ALSO do not see in the settings the option to indicate that my quick swap kit is installed. I’m actually a little suspicious about the firmware not actually being updated because of that, but I have checked and retested that several times now….and Trey, your posts lead me to believe that it really doesn’t matter.

Wouldnt load both pics, but with the dual head is this pic, and the saftey screen was the single extruder.