Snapmaker 2.0 Linear Modules communication problems

Hey Guys,
first I want to say sorry about my German English.

On Friday I got my new Snapmaker 2.0 A350 delivered. I put everything together at the beginning.

Then was the first startup:

The Snapmaker don’t detected first the 3d-Print Modul. The Z + Y Achses was not responding.

I Connected the Snapmaker with Luban and with the Comment M1999 the Snapmaker detected first the 3d- Module after few minutes.

But the Problems continued:
I started the Snapmaker without Module and Checked in Settings / about Machnine the info menu. The Pictures are attached. There you can see, that the Snapmaker only detect the X - Linear Modul. Then I Tried to connect one of the other 4 Linear Modules directly on the X Port… no results. The Snapmaker Showed 0x0x0 in this Menu. That means only one of fife Linear Modules is working. I checked in Luban Comment M119 too. All end stop status is open.

If I connect the X linear module with one other together on one port I can move both. I think that this is not a Hardware issue. Is it possible that I have only a Firmware error with the Linear Modules? It looks like the Main Controller can’t detect these Linear Modules.

Is there a way to update or reset the Linear Modules CAN Firmware?

Firmware Upgrades or downgrades are not helpful.

Thanks for your Help


No, unfortunately.

Do you have a toolhead plugged in? I think the “no executor” message is related to the toolhead not talking to the controller.

I think you might need to email support on this one. At least recently they’ve been pretty responsive, should get back to you within a day or 3.

1 Like

Hi brent113,
Thank you for your answer :slight_smile:
Its very comforting to know the Snapmaker Team response quickly. I will wait for the support and let you know the news.

1 Like

Hi Kevin,
Im having similar problems. I received updated linear modules power unit and printhead for 350. Put everything together checked cables and modules that they are at correct places. Updated the sw to Snapmaker2_V1.14.1 Through usb stick. It seemd to go through.
I tried first fron control page to move module different directions but it didn respond not even home button. Now I dont know what to do next I put a line to support few days ago havent got any reply yet.
If You have got any reply from support or other members Im happy to hear how this could be solved ?
Kind regards