Linear module stopped working after third print

I took delivery of my A350 a few days ago. Two test prints were successful. Today’s print, the third, didn’t finish successfully. About three vertical centimetres before the end of the print, there was a bulge, suggesting a problem on the Z axis. At the end of the job, the percentage completion stayed at 100% for over an hour, with the print nozzle still on the printed piece, before I turned the machine off.

Since then, one of the vertical linear modules no longer works. There is no motion at all. I have removed the horizontal linear module to confirm. One vertical module works, the other is completely stationary. If I press manually on the working module, the slider moves relatively easily. To move the slider on the problem module requires much more force and the movement is not smooth. I have tried swapping the cables for the vertical modules at the Z converter but this makes no difference: the same linear module no longer works.

I have emailed support but so far have had no reply. Does anyone have any comments or suggestions, please?

Hey, i think you have to wait for the response of support.
There are a lot of defective linear modules out there, you could search at the forum about.
Have you tried connecting the defective one to the X axis, to see if the controller or the module is faulty?

Sadly could not help…

If it does not move the same as the other linear modules when the power is off then I would say it’s faulty. It’s sad that snapmaker’s quality manufacturing and rigourus quality control is falling short for so many users.

Sorry your having issues,
Good luck!

Hello xchrisd,

I swapped the X and Z cables and it made no difference. It seems clear that one of the linear modules has simply stopped working.

I was disappointed to read that the warranty states that I will have to pay shipping costs for the return of the faulty module and for the delivery of the replacement. This seems a poor way to support a customer who has paid a lot of money for a machine which has only delivered two successful prints so far.

I’m still waiting for a reply from support.

1 Like

Hi there!
Got a similar issue with mine and I was ready to send the module back and asked for replacement, I doubled the online form with a mail to the support.
They were fast and forthcoming and we solved the issue together.

In my case, one of the Z modules was faulty and I already swapped it with the X module to avoid overloading the twin Z module.

The cure went so:

  1. Depose the toolhead. Unscrew the X [horizontal] module from the vertical ones. (The faulty module should first be swapped with the X). Lay the X module on a stable surface while keeping it connected to the controller.
  2. Depose the tray in such a way that both Y axis modules are free to move.
  3. Swipe the screen left to access option apps. Click the ‘Home’ app.
    The modules will then cycle to their extreme positions. The first time, it may still work unevenly so a second click on the ‘Home’ button may be needed.
  4. If all went well, reassemble and do a test print.

In spite of the screen showing a bit out of range values (X : -0.19), the trick worked. I printed a few very detailed models and all went well. I hope it’ll work the same for you as this machine is great.

Enjoy your day wherever you are.
Phil

2 Likes

Hello Lacitis,

Thanks for your suggestion. I still haven’t had a reply from Support after several days.

I have already removed the (working) X module from the two Z modules. Only one of the Z modules responds to any Home/Jog command. I’ll do as you suggest and swap the current X and non-working modules but I’ll be surprised if that revives the dead one.

Chris

Hey, I’ve had this exact same problem, mine happened on the y axis, it randomly started printing roughly 30mm Y+ about 5 hours into print a print. I stopped the print and homed the machine and the y axis got snagged on its return and made a horrible noise that made me flip the switch pretty quickly. I removed the bed and tried again and realised the issue. I swapped the x axis module with it and now the y axis is working but x doesn’t move or even make a noise whilst attempting to jog. I was planning to remove the ends and see if anything seems a miss tomorrow. Keep us updated if you have any luck.

Andy

Hello Lacitis,

I swapped two linear modules, so now the two Z-axis modules are good and the problem module is on the X-axis. As I expected, this has not fixed the problem. Home/Jog now works correctly for both Z-axis modules but there is no movement from the faulty module on the X-axis.

Chris.

Hello Gandy,

I heard from Support. They asked me to check the silicone pad was correctly in place. It was. They also asked if it was much more difficult to manually move the slider on the problem module than on the others. It was, though the effort needed changes as the slider moves on the module.

Now I’m waiting for Support to advise what I should do next.

Chris

4 Likes

Hey Chris thanks for the update, I seem to have the exact problem as you. My silicone pad is where it should be and it is difficult to manually move the problem module by hand. Hopefully this is fixable and we don’t have to send the modules back.

2 Likes

Same problem here. I haven’t checked the silicone pad but the module is impossible to move. I’ve had it a week…

I just received a free replacement linear module (and no postage/VAT). I’m running a print now and it seems to be working well. I was not asked to return the original faulty module, so I have no idea what was wrong with it.

1 Like

I’m in the same boat, though I’m still waiting for a resolution. Going on a week now with just an email asking me to verify that the silicon pad is still there (which it is). Hope I can get a replacement soon!!

They replied to me quickly and got the replacement in the mail. I should receive it Wednesday so I’ll only be down a little over a week. Hopefully this isn’t a trend. I don’t want to have to replace all the rails one by one due to a bad batch.

It’s definitely a trend… I replaced the broken module and 2 days later the opposite module does the same thing. They need to replace them all at once if this is going to continue.

Has the root cause for these problems already been investigated? To me it seems that misalignment of the frame could cause too much friction on these linear modules and both will suffer from this, resulting in total functional failure of both of them in relatively short period of time. Again, this is just a hypothesis and I also don’t know if there is any overload protection in the motor/driver circuitry?

First the good news: the replacement module is working correctly so far. Now the bad news: FedEx sent me an invoice for £17 for import duties and fees! Having to pay anything at all for a replacement is just salt in the wounds.

I have the same problem. One of the y-axis linear modules stopped working. When I tried to home the device, after the x and z axes were homed, the machine made a loud noise and I turned it off. It had been working really well. I contacted support on Nov 4 but haven’t heard back from them. I was really impressed with the machine - until it stopped working.

Hey, because you have problems with the y-axis, read on here:

1 Like

It looks like i found the right thread. I had my A350 running for 1 week then I came in and turned it on and normally the screen will show the tool that is attached. Well it came on but didn’t show the tool anymore. After turning it off and on a couple more times I then tried to use the screen and move the axis around and the motors didn’t respond at all or moved to the end of the rail and started clicking. I jumped over to shut off the power and was like that’s not good. At this point I reached out to support. It took 3 days for them to get back to me after about 12-14 days of emails with a few days of them taking there time getting back they said they were going to send me a controller. Ok great. Well it took another 3 weeks for me to get it. I plugged it in and still had the same issue. I emailed them that the new controller didn’t fix the problem. Knowing it was going to take time for them to get back to me I started by just plugging in the tool and no axis/ rail and the controller saw the tool!! Yes! I’m getting somewhere. So, one by one I plugged in an axis into the X port on the controller and turned on the machine 3 out of the 5 axis motors worked. Both of my Y axis motors died along with the controller. I then emailed support my findings and I’m now waiting to hear back. So, currently I can turn on the machine and I have the tool plugged in along with 1 axis motor plugged into X,Y, and Z. It see the tool and it is able to home correctly now. Of course it’s all disassembled but it’s a step forward. Then today I found this thread and I see that this is a pretty large problem they are having. Not cool!! I have had mine 2.5 months and it only work 1 week. This is really not cool!!