"Bump" in Y-axis

Make a video about would help.
Disassemble the bed and the piece under the bed to let the axis drive freely to see from which module the issue comes.

1 Like

Thanks for reply! :slight_smile:
Yes I will remove the bed and check, and if the problem is still the same I can post a video.
(I am away for a week, so it will take some time before I can play more with my Snapmaker :frowning: )

PS: I ran two 5 hrs prints yesterday before I left, they both turned out perfect! :slight_smile:
But the pieces was printed in the center of the bed and not large enough so that the axis travelled into the bumpy area.

I’ve got the same issue, really annoying.
I don’t think it happens on the same position every time, but somewhere near the middle. Also it doesn’t happen every time, but occasionally, especially when moving far and then returning.
Sometimes it’s just an audible bump, sometimes I can even see the platform jumping a few mm up.
It has broken my CNC mill once, when it was nearly finished, the table has jumped up, so I found the mill stuck almost 2 mm into the surface, much further than the print should go.

Considering it doesn’t happen all the time, it’s quite challenging to film it, but I got something here: https://yadi.sk/i/tAQQINqiGpEqfA

I did re-tighten all the screws on the platform and bed, nothing has changed.
The issue is critical, it breaks CNC mills and ruins prints, making the printer pretty much unusable.

1 Like

Hi Flid, I looked at your video, seems like we have the same problem! :frowning:

After I ran a few more tests it looks like it doesn’t happen at the same spot, but changes a bit depending on which way the bed travels.

I can also see the bed shake when I hear the bump…

Relly hope there is a way to fix this! :thinking: :face_with_raised_eyebrow:

Here are some threads about Linear Module defects, unfortunately you will have to contact support@snapmaker.com :

I have now tried to remove the base and let the axis move freely. When testing without anumything on, I did not hit any bumps on the axis. I then loosened the y axis modules and assembled the base with loose screws and tested again - still fine. I then tightened the bed and moved the y-axis to the end and tightened the screws on the Y module, and the travelled to the other end and tightened the screws there. I then tightened all screws.
After everything was tightened, I ran the test again - still fine!

I then set up to do a new 3D print and ran the calibration, and suddenly i heard the horrible noise again! :frowning:
I did another test of manually moving the axis, and the problem is back and still as bad as before :frowning:

Hey there,
Have a look at this thread:

Spoiler alert… there are no solutions in it… but misery loves company, right?
Perhaps it will help fill in all the troubleshooting blanks for somebody somewhere whenever support decides to tackle what seems to be a major QA problem for these units.


Hi all,

I just received my A350 a couple weeks ago. I’ve been able to print several small items in the center ~75mm of X and Y axis travel, however when I have tried larger prints, I noticed problems with the bed leveling. In trying to troubleshoot those problems, I’ve experienced the same type of issues you described here, but only during calibration (so far).

Randomly during calibration, I’ve had the machine make a think sound and then the Y-axis gets stuck, forcing me to turn off the machine since there isn’t an emergency stop on the touch screen. This has happened three times now, each time in a different location in the Y-axis. The first time was near the center of travel, the next time near the back end of travel and the most recent time is was at the front of travel (close to Y-axis home).

So far, this has only happened during calibration. Every time this has happened, I’m able to move the Y-axis manually from the touch screen and it always homes successfully. Prints also have been able to complete fine without any apparent Y-axis issues, so far at least.

I have the A350 in its enclosure so there should not be anything getting in the way of the Y-axis. I’ve also completely disassembled the Y-axis during my troubleshooting and I’ve not found anything that can explain this behavior.

Does anyone have any further suggestions for how to troubleshoot this beyond what has already been said or should I contact support directly?


I’m really curious what the root cause of these turns out to be. The circuits are very simple, I’m thinking it has to be something mechanical? Guide rail bearings or something?

Hi, I am very curious too! Must be something mechanical… almost seem like the axis does not move completely parallel, so that there is some slack that suddenly “spring” back when the tension gets to high. :thinking:

I made a video of the problem: https://youtu.be/6uJt54c3fc8

Are both actuators moving without the build plate attached?

Just a quick update on my situation. I was able to print another small part (50 x 50 x 15 mm) last night. I’m really curious why this problem only appears during calibration on my machine.
I also contacted support, hopefully they can resolve it soon.

I can also print small parts without any issues… looks like the axis have to travel at least half or maybe 2/3 of the way before the problem occurs.

Just a thought I had, although I realize this is probably not the issue.

If the machine is off and you manually push the bed all the way against both of the Y stops so both of the modules are definitely in alignment with each other, does that change anything?

Also does it happen at all travel speeds? Can you try it at slow and fast speeds?

Yes, I have tried to push manually all the way to the end, but I can’t find any problems there. Also when I took it apart I ran the machine back and forth while gradually tightening the screws, so I do not think this is the problem.
I have not tried on different speeds… Im not very familiar with the machine yet so I’m not sure how change the speed.

Watched the video several times. Sounds to me like the stepper motor is skipping a step, especially considering the right side jumps forward or backwards when it moves.

Are the modules parallel? I see you said the problem goes away when you removed the bed. When you assembled the Y modules to the base plate did you leave the screws loose until the bed was assembled?

Could you try loosening the screws under the Y modules, moving the bed around with loose screws, and let me know if the problem is still present? Also, if it goes away with loose module mount screws try pushing the bed against the endstops like before, then driving the bed position to somewhere in the middle using the controller and retightening the screws - does the problem come back?

1 Like

Thanks, good suggestion! I will try :slight_smile:


Brent113, I have now tried to loosen all the scews again. When i run the machine with all screws loose i do not get the problem. But once i fasten the 4 screws to tighten the base plate, the problem come back. (All the screws on the linear modules for the y-axis are still loose)

I also turned the machine off, manually pushed the axis to the end, started the machine and drove the axis to the middle before i tightened the 4screws on the base plate. Still same problem.