Issues with firmware V1.15.11 and temporary solutions

We saw the issues that you reported about the latest firmware V1.15.11. We are sorry about this unhappy experience. Today, we stopped the update push for V1.15.11. The software team will be back to the office on Jan. 31. We will try to fix the bugs as soon as possible.

Currently, you can keep using the firmware V1.14.3. If you need to revert to V1.14.3, you can: Reboot the printer. Go to Settings - Firmware Update on the screen. Then you can update the firmware to V1.14.3.

If you have received your new Dual Extruder Module and you need to use it, you will need to update to V1.15.11. If you encounter the endless update loop issue before, you need to revert to the firmware V1.14.3, and then update the firmware from V1.14.3 to V1.15.11 via USB flash drive. You can download to the file for firmware V1.15.11 here: Snapmaker 2.0 Firmware Updates and Downloads - #21 by Alan It should help to avoid the endless update loop issue.

If you are having the endless update loop problem, you can: Power off the machine. Disconnect the tool head and all linear modules from the controller. Power on the machine. You should be able to revert to firmware V1.14.3 from the screen.

Make sure that the printer is powered on during the firmware update process. Otherwise, it might cause the problem that the touchscreen firmware and controller firmware are not consistent, which will result in the blank screen issue.

Apologies again for the limitation this time, but please reply to this topic to let us know if you still encounter any issues with these temporary solutions.

1 Like

Hello, thanks for the update.

I’ve still problem with reverting to the previous version. My actual is V1.15.11 and want to revert to V1.14.3. I’ve disconnected the tool head and all linear modules from the controller. After restarting the machine I got the error: after starting downloading and reaching 100% popup appears with a “failed” message.

Mines out of sync, not sure what version I updated from as an older version installed some months ago. Screen just not displaying anything apart from icon that shows usb plugged in and removed.

1 Like

There is also the issue that Auto Bed Leveling for the Dual Extruder is also not working.

Same here, @briansmad

@jaywinks Mines resolved now with the controller updater provided by snapmaker support. Email them and it’s easy to fix.

I emailed repeatedly over their holiday and latest yesterday. The last instructions I had were to boot the controller with nothing but the touchscreen attached and I could upgrade from there. But I can’t upgrade from there, it’s still a wallpaper-only screen. Awaiting next instructions.

I upgraded to 1.15.12 (successfully) but I was still having the same issue. Swapped out the module back to the single Extruder as the dual locks you into a calibration cycle on first use. Sent it to “Home” then move the three axis out of Home alignment. Switch the modules again and managed to get through the calibration sequence successfully

1 Like

Had the same issue, will try your work around, Thanks.

I tried what you said about powering off machine and disconnecting tool head and linear modules from the controller. I disconnected EVERYTHING except the power cord and the display, I got to the home display that said, “Snapmaker, Create Something…”. There is NOWHERE that allows me to “revert to firmware V1.14.3” from that or any other screen. I checked the settings screen (under updates) and I found no where to revert back to any update. I turned off the machine and turned it back on (after unchecking the box that showed an update was pending) and turned the machine back on. Then I turned it off and back on with another item plugged into the controller. I had the same message about a “Firmware Update” necessary. The same Update Loop that caused the initial problem.

What am I doing wrong.

I have the laser module hooked up. I don’t use the 3D Printer currently.

The newest firmware (1.15.19) should have fixed this problem. If you are able to update to that via the touchscreen WiFi, you can try that. I always suggest instead that the latest firmware be downloaded from the Support website directly onto the USB flash drive, and then the machine updated from the flash drive; seems updates are more reliable that way as you don’t have to worry about a WiFi connection failure and some other potential issues. You can also revert back to the older firmware versions by using the flash drive method; the Support website has a link for finding the older version.

Have you been able to get your machine working yet? If not, try disconnecting everything as they said, but instead doing the update via the USB flash drive. The latest and also old versions of the firmware can be found on the Snapmaker Support website and downloaded directly the the flash drive.

Can you please clarify. Did you power off, swap heads, home the machine, turn off the machine > swap heads > calibrate?
Thanks - After the upgrades the machine now says the calibration sensor is not working.

I was already at v1.15.19. So, it was just an upgrade; I did do a bed leveling after upgrading.

The one 6h print with the SM break away PLA, worked fine.

Firmware V1.15.12

I update on 3/10/23 to 1.15.12, just noticed yesterday that the machine say’s a new version is available, but it’s the same one. Is this a know issue? It say’s firmware is updated to 1.15.12 on the “about” screen. Wasn’t sure if this the endless loop everyone is posting about.

@Jade

I received my DX on Friday. I was on 1.14.3 and plugged in the DX… it wouldn’t connect and gave me a cyclical ‘would you like to reconnect?’ I put the SX on and put the 1.15.21 firmware on the stick and updated. At that point the DX head worked fine.

Just an observation to people to update to the new firmware before attaching the DX if you were still legacy.

1 Like

The currently released firmware is v1.15.21. seems to have a solved a number of issues.

https://forum.snapmaker.com/t/snapmaker-2-0-firmware-updates-and-downloads/5443/27

scroll to the bottom

Marty

image001.png

image002.jpg

2 Likes