Extruder Calibration a must

Spot on. Had to up mine too to 240

@Skulldragon33 make sure to set the machine to relative extrusion (M83 i think, someone please confirm this) if you are retesting in the same session. i forgot to do this and got a messed up result (i think mine was 10mm further off then the first test)

2 Likes

I had turned off the machine between test runs as the article linked earlier in the post said to do in order to check that the settings were saved. so it was not in the same session. but i will try again with M83 and see what happens thanks.

If I remember correctly I had to turn off and on for changes to take affect.

-S

Please be aware that the code in the first post is wrong!

Also I’d like to add that I think firmware updates reset the extrusion count, I adjusted mine months ago (turned the unit off for several months till I could get some mods completed) did the update to 1.10.0 on the unit and it seems that I’m under extruding again. Won’t be able to verify this until the print is completed but I have a sneaking suspicion…

It is reset in firmware update V1.9.0 or above, as the the code for the controller’s firmware is refactored. This was mentioned in the changelog of firmware update V1.9.0.

Did it adjust it to a new updated setting of the extruder back to 212.21 or a new setting? It doesn’t look like its off by much, not like before, just a faint under extrusion that is visible during the initial layer where the bottom/top shell meets the inner shell.

I’ll have to test and adjust when I get home

After a firmware update you can do the M503 command again to confirm if your adjustments have been reset. With latest update it didn’t change mine.

-S

I am trying to follow these procedures. I am getting strange results. When I initially sent the extrude command G1 E100 F300; it seemed to work and moved in the right direction. I tried to do several small moves in a row E040 for example and it stopped moving. I thought maybe it was not allowing me to send the same command several times in a row. Then I noticed it was going backwards. Now each G1 Exxx F300; command I send causes it to retract instead of extrude. What am I doing wrong?

Edit: I seems somehow interacting with the control panel took it out of relative mode. I entered M83; to return to relative mode and it’s working again!

1 Like

OK got my calibration set. Using SM PLA it is better than a fraction of a mm over a 100 mm extrusion. Initially it was way off. I tried the value from the OP and it was far better but still needed a little tweaking for me.

My value is 243.33.

Mine is exactly same with yours, 235.79

1 Like

I thought a summary of everything you guys listed in the previous messages would be helpful for us newbies getting started. I struggled with some basic things, so I thought I would share a detailed set of steps to help us get through the extruder calibration.

  1. On the touchscreen, swipe and tap Controls, preheat the nozzle to 200C and load the filament
  2. While the nozzle is heating, connect a computer via the USB cable and connect with Luban (as of 7/31/2020 trying to send commands via WiFi doesn’t work, I wasted a lot of time finding this out)
  3. In the terminal inside of Luban, type in M83 to enable Relative Mode
  4. With some calipers or a ruler, measure 100mm of filament from the top of your extruder and cut it or mark with tape (I cut it since it’s so easy to load/unload filament with the SM2)
  5. In the terminal, enter G1 E100 F300
  6. After the command finishes (extruder stops moving), measure the remaining filament you have left in millimeters. We will call this measurement “R”
  7. In the terminal, enter M503. In the response you get back, look for the text M92 and find the E value. We will call this value “E”
  8. Calculate “S” with the following equation, S = E * 100/(100-R). As an example, if you measured R = 11mm, and found E = 212.21, then S = 212.21 * 100/(100-11) = 238.44
  9. Update your “S” value or the new steps/mm value to the SM2 by sending the following command in the terminal, M92 E###.##. For the example above, it would be M92 E238.44
  10. To save this value permanently send the M500 command
  11. You can verify everything is updated by resending M503 and look for the E value in the M92 line.

This info is basically from chazr33gtr and rojaljelly. Thank you all for sharing your knowledge with us!

42 Likes

Tonight I’m trying to calibrate and every time I enter G1 E100 F300 it runs backwards and unloads. When I load or unload it runs the right way - whether I use the control pad or from my computer. I’ve tried restarting everything.
Anyone else have this happen?

-S

did you make sure to use M83 (relative mode) first?

1 Like

That was it. That’s what I get for trying to do stuff while I’m tired.
Thanks!!!
-S

1 Like

we have all been there. glad to hear you got it working.

Happy making,
-Atom

*Wide eyed *
My R value (filament remaining after extrusion was 49.38mm…)
That gave me an S=419.22!?!?!?
Doing a test print now to see if it fixed the issue I was having with little to no extrusion.

  • Update: IT WORKS!!! It even seems to have fixed numerous issues I was having with first layer adhesion.
  • Update 2: It kinda worked. I think it is defenitly over extruding now but I am not sure if that is due to this setting or another issue with printer settings.

First layer viewed from the bottom

Third layer

This is not normal, the most people in the forum have between 230 and 250.
Did you calibrate correct?- It looks overextruding OR too near to the bed.

If yes, I think you have a partial clogged nozzle. May you try to swap the hotend with the replacement and check the extrusion again?

1 Like

It should only be off 10-15%. That means if you tell it to extrude 100mm it only extrudes 90mm or so. Something else is wrong if you’re changing it that much. Bad filament or clogged nozzle or something in feed path?

-S

1 Like