Discussion of Snapmaker 2.0 Firmware Updates

suggestion : the time for the cnc job (6 basic images) said 24 hours, it later changed it to 8:30 hours longer than when it originally said (working through soft pine). To me, it is just calculations of all the factors (print speed, distance traveled ect), it seems to get really accurate half way through.

can we have a more accurate initial time please?

or am i missing something? (like resistance of wood)

Is it possible to update the firmware without the touchscreen? Mine was DOA and I’m waiting for a replacement.

Thanks.

Good question! I have not heard of one, @JKC20 @Edwin is it possible to update through luban and/or the console?

agree :slight_smile: to update via luban on the computer would be awesome :slight_smile: regarding the touch screen, if you don’t have one - it would be impossible to do a job, as you have to verify the connection on the touch screen, sorry @mikejl

just finished a simple job last night (made a mistake with settings on cnc, left step down at 0.2 instead of 0.5) with filled in text - said 3 hours (which was ok - job was with soft pine) ended up being 9 hours (and had to stop the job 1 hour before it finished), please - if there is a reason - let me know.

I have been able to Laser and CNC via USB connection and Luban, current firmware on machine doesn’t support the enclosure.

@Mikejl not too sure how you did this without a touch screen? maybe you have it now.
regarding the enclosure - congratulations (YAY), i found the enclosure excellent (it was better than i hoped and really good quality).
i had the same problem when i got the enclosure, but at least you worked out it was the machine software (took me a while to work out), just update the firmware on the machine via a usb (after update you will be able to do it via the touchscreen) the usb must be fat32

go to the bottom of the thread and it will tell you how to update.

for me (before i updated) wouldn’t let me print because it said the door was open, lights and fan didn’t work. (after update) works perfectly.

Hint (for mikejl) i connect the computer to the snapmaker via wifi, the top of the top four left buttons, press refresh (assuming the snapmaker is on and you are on the same wifi) press connect and verify on the touch screen

you will now be able to send the gcode to the machine via wifi

Unfortunately still no word on replacement TS. I’m connected via USB Serial Port and can use the Snapmaker that way for now. From what I gather the firmware can only be updated through the TS.

@Mikejl - that must be frustrating :sleepy: being a beginner myself, i don’t know how you got this far :thinking: i take it you are in Australia? an assumption based on the times of your posts - have they given you a tracking for it yet?

from my understanding (because you have to select the file via the TS) - i would say yes (only through the TS)

Why does the firmware not display an error when a linear module is not connected or has a malfunction?

I updated the fimware with the latest download and the controller says it’s at 100% but under that 100% it says, “Wait for the controller to upgrade…”
That has been doing that now for about an hour +…
Any thoughts on what to do or is this normal? I emailed tech support but the auto-reply said that could take up to two days (ordinarily, I wouldn’t care but the machine is stuck on and I don’t want to leave it like this for two days – and I am going away later today so I am jammed).
Anyone? Help! Please!

Power off and on and try update again. (You can check if it shows it updated, but I’d rather make sure it ran completely without freezing)
Firmware should take no more than 10-15 minutes to upgrade.
If it’s not done after that time it’s stuck. If you want to be safe wait an hour, but I think you’ll find that it won’t change even if you leave it overnight. (mine didn’t)
I know they warn not to power off during a firmware upgrade, but I don’t think there’s much choice in this case. I think the danger is when it’s in the midst of writing and in this case it’s not doing anything.
It’s frozen twice for me on two different firmwares, and both times I’ve powered off and on and been fine.
Do all of the above at your own risk though.
-S

2 Likes

Hi guys,

How do I know which firmware has my Snapmaker installed? Would you recommend installing new firmware or does it causes more troubles than solutions?

Thanks!

You should be running at least 1.9 - that’s the most stable.

I’m running 1.10.0
It’s one main bug is that sometimes prints freeze at 99%. Basically they’re done but you have to power cycle. It’s not all the time. I can live with it.

The latest 1.10.1 has a bug where if you quit a print and then try to restart the nozzle and bed temp get set to 0 and you have to cycle power. There also a bunch of other weird bugs that I can’t quite get to repeat. Also seem to be problems with laser calibration.

You can check your firmware on the control pad. Somewhere in settings. (sorry, in midst of print and can’t give you exact menu)
-S

2 Likes

Thanks!

I have the 1.7.0.0, so I think I will install the 1.9.0. I mainly use the engraver/cutter, so that would be fine for me.

A really nice improvement for the next firmware would be if the Z-offset could be changed (via touchpanel) in steps of 0.01 mm. In my case 0.05 is to imprecise.

2 Likes

I just reversed back to 1.9.
1.10.1 doesn’t store the calibration after a power cycle.
transfering file to touchscreen hangs and will only start to print after you removed the usb and inserted again. Then when you start it will transfer to touchscreen and start.

Has anyone else still experienced the “stuck at 99%” issue on 1.10.1? I thought they said they fixed that but I got this on 4 consecutive prints

Never saw that with 1.10.1

Had this problem because of comment lines in the end-gcode.
I deleted all comments and it works fine now.

1 Like

I see, this is only a recent issue for me however and I have not updated Cura or anything else related to generating g-code so I wonder why its only now started happening…