Issue with 2021-02-03 firmware?

I updated the firmware last night from the previous version to this new latest one. Ever since, anytime I power off the printer, it loses my saved Wi-Fi network and I have to re-enter it.
Additionally, I can no longer use the wonderful send to snap maker by Wi-Fi batch file/registry edit.the transform and will not connect again. I know this is unofficial and technically unsupported, but it worked up until this firmware update.
Not that I was having any success actually creating anything at all with previous version, because I wasn’t, but at least it maintained a stable Wi-Fi connection. What is the best way to roll back my firmware?

1 Like

I think it’s been mentioned to the developers: After power Off/On always hook to WiFi that was used during first setup and no Forget Wi-Fi option · Issue #73 · Snapmaker/Snapmaker2-Controller · GitHub

Someone was saying if you turn wifi off and on it will find it again.

I havent had this problem myself.

That’s from the July 2020 firmware. This didn’t start occurring for me until this months update and I was fully up to date prior to that.

Saying the developers are aware of it doesn’t exactly instill a lot of confidence in me given the ongoing bed leveling issues.

I will try this tonight. Thanks for the suggestion. think I’d prefer to just roll back though to where I didn’t have the problem.

I think you can just zap over the old version with luban, never did it before tho

Roll back, simply extract a older firmware from the forum and install it over thumb drive.

I will give it a try, thanks. You never know with some things, sometimes you got to do whole factory resets and reflash with some complicated method to get back to the base OS

I have an adjacent question. When you update your firmware, does it overwrite some of the calibration settings you may have stored to the machine such as those for the extruder? I’m just wondering if I’m going to have to do my initial out of the box calibration a third time before I’m able to actually successfully print anything.

Everything I read on the forums suggest to re calibrate after firmware upgrade. Some even suggest that the heads sometimes crash into the beds on new firmware so calibration is a must.

I wasn’t just referring to bed calibration. But that’s important to know, thanks!

I have not had to redo the esteps and personally my linear acceleration i built into my gcode instead.

1 Like

On previous versions it didn’t change it, but I haven’t checked on the new version.
If you remember what it was changed to you can do the M503 command to check.


1 Like

Hi everybody, I am new in the forum and would like to comment on some problems I had with the last firmware that not only concern to the WSiFi settings: 1.- WiFi credentials are lost after turn off, I need to introduce it again every time I turn on the machine.
2.- After successfully saving the data, the connection goes on and off intermittently.
3.- Autofocus fail once and again,
4.- Prints or laser jobs end at 99% or 101%
5.- Even on those few exceptional occasions when autofocus or manual focus succeed, I got the impression the laser power is down. The same plywood 1.5mm from Snapmaker now needs 4 passes when on the previous firmware just needed 1 pass to cleanly cut under the same conditions.
6.- The estimated time to finish is a bad joke or the internal clock goes faster than reality. Luban says a job will require 45 hours to end, however after starting finished under 45 minutes.
I would be grateful to receive a reply from Snapmaker concerning those flaws from a firmware released as final and not labeled as alpha or beta.

1 Like

Same here, I go to the wifi list and click my network and it sometimes works. A bit frustrating as it worked perfectly before the update. Even with a mesh wifi and my laptop connection via wifi or on ethernet to the router.

i do not have this issue at all so i cant vouch for legitimacy but

the forum says if you switch the wifi off and on at the machine it will reconnect.

i do know that they had done some tinkering with the wifi for the latest version and personally it made an improvement in that i dont have to reauthorize after a power cycle.

it may be related to 5 gh vs 2.4 gh network, it may be related to certain channels on the wifi network that are not allowed in china, or it may be just bad luck.

almost wonder if a factory reset would allow you to start over and have it work properly, because honest to goodness i am liking the latest version of the firmware.

Thanks for your comments, but honestly BAD LUCK is not a possible answer for a final firmware and for a product of more than 1500 dollars

Well, im just being straight with you, the product has been a mess from day one. they are working on it. and we are working together to get through it.

like i said, maybe try a factory reset to see if it takes better, or revert back to 1.9. i know alot of the issues on the software side were solved by uninstalling and deleting all traces, so i can only guess that a full factory reset might get rid of any artifacts in the firmware causing issues on the latest version.

As I have not experienced any issues I cannot test this theory myself, or I would have.

good luck

I was experiencing these symptoms with installing v1.11.4 (2021-02-03) via the touch screen

  • Disconnecting during gcode parsing
  • Hot end would not heat

I reinstalled v1.11.4 using USB and still experienced the same symptoms.

I rolled back to 1.10.1 (USB) and have not been having any problems since

I dont have such symtoms with 1.11.4 :grin: