Camera calibration, laser too weak or too far away

I tried to get the camera calibration working. If I understand the instructions correctly the laser should make/ engrave a square on the paper so that the camera can calibrate.

I tried to do that with and without the enclosure connected bu do not get a square on the paper. I see the laser is working (and with enclosure on I can make it stop by opening my door) but it seems to be too far away or too weak because the Paper stays blank after the laser has finished.

I tried to play with the papers distance to the laser and was able to get it close enough so that the laser leaves small burn marks but I can’t use this for calibration.

It seems odd that before the camera is calibrated I can’t set the position of the laser (incl z distance) like I can do before the laser is calibrated.

Any ideas? I’m running my A350 with the latest firmware (august 2020).

Thank you

Markus

I would suggest you to initial calibrate the laser manual to the smallest point, after that you have to set the z work origin.
Now try to calibrate the cam.

Havent used the cam feature so far, but I guess this could work.
Hope it helps!

I fear that might not help. From the description it seems like the camera is taking its pictures at a constant height. There should be the possibility to set the workpiece thickness before grabbing the images. The camera could then use the thickness as offset for taking the pictures and the stitching in the work plane should work.
Are these superstitions correct? @hyeii @Edwin @JKC20

1 Like

When you do the auto-calibration, please close well all the enclosure’s doors.
Or you can go to enclosure>settings>disable door detection. Then it works when the door is open.

Actually, only when the machine starts to engrave a few lines, you need to close the enclosure’s doors. If you are doing other steps, no need to close the doors.

Please try it first. If you still cannot use the laser module, please let me know.
If you have more questions, please don’t hesitate to let me know. Thank you

Hi @Edwin,

The laser focus calibration was not the problem (once I fixed the door issue) my problem is that for the camera calibration the laser tries to make the square on the paper but it does not use enough power. I don’t think that it has something to do with the enclosure but will try to do the camera calibration without the enclosure connected to the printer.

@Edwin I join this discussion because I’m really getting stuck with the laser calibration too. I recognized the same issue of @ml1140 with the enclosure door and I solved it.

Anyway it seems I still have the same problem about laser too far away. When the laser engraves the lines, only the first few are visible. And the calibration result is always a failure.

I really tried many times the same procedure but without success. I manually confirm the first line (0.0mm) being the best to my perception.

Sadly the following camera calibration fail because even if the laser tries to make the square on the paper no cuts are visible. I double checked the enclosure and all the doors are closed.

1 Like

Hi @jlropes

Sorry for the late reply.

  • Please send me a photo of the lines on the material and we need to check from which it became invisible.

  • Please check the default laser height in the touchscreen. The path is “Settings --> Laser --> Adjust Laser Height”

  • The height should be 15 - 20mm, and you can adjust it by yourself and choose a better one.

Best regards

Is that default laser height also used for the cam images?

Thanks @Edwin. Your advice was correct. The problem was the laser height.

From my understanding there could be a criticality if it’s performed a calibration wizard after the first run calibration in case the camera is out of focus.

In this case it seems there’s a tendency of the machine to increase the laser height at every further run of calibration.

In my example after many autocalibration routines, using the best engraved line, the laser height went over 29mm. The following camera calibrations failed, because laser was too far from the surface… and so on.

The solution was to force the laser height as you suggested and then perform the autocalibration wizard.

Please let me know if you need any help from us.

BR

I’ve noticed that after the latest firmware update that the “Settings --> Laser --> Adjust Laser Height” was on the maximum height (40mm) on default. This caused my laser not to print any lines.
After setting the laser height to 19.7mm in the settings, I could calibrate again and it works.

So when laser is showing issues, please first look at the settings and see if the laser height is not way high.

1 Like

From the 5 lines here, which is the one to select as best? Does not help me to get the lines when the manual does not tell me what to look for as correct…

I’m having the same critical issue of the Snapmaker 2 laser not engraving any lines during the Auto Focus procedure. It failed every time because the laser leaves no engraving marks.

Furthermore, I cannot even get to “Settings --> Laser --> Adjust Laser Height” because the setup wizard has no option to escape to get to settings.

I have attempted this both with the enclsoure door sensor switched off, and with the doors of my enclosure well closed.

I can see the laser beam hitting the surface of the 1.5mm wood sample supplied with the new package, but it’s as though the beam is far too weak to actually make any engraving marks. Please help!

UPDATE: I realized I could just “fake” my way through the rest of the setup wizard to get to “Settings --> Laser --> Adjust Laser Height” — However, that did not help, even when I went there and set the laser height down from it 30’s mm setting to 19.7mm and then attempted to re-run the “guide” wizard. The Auto Focus procedure still failed because the laser leaves no engraving marks. After attempting to re-run the wizard, I went back to the settings — back to “Settings --> Laser --> Adjust Laser Height” — and the laser height was again at 32.2mm.

I should add that I am using the base setup described here: Easy way to switch build plates

…In that I have magnets used to attach my laser bed pieces. However, if the laser height is “higher” than normal because my bed is higher than normal, it still should work. I am perplexed.

If you are connected to luban with usb, do you see the echo of the door switch?

others < door opened!
others < door closed!

If not you could look for the status by M1010 in the console.
What firmware do you run and what version from Luban? I would suggest to update these things to the latest from the forum.

1 Like

@xchrisd:

My problem was related to the door sensor! I solved it by taking the advice found here: Door Detection Faulty

…In particular, using the image you supplied of how the magnets in the doors should be arranged!

Success with a cut (without having yet done the auto calibration)!

I’m running the latest versions of Luban and latest firmware.

Of note, even though Luban shows the door sensor feature turned off, the firmware was still demanding the doors closed, as though the feature were turned on!

1 Like

I use the easy-switch method. I just did several photo engravings and also did the sample box cutout. Autofocus worked fine in all cases. Perhaps your starting height isn’t correct? I just follow the autofocus procedure as documented in the manual.

@wje, thanks, but I got it sorted. See my last post (showing above yours). It was a combo of firmware bug not honoring ‘disable door sensor’ and the door sensor itself being unusable because door magnets were not in correct locations.

Hi Edwin, hopefully you can help, I have an a350, and during the initial laser calibration, on wood and A4 paper calibration, everything worked out great. I was then able to cut through the 1.5mm Birch plywood that was included. I have been having issues cutting 2.8mm Birch plywood with a variety of settings, and can’t figure out why. After calibration my laser height consistently shows a height at 27.9. My snap maker is about 2 weeks old.

Are you referring to the solid basswood sheet? It’s an important distinction as plywood has a glue layer and the solid wood does not.

The laser cannot cut through the types of glue used in some plywoods.

Hi brent113, I guess that’s basswood, it doesn’t appear to be solid though and has two layers. I’m trying to cut thru 2.8mm Birch plywood. I’ve read here and on Reddit that people have been successful in cutting up to 5 mm birch plywood, albeit very slow. My real question is after calibration my “calibrated” laser height is 27.9mm, isn’t that really high, though my laser dot appears to be the finest at that Z distance.