3D and Laser modules no longer working

About a month ago, I came here about my filament getting stuck in the 3D module (Filament is stuck (jammed) inside 3d printer module). I was pretty disappointed, but ordered some new extruders).

I haven’t had the time to mess with the A350, so it’s been sitting dormant since that time. I turned it on today and checked to make sure there wasn’t a firmware update. I decide to fire up the laser module to maybe cut some Xmas ornaments. Get it all swapped over and turn on machine. It says need to calibrate. Everything is going normal.

I get to where it’s going to cut the lines for best laser height. The light comes on, it moves down, it moves like when It does when lasering, but no laser. It finishes “cutting” and tells me the camera cannot find the lines.

So now not only does the 3d module not work, but the laser isn’t either.

I want to throw this thing in the trash. I am so frustrated with this thing. I have no idea what do. I’ve shut it off, reconnected the cable. Same behavior.

Do you have the enclosure? Make sure the door is a) shut b) all 4 door sensor magnets are in the correct location.

1 Like

It has nothing to do with the enclosure. It would not run at all if enclosure is open.

For some reason, the 3d and laser modules are not turning on their functions. They have power because I can load filament/camera comes on.

It has been tested previously that if the enclosure is not being read as shut that the laser “runs” but at the lowest power setting. Of course you can open a support ticket, but they will ask the same question after 3 weeks when they get around to it.

I do understand your frustration, my printer has been broken for almost 2 months now. Still waiting for replacement parts. And if you just created this post to vent that frustration so be it. But if you want help trying to get it working we would love to help.

Good luck

1 Like

Ok. I guess you’re right. I turned off door detection and it worked. Now I’m wondering if this is why 3d printing was failing.

How do I troubleshoot door detection?

1 Like

Unfortunately I have not heard of it affecting 3d printing. Also I do not own an enclosure so I can’t really help you troubleshoot the enclosure itself. Maybe search the forums for some related posts? Or wait for someone else with more experience in that area.

There is a small gap at the cable entry at the door contact. Through this you can see whether a LED lights up inside when a door is closed. It must light up on both doors. If necessary, use a mirror or webcam to look inside. A bit of darkness is an advantage. Ensure that the cabling is correct, the door contact must go to one of the two small outer slots in the housing controller.

The magnets on our doors had to be moved into location, they had migrated during shipment. Super simple fix if that is the error. Make sure you check both doors.

We used a small magnet to trigger each sensor individually and marked with a sharpie on the sensors.

Magnet locations:

Left side sensor locations:

Right side sensor locations:

1 Like


Reading the above posts, I have a similar issue in which my laser module will not function for a project, but I have no enclosure so it would not be related to door detection for the print. During calibration, the laser will work just fine cutting lines at various focal lengths. However, as soon as I try to run a job, the system runs as if it is engraving, but there is no laser at all. I’ve tried all the basics - system power on/off, unplug/replug laser module at the head and system, recalibrate, different job and Gcode, etc. all with the same results. I am quite confused and need some help finding a lead to discover the issue. I had just had a successful laser job the night before, and the next day no juice.

Can you post the g code?

gen_30655035.nc (1.3 MB)

Sorry for the late reply. Attached is an example of gcode that will not function with my laser.

Maybe a red herring but this is suspcious:
;power(%): 0

If you M3 P1 in the terminal no laser?

1 Like

Yup that comment in the header says the code been generated with a laser power of 0. Also further down in the code the M3 command has no parameters indicating its off . Is should be something like
M3 P75.5 meaning 75.5 % power.

Check when your generating the code that you dont have it set to fixed laser power and that value be 0. Also if you just send a laser power command from lubans printer interface of say 50% it will set the laser to 50% power during the print. Worth testing, its on the lower left hand side of the laser parameters roll out

It’s worth refining this point. It specifically means turn the laser on to the last used power. If the last used power was from an M3 P0, as is occasionally used, then it will experience this behavior.

Changing the working laser power from the touch screen may be all that’s required to get this working.

In one of my previous cases the last used power was 100%, so I was quite surprised.

1 Like