A350 3D module not detected, even after new purchase of module

So, I hadn’t used my 3D print module for quite some time.

When I got my 10w laser it stayed on for a long time! Loved it!

So the other day, I go to switch it all over to 3D and went to plug in the 3D module, I had the UNIT turned on,(doh) to use the led lights not realizing that it should be off to swap heads.

I went to plugin the module, and almost plugged it in backwards. Probably got it barely started then stopped, flipped it around and plugged it in. I thought I heard some noise, and seconds later a small puff of smoke. I quickly shut off the machine, but thought the smoke may have been the unit warming up.

Hit the calibration tab on the handheld controls, and it said no module detected, I turned off the machine and back on, same deal. I plugged back in the laser module. It was detected and working fine.

I concluded I had burned up the 3D module, so I jumped on the snapmaker site and bought another module.

It came yesterday, plugged it in, and updated the machine again.

Nothing detected, even with new module.

Any ideas?

That’s a common mistake, the plug design is stupid enough that it allows to get in the plug so that it electrically connects before the mechanics stop you. Result is usually that both module and controller box (the thing screwed to the Z-axis with the lots of cables going in/out) are fried and need replacement. Sorry…

But the laser module is working fine?

I don’t mind buying another controller, it’s my mistake but it’s odd that the laser is working when plugged in. Yet the brand new 3D print module didn’t detect

Hm, interesting… I’d assumed that the laser would not have worked either…

Whatever, what you can try is attach the 3D module to the Addon 1 port (just one below the Toolhead port) - it will not work there, but it should be detected. I did this once for a test - honestly, I do not remember which module I used, so there’s a chance that the 3D module will not be detected. But if it is detected in your case, I guess that would confirm that something is broken in the toolhead port.

One reason why the laser might behave differently from the 3D printhead is that it has no stepper motor in it, while the feeder of the 3D head has. So some lines in the port/cable are only used for the 3D module. Still, I would have thought that the CAN lines are used for head ID…

I’ll give that a try! Thank you for responding!

I just plugged in the 3D print head to the second slot, and it reads it. It’s heating up the nozzle as I type, what function doesn’t work using the second port?

Edit: nozzle warm, load button ok filament produces no response, so guessing the loss is the additional commands to push the stepper

Just plugged it back in, to top spot, zero reads on 3D print head, but the Laser reads fine


Funny indeed, but IMHO a clear indication that the toolhead port of your controller is fried… You’ll need a new one.

I cant find any in stock, but Only saw two US friendly places to purchase from so far.

Not critical, just frustrating.

Seems the controller can only be purchased by contacting Support. There is a similar looking product on the official SM store, but that is the CAN Hub, not the Controller; it doesn’t have as many or the same type of ports as the Controller does.

I’ll have to email them, see if I can get one faster.

1 Like

It seems that you could remap the toolhead-port to another port:


I guess you’d need to remap the E-axis - if that works, you could continue printing until you receive a replacement controller.

1 Like

I wouldn’t have a clue on how to do that :joy:

It is surprisingly easy, only caveat: You’d need to do this at every power on of the machine.

  1. Start Luban, connect to printer
  2. Switch to the “Workspace” section of Luban
  3. In the Console section where there’s “Send command”, type M1029 E2 (case matters, captial M, capital E) and hit enter

And that should be it. Now AddOn 1 Port should be your new 3D toolhead port. The other toolheads still go into the original port says the documentation.

This is untested by me, so may or may not work.

1 Like

I’ll let you know thanks man!

Just tried this, no luck. damnit lol

Its heating up nozzle, bed is heating, lets me calibrate, doesnt feed any filament :confused:

Ah, stupid me, did not read the doc properly. If you go to the page I linked earlier, it is pretty clear. Here’s how it really goes:

  1. Start Luban, connect to printer
  2. Switch to the “Workspace” section of Luban
  3. In the Console section where there’s “Send command”, type M1029 E2 (case matters, captial M, capital E) and hit enter
  4. Send M500 command to save setting
  5. Power-cycle the machine

→ Now the setting should stick and the port re-mapping is effective. It will stay until you repeat the procedure with M1029 E1 (getting back to default. Most likely this is not necessary, since the new controller will be on default settings anyhow.

Sorry for the confusion - and still: untested, may again not work :slight_smile:


I’ll give it a shot today!

Im just now starting to test it, bed is warming up!