Upgrade the Toolheads Separately with Snapmaker Firmware V1.12.0

To use the Emergency Stop Button and the Rotary Module, you need to upgrade all modules to Snapmaker Firmware V1.12.0, the toolheads included.

With this version of Snapmaker firmware, the Touchscreen will ask you to upgrade three toolheads with the USB flash drive. You will see the Touchscreen notification “Outdated firmware (Modules) detected. Please visit our website, download the latest version, and update before use.”

For a complete and quick procedure, you can upgrade three tool-heads without mounting them on X-axis. You can plug the cable in three modules direct and upgrade them separately. See the image below.

image

Please be noted that you need to power off the machine whenever you need to plug or unplug any cables.
Please also notice that you need to use the cable correctly. Here is an image for your reference:

Caution

  • Users who have not finished the onscreen walk-through of Laser Engraving and CNC Carving need to upgrade Snapmaker Firmware to V1.12.0 before using the Rotary Module; otherwise, the toolhead might crash into your Rotary Module during walk-through.

How to upgrade the firmware

  • Put the firmware update file Snapmaker2_V{version}.bin in your USB flash drive.
  • Plug the drive into the Controller.
  • On the Touchscreen, tap Files > USB > Snapmaker2_V{version}.bin .
1 Like

It’s none of my business, but…
When replacing the 3D printer module/CNC module/Laser module, turn off the power before replacing the cable.
Do not replace the module while the power is on.

It may be better to put the firmware in a USB memory and update it.
After the module update indication appears, it will be updated automatically.

Thank you a lot for the reminder.

Please be noted that you need to power off the machine whenever you need to plug or unplug any cables.
Please also notice that you need to use the cable correctly. Here is an image for your reference:

If users upgrade firmware to V1.12.0 from V1.11.4 or any previous releases, you need to upgrade three tool-heads with the USB flash drive separately.

So I updated the firmware in the controller, and that was nice and painless. The laser module was mounted when I did this. When I plug in either the 3D module or CNC, I get the notice about upgrading the firmware, but when I go select the .bin file on the stick, or try to update online, I’m told I’m already at the latest firmware. So it looks like my laser module is upgraded (no warnings) but CNC and 3D are not.

Now what?

My memory’s a little foggy, but…
If you did the online update from the touch screen, I think you only got a warning if you changed the module.

If you put the firmware update file in a USB memory stick, you will see a warning and the update should be done automatically.

1 Like

@dbvanhorn

Hi Dave, sorry for the inconvenience. If you update the firmware from V1.11.4 to V1.12.0, you need to update the tool-heads separately with the USB flash drive instead of updating it online.

@Blockmodule Thank you for your reminder.

Cheers
Edwin

1 Like

I tried to launch the update from the flash drive, it tells me I’m already at that version and exits.

anyone experienced a “halt” when upgrading the display. I took an awfully long time to process but never ended (the display update/upgrade) … so I never had the chance to update my module heads … any ideas or clues? is there an alternative way to do that (probably via luban firmware update - which .bin file to take??)

Thanks!
Hannes

The .bin you need is in the first post of this topic, posted from edwin.
You need to copy it to the root directory of a usb-flash-drive and plug it to your machine USB-Port A (don´t know if there are thumb drives with mini B out there :wink: )

Switch your toolhead to a not updated one, take care to plug the cable the right way, turn your machine on:
Touchscreen: START → Not LOCAL, USB → execute the Snapmaker2_V1.12.0.bin

2 Likes

Thanks @xchrisd ! However, this is exactly what I did … until it “hang” whilst updating the display firmware. After half an hour, I gave up on the “updating …” info on the screen and rebooted. I checked via serial connection upfront, whether the controller was updated (and it was), so I hoped for the best and rebooted. Turned out, now I have the controller updated, but not the display nor the modules (as it seems). … I tried several times … always the same “hang” when i comes to the display firmware … Any suggestions?

Best, Hannes

You need to have one toolhead per update connected, this means, you need to update the firmware three times.

Do you see your toolhead at the mainscreen of the touchscreen with a green point?
I would suggest to try another thumb drive, from time to time there are people who had problems about…
Maximum is 16GB, USB2.0, FAT32

My first update took more than 15minutes, i guess.
Toolhead updates took less than 5min, i guess.

@Snapmaker-Edwin -I noticed that the new firmware took away the option to start a job after sending a gcode file to the snapmaker-is this intentional?

2 Likes

I Just had mine stuck on “updating…” on the screen while upgrading to v1.12. Don’t know if I should power it down and try again?

@xchrisd thanks for the advice - it worked. However, I used a 128 sandisk stick BUT I formatted it under linux using a VFAT partition - worked like a charm. Additionally, I disconnected my OctoPrint serial connection (not sure if that influenced the update).

@Durken for me reformatting the stick under linux and disconnecting the serial connection did the job.

1 Like

@cbardon

Other users indicated this change as well.

It seems that this is an intentional fix from our software developer, @Alan. We will go back to the office tomorrow, and I will confirm it with our colleague.

Sorry for the inconvenience.

Edwin

@Durken

Please power off the machine. Remove the tool-head, and then reboot the machine without the tool-head on.

Please check if the firmware version of the controller.is V4.2.1 (the latest).

If the controller’s firmware is the old version, you can re-upgrade the firmware.

If the controller’s firmware is the latest version, please check if the touchscreen will show upgrade notification when you connect the tool-head.

Keep me updated.

Edwin

In the first photograph above it seems to be deceiving as it makes it look like the touchscreen is directly connected to the toolhead.

Also, it looks like the method of updating the laser head without installing it cannot be achieved if it’s never been installed before (brand new machine). This is because it wants to go through the calibration/focus stage before you can do anything else. There seems to be no way to stop it so that you can run the update. This means the currently installed head (in my case the 3D printer) starts moving around while you actually have the laser head connected to the cable as in the photo.

Hey Edwin,

Thanks for the post, as I had completely forgotten about updating the modules. When you use the update the firmware over WiFi, doesn’t it save the *.bin file to the Touchscreen? Couldn’t your programmer allow us to use that update file to update all of our modules? It would make this process significantly easier.

Also, for the most part, I always want the LED lights in the enclosure to be “ON” when the power is on. If you don’t want to always power up with the lights “ON”, could you have it do one of the following? Either:

  • Remember what state the lights were in at power-off, and return them to that state on power-on?
  • Add a configuration setting where we can set the power-on state for the lights?

It’s a bit of a pain to always have to turn the lights on manually, after a power cycle.

Best,
Will

2 Likes