Touchscreen is black

Today i received my Snapmaker 2.0 F350.

I set it all up, all the cables are in their right position. When turning Snapmaker on, the little touchscreen shows the ‚S‘ Logo very short and then goes black.

I can’t operate the touchscreen at all. I unplugged the cable and flipped it. Didn’t help.

The Status light is breathing regularly.

When opening Luban on my notebook i can connect the snapmaker and controll all the axes without any problem.

But it aways shows me the error ‚Echo: Unknown command: M1012‘. (even though i don’t have the emergency stop button)

I thought that it maybe needed a firmware update, but i can’t update it when the touchscreen is not working

Is there anything else i can do? Or might the monitor be malfunctioning?

This article may help: What should I do if the Touchscreen is black? – Snapmaker and What should I do if the Touchscreen shows “not responding”? – Snapmaker

Thank you but i already saw this article and tried all of these suggestions.
Unfortunately they don’t help me, which you can guess by reading my post.

I would then contact who will advise further or replace a defective touchscreen.

I don’t get any answer from them. But i guess i need to wait.
Thanks for your help though

You should at least get an auto-reply from within an hour.
If you don’t check your spam folders.


A few days ago, the touch screen on my A250 stopped working and I emailed support and they agreed to send me a replacement.
It may not be a good environment because the temperature inside the enclosure is quite high due to the ABS molding.

You may want to contact support for more information.

got the answer from the snapmaker support today.
The Problem was the rubber at the cable connector to the touch screen.
We cut of 1mm of it.

It worked immediatly!
Thanks for your support

1 Like


Is there such a thing as a response…
If you ask me to cut 1mm off the rubber, I don’t think it’s at the product level anymore…

I guess it’s solved for now.