Touch Screen not working after assembly

I received my A350 via FedEx yesterday and spent what time I had yesterday and finished assembling this evening after work. After getting all of the screws and cables etc. I got to step 3.2.1 of the guide and the power module fired up as expected but the touch screen stays completely blank and never powered on. Suggestions, helps, troubleshooting steps??? I already directly messaged Raine on FB with a video showing the setup and exactly what I’m experiencing.

Hi fillngraves,

Please try power off the printer, re-plug the screen, power on and wait for the screen light up.

If the screen is still blank, please check the controller’s light is on and breathing.


I received my A250 today, assembled everything and at least saw the “S” (Snapmaker logo) for 1-2 seconds. Since then I have exactly the same problem - black screen. I already checked each cable connection, turned it off and on again. The Power Supply is slowly flashing and the fan is running.

I started with the Laser Engraving configuration and when the black screen don’t want to turn into something else, I turned it off and changed everything to the 3D Printing configuration. (Thought that might help if there is an error on the Laser module.) But still same result - black screen.

@Alan: Any other ideas?

@fillngraves: Did you make it work?

no, nothing has worked for me, I don’t even see a flash of the logo :frowning: nothing has worked

In serial port connections nothing shows up, I just re-tested. So it may actually be the controller that’s not working, is there a way to test that?

@fillngraves Have checked the video and I found that the Snapmaker Luban is not connected with the printer. Did you saw the new serial port infomation if clicking the refresh button in Connection Widget?

It nothing comes up, then the controller is not power on. Maybe there’s a connection problem between the power supply and the controller via 4-pin wire, not sure for that but you can try for it.

@marcelbreuer you can check the controller and see if there is a white status light on the back. If the light is not on, that means the controller is not power on.

Here’s the picture that controller is power on with white breathing lights.


1 Like

@Alan I checked if there is a light, but everything keeps dark - no flashing or permanent light. The power supply is running. Can I conclude, that the cable between power supply and controller or the controller itself is broken?

1 Like

@marcelbreuer Not a hundred percent to confirm, but maybe you can test continuity with the cable using multimeter, hope this can help you.


No breathing, I haven’t been able to bring a laptop to connect yet but I’m pretty sure it’s the controller.

-Phil Graves-

Hi Phil,
have you tried to check the power cable with a multimeter?

@Alan, I tested the power cable with my new multimeter (:grinning:) and indeed one line seems to be broken. Already contacted the support and asking for replacement.

Hi, I had the same problem. The cable its on my way: D
I hope there isn’t any other problem ><

This was the faulty pin and cause for not able to connect. When tested with the multimeter it did not have connection from end to end

Any way to disassemble this cable in order to make the repair until a replacement cable can be sent from Snapmaker… I’d really hate to wait weeks or months for just a cable…

1 Like

Here is some pictures and my experience how to repair power cable.

  1. Get multimeter with beeper and locate pin with bad or no connection.
  2. Cut outer plastic
  3. Solder wire to pin.
  4. Test all connections.
  5. Isolate with shrink tube or tape.
  6. Done!

P.S. I tried to remove outer shell with no success. May be someone with pictures will be more lucky.

Email me at

What are the voltages on the pin wh should be getting?, is this any standard cable?


The two outer, big Contacts are carrying 24V.
Afaik, its not a standart Connector you can get off mouser or Digikey. Never seen it anywhere else so far exept on the SN, which is annoying if you want to make your own Cables for Testing things.

Thanks so much!!

El El dom, 1 de noviembre de 2020 a la(s) 13:01, Streupfeffer via Snapmaker where creation happens <> escribió:

I’ve got the same problem. My controller light is breathing after I turn on the Snapmaker. The S is shown in the display, the enclosure lights turn on for some seconds and then I just get a black screen, while the controller light keeps breathing. The emergency button led’s are working as well. Do you have any guesses what to do?
Best regard