Snapmaker Luban shows a blank screen

I have recently recieved the A250 after the Kickstarter project. Assembly and set up went perfectly but I’m having trouble when it comes to using Luban.
I have installed the latest version from the Snapmaker site, connection to my machine over Wi-Fi is fine but whenever i try to load a model in to Luban to get it ready to 3D print, the screen goes completely blank. All I’m left with is the ‘File’, ‘View’ and ‘Window’ tabs at the top. The best i can do is select reload or force reload which just restarts the software. The software hasn’t crashed and still responds.
Does anyone have any ideas what could be causing this or how to get it to work properly?

Just a few points to mention;
I have tried uninstalling and installing the software.
I have updated my machine to the latest firmware version listed on the Snapmaker site.
I have tried Wi-Fi and Serial Port connections and end up with the same result.
I can use Cura to save a model on to a USB stick which then loads directly in to the machine and prints perfectly.
I haven’t tried laser cutting or CNC carving functions with it yet.

Any assistance would be appreciated.

I get that once in a while with my 8yr old fanless computer, usually mine will work fine loading the file then when I load to the workspace if it is a huge print program it’ll overload the video driver in the Luban software (it did it to me with the previous snappy1 software as well), at least this is what I think it is…maybe its something in the video card that doesn’t like the 3D rendering or its not powerful enough and it crashes the rendering window.

Doesn’t happen to me enough to worry about right now and I’ve never gotten the problem running SD3, repetier or makerbot software and I’ve never gotten the problem with Luban on my work laptop meant for 3D CAD/design.

Snapmaker Luban got updated. Now it shows an empty window: What to do now???
snapmaker Luban empty window
My previous version 3.10 never showed this problem.
I started a discussion at facebook without a solution yet.
Uninstalling and reinstalling old version doesn’t work either any more! CCleaner registry and updating nvidia driver didn’t help. “View in browser” (in Firefox) never worked. Cura, SnapmakerJS and my other CAD and 3D software do work, but Luban does not. Please help!