3D Printing - Nothing happens after starting

Is this happening to anyone else? After selecting a file to 3d print and hitting start, it says “transferring the file to touchscreen, please wait…” spins a little and nothing happens. If I try to start again or pick the file again, it crashes. I have to turn it off and back on 0 - 10 times for it to start printing. It’s able to home and I can change filament just fine.

I’m on the latest firmware. Tried re-loading the same firmware. I use Cura 4.8 and happens with any stl. Also happens with Luban generated gcode.

Tried other usb sticks, and it does the same thing. Tried with and without the enclosure connected.

Anything else to try besides another firmware?

Tested wifi connection and it loads the gcode from the local storage 4 out of 4 times after a power on.

disregard, i didnt see you said luban gcode did it too

can you jog in all directions, raise the temp of the nozzle and bed?

maybe you should roll bacvk to 1.9 firmware everyone says its more stable

1 Like

Yeah, I can jog, and raise temps.

I may have to, but hoping there’s other things to try before doing that.

it sounds like you’ve probably tried everything there is to try, short of re-seating each connector on the controller including the screen

if it happens with every stl on either luban or cura, with or without transferring the file on usb, and the machine otherwise functions.

1 Like

Sorry, forgot to mention re-seating all cables.
I’ve only ever done usb dongle, no wifi transfer or usb cable.
Thanks for helping out.

if a firmware roll back doesnt work it seems like something is going bad in the hardware someplace and you will have to work that out with support@snapmaker.com unfortunately

1 Like

oh - and i should warn you - dont wait too long to try this. if you need replacement parts, the chinese new years is rapidly approaching, it will take a couple months to get them if you are too late.

if you do need parts, reference this thread in your email along with extra details, your order number and address in hopes to get it all in one shot, because sometimes it takes several days to a week to get a reply.

1 Like

I guess you should try some other usb thumb drives, maybe yours is defective.

I have tried another one with the same results. Both formatted in FAT32

Not an answer but this thread details two ways to send files over wifi rather than using USB. I use the context menue “send to” method for laser and CNC transfers. I use OctoPrint for printing. The Cura plugin might work for you though I have not tried it.

After you hot Start can you see the nozzle and bed tempeatures rising? Nothing happens until they reach the required temperatures. Then the print starts

To do that you need to look at the handset or have something plugged in using USB. Thats one of the reasons I use OctoPrint running on a Raspberry Pi. I connect to OctoPrint from my laptop, the Raspberry Pi is connected to the Snapmaker via USB and OctoPrint shows the temperature, head position during working jobs and replies received from any GCODE command sent from the terminal page.

The thumb drive has to be USB 2.0, 16gb or less and Fat32.
Do you have this specs?

Stewl that was not a question. It was an answer to luffypandas question that “nothing haooens” :rofl:

Used the supplied usb stick and my own usb2.0 formatted to fat32 and is 4GB

After start is hit, nothing happens

May you share a not working gcode, please?
Or make a video.
You could “listen” to the communication between the touchscreen and the controller if you connect your pc to the controller with usb (serial). Maybe this helps you finding the issue.

CFFFP_Painters_Piramid_Blunt_tip 6.zip (1.4 MB)

Here’s one in a zip. Though it happens randomly and works like 1 out of 5 times.
I’ll try to make a video soon

So far, wifi has been working better for me, though just prefer usb stick

I’ll try USB cable too later

Execute job from snapmaker, load from luban over wifi or usb, but dont execute from luban for best results

Your gcode looks good and works so far…
I have sent it over wifi and also the transfer with a thumb drive works fine with my device (latest firmware 1.10.1).
May you make a video about, what does not work or describe your problem a bit closer?