Luban application crashes


I’ve have problems with the program for a while. I am using Windows 11 22H2 and for long time Luban is working well. But suddenly it start to crash every time when trying to use the advanced menu “more Setting” in the 3D printing. Every time if I try to use this menu a error window appear whit message “Something went wrong. Please reload the app.” Reload not help at all - already tried Reload and Force reload after use them it is the same. Open and close the Luban not help too. Already tried to reinstall and strangely this not repair the problem too…

Not sure if windows update cause this problem.

Any ideas how to repair this problem or what to try?

I use CURA for now but it will be grate to have Luban working too.

Hi Infinity_bg, Luban v4.5 will be officially released within one week, so you could try the new version and see whether the problem persists. :blush:

1 Like

Ok thank you. I will try it.

The new version not repair the problem. Even it get worse and now when load the 3d Printing module the menu on the right it is on constantly loading status… If i try to load any file for printing the process is suck on 74 % or something like that…