Snapmaker A250 3D printer breaks on contact with a heat bed during printing

The Snapmaker 2.0 A250 that I had ordered on November 30 arrived.
However, when I followed the steps below to print out the 3D printer, the heat bed plate and the output nozzle interfered with each other, damaging the nozzle and crushing the hole diameter, making it unusable.
In addition, the heat bed plate was badly damaged and I later found out that this problem had already been discussed on the internet.

I think it is the responsibility of the manufacturer to prevent such problems from occurring, not to avoid them with a single piece of paper announcing the problem at the time of shipment.

In addition, after updating the firmware, the enclosure selection buttons are no longer visible and cannot be operated from the touch screen.

I would like Snapmaker to send me replacement heat nozzles and betting plates, and I would like to see a resolution to the inability to operate the enclosure.

Why should the user be held responsible for any problems that occur as a result of the user assembling the package and following the instructions?

The manufacturer should be able to avoid the problem by putting in a notice about the problem before it is shipped, and the user is not responsible for not knowing about it without measures.

Please take immediate action.


  1. Turn on the power
  2. perform homing (the origin of each axis)
  3. perform automatic calibration
  4. load the model in Luban
  5. run it from the PC via USB cable or put the data on a USB memory stick
    Stick a USB memory stick into A250.
    6 The temperature of the nozzle and heat bed rises.
  6. Start printing
    Low Z-axis position immediately after the start, heat bed damage and heat nozzle breakage
    Two platform plates damaged and two nozzles broken

We have rechecked the instructions and parts in the package, the state of assembly and found no defects
At that point the solution to this problem will not be found.

Search on the net.
This issue (heatbet and nozzle interference issue) was announced in the firmware months ago.
Snapmaker is aware of the problem and could have announced the danger to new users at that time.

  1. Update firmware to the latest version
    9 The enclosure function button on the touch screen disappeared.
    It is no longer possible to control the LED lighting and duct fan on/off.

This information will be made public on the forum as well as in Snapmaker Support emails.

Thank you for your patience.

Translated with (free version)

I tried the latest version of the firmware, but the enclosure icon disappeared from the touchpad, and worst of all, the LED lights are unusable, and the duct fan can’t be turned off as soon as it’s powered up.

What have I done with the Snapmake A250 that I just bought and received!

Current firmware version is 1.10.1

Updated with the latest firmware Snapmaker2_V1.10.1.bin.

What on earth is going on with my A250?

If you have performed calibration and this occured afterwards, I would wonder if maybe the sensor distance sensor is bad?

It sounds like you are going to need to talk to support directly, which unfortunately is a timely process.

If you were using cura to slice and had it some of the machine parameters set incorrectly i could see something like this happening, but if you are slicing with luban that doesn’t make much sense.

What a pain in the butt.

You could order some MK6 nozzles (make sure they are 13mm long with m6 thread) .04 output for 1.75 filament in brass to swap the nozzle out (it just screws off the hotend, they cost very little) and you can order print stickers from snapmaker readily as well as some third party sites, but if the heated bed or the print bed it mounts to was damaged i think you are not going to be doing much printing, at least with the heated bed, without some rigging while you sort this out with support. Snapmaker will ultimately provide you replacement parts if the heated bed or plate is damaged, i am sure of it, but it takes a long time to get to that point…

Do yourself a favor, document and send as much information as you possibly can to support in ONE email, because it can take a couple weeks for them to get to your message and if you send multiple messages in between it always gets janked up in terms of communication between you and them.

Every back and forth you have is going to add a week or two to getting replacement parts.

If you decide to play around more while you sort that out, do the auto calibration again beforehand, and make sure to set your z-offset properly at the end. Bring the nozzle down to kiss the calibration card with a little resistance, and then back it off at least .05 mm (most people say .1mm but i personally have adhesion issues that far away)

Keep your finger on the power switch if you start printing again, because if the sensor is bad, it will probably happen again.


Matter of factly, if you send everything at once, include your backer number or order number and the address to send parts, maybe you’ll luck out and get it all taken care of in one swoop.

1 Like

Hi MooseJuice.
Thank you for answering my question.

I’d like to share some currently known information.

  1. The auto-calibration sensor in the 3D printer module seems to respond and not respond.
    Sometimes it responds when you put a metal plate close to it, and sometimes it doesn’t.

  2. Manual calibration is performed after automatic calibration, but when 3D printing output is performed after completion, it interferes with the platform plate on the heat bed and destroys the platform plate and nozzle.
    This time, I purchased one platform plate and five nozzles as an option, but both plates were damaged.
    The nozzle is the third one.

  3. I also have a Cura slicer, but this time I only used the Snapmaker Luban because I just assembled a Snapmaker 2.0 A250.
    I am experiencing this problem using the initial steps and initial settings described in the so-called manual and the designated stock slicer software.

  4. Yesterday, I checked for mistakes in parts assembly and there were no assembly errors.

  5. The enclosure icon on the touch panel is missing and cannot be operated, but after updating the data of the latest firmware version several times (which seems strange), the enclosure operation is now possible.

  6. The MK6 nozzles are listed as using other companies’ nozzles, but I prefer to use the genuine Snapmaker nozzles, so I won’t order them myself.

Q. I’m not sure I have a final solution, but am I correct in assuming that the two damaged platforms and three nozzles are warranted?

I’m going to see if I can do something about it from the information I’ve gleaned from the forum and this support email, or if I’m prepared to break it, so I don’t know the final damage and consequences.

I think that any problems that may occur now should be put in the package as a notice or alerted in the shipping email before the product is shipped.

I feel that this disastrous state of affairs that occurs after the product arrives and immediately after assembly can be avoided with a notice.
This would not cut down on support resources and would prevent the loss of replacements.

Make sure that future new users “look up” the “must do’s” that aren’t listed in the product manual before the user turns on the power switch, because that’s what I’m angry about.

I’m angry that such information is not shared with them when they open the package.
I don’t want to waste my time and watch my hard-earned Snapmaker components break.

In the meantime, I’ll report back to you in the meantime and ask for your help.

Translated with (free version)

----Japanese Language–




3.スライサーはCuraも持っていますが、今回はSnapmaker2.0 A250を組み立てたばかりなのでSnapmaker Lubanしか使用していません。











2020年12月3日(木) 1:03 Brian Sherba via Snapmaker where creation happens <>:

FYI - Snapmaker doesn’t sell nozzles by themselves, they only sell the hotend assembly.

Extruder Hot End Kit for Snapmaker 2.0

Any MK8 nozzle with m6 thread will work so long as it is 13mm long.

A perfectly acceptable part would be something like this: LUTER 20PCS 0.4mm 3D Printer Nozzles Extruder Nozzles for MK8 + 5 PCS Stainless Steel Nozzle Cleaning Needles for Makerbot Creality CR-10: Industrial & Scientific

I would say if your sensor does not always respond, it is likely faulty or misaligned and you should cease using the machine until support assists you, which unfortunately will take some time.

I would be shocked if snapmaker did not provide replacement damaged components.

I think in your particular case, the malfunctions you are coming across are not typical and that is why they are not pre-warned about.

In other words, while other people have had issues with nozzle dragging on the heatbed, I don’t think there have been additional instances of it being from the sensor.

However, there certainly are enough bits of information that are gathered through experience and this forum that they could stand to assemble a “must do” list as you described. I actually would like to create a list of my own!

I hope everything works out for you quickly.

You will need to contact and wait for their response. It may take a couple of weeks, so as I said provide as much information as you possibly can including the list of parts you feel should be replaced (perhaps the 3DP module itself, the print stickers, the hotend, the heated bed and build plate if applicable) your backer number/order number and address to prevent back-and-forth (increasing time to resolution)

Support will not provide resolution to you on the forums, it must be via e-mail.

Hi MooseJuice.
Thank you for answering my question.

I arranged to buy the nozzle from Alibaba Express (Aliexpress), as there are many products with vague nozzle dimensions on Amazon in Japan.

Later, after much research, it worked fine.


  1. The positional fixation of the sensor was loose.
    The position may have changed each time during the work.
    There is no accompanying manual, I re-set it from the forum information.

  2. Firmware was not properly updated?
    The problem was solved without knowing much about the lack of enclosure icons, etc.

  3. auto calibration does not seem to work when the table temperature is up.
    The height seems to vary from place to place.

As a result, I was able to build the model with normal operation by calibrating the sensor alignment and table temperature at room temperature.

On this subject, Snapmaker purchased the three damaged hot end nozzles at my expense, but will the two damaged platform plates be replaced and tampered with?

Please instruct us on the procedure for doing so.

Translated with (free version)

2020年12月4日(金) 0:11 Brian Sherba via Snapmaker where creation happens <>:


I do not work for Snapmaker. I was just trying to help you get your machine running.

You will need to e-mail for warranty discussions.

I am glad that you have made progress and I wish you the best.

Thank you MooseJuice.
I had a Snapmaker support misunderstanding in my email correspondence.

I have emailed Snapmaker support and they have asked me to give them a video of the homing.

I’ve told them that the sensor position is out of alignment and that it doesn’t make sense to make a video of it when it’s fixed and working properly, but they don’t listen to me.

They don’t understand what I’m reporting and say things like misconnected cables and that the sensor doesn’t work while printing, which is completely different.

I’m a little frustrated with the support response.

Translated with (free version)

Translation is difficult, some things don’t come out the way you want them to. Maybe you can ask if they have a technical support agent who speaks Japanese?

Its possible they want to make sure that the adjustment was done properly so I would go ahead and send the video they ask for.

In that email you should also do the following though:

Try to copy paste the hyperlink to this forum thread we are talking on: Snapmaker A250 3D printer breaks on contact with a heat bed during printing

Also maybe copy paste this line to them:

“After reading through many forum posts, I found instructions on how to correctly align my sensor, so the machine will now currently calibrate properly. However, the damage to my bed was done when the sensor was out of alignment and therefore I need a replacement”

Hi MooseJuice

It’s difficult to exchange information with translation software that doesn’t use correct English.
Since then, I’ve been in technical communication with the people at Snapmaker Support.

He understood what I was explaining, and we made a video to verify the operation and shared the information.

We discovered that the left and right sides of the linear rail were not synchronized, and shared this information with them.
It has been in the forum in the past that the left and right rail positions produce different results, but all of my five rails have variations and all combinations produce strange sounds and vibrations in the XYZ axis.

Additionally, I have found a strange behavioral phenomenon.

I have shared information about this with Snapmaker Support as well.

Translated with (free version)

I should preface my comments with the fact that I am not an expert on 3d printing, I just started playing with it about a month ago. It is very possible nothing I say is correct or accurate.

With that said, I believe that the touch screen is not intended to be a precise & reliable method for using the machine. I believe it would be considered relative position and rapid button presses probably mix it up a little bit.

I often try to move my print head over when cleaning the linear modules and it never really likes to go more than one press at a time.

I think that in g-code you should not see these types of positioning commands not being followed, as gcode is absolute and directly controlling the modules.

With that said there is always room for improvement, and I think that its fair to say the firmware could use some more love. As could Luban. I don’t even imagine they considered the button press lag a bug to worry about at all. It’s up to us, the community, to point these things out to them, so thank you for your work!

They are working on improving things, and it is frustrating when we have issues, but at least they are standing behind their product and trying to make it better.

Regarding your linear rail issue, I have heard about rails being out of sync before, but all five of them are different? That is wild!

I am very curious how the end result will be from this whole thing.

I am glad you are making some progress with support. Thank you for following up on your situation!

Please keep us posted!

Yes, it may not be a good idea to give movement instructions for each axis of the touch panel over and over again.

However, it is human beings who operate the touch panel, and not all of them operate it according to a set of rules.

I am currently in contact with Snapmaker Support because there is a gap between the instructions on the touch screen and the actual movement of the axes, and I am wondering if I need to do the following I’m suggesting the following

One click on the touch screen axis movement instruction = actual movement time (actual distance traveled) + "break time

This means a mechanism that cannot be pressed repeatedly and a break time for safety.

As you can see from the video, the linear rail will break if it gets into this situation.

What will happen if the system is operated automatically without noticing this trouble that occurred manually?

The control board of the linear rail will be destroyed and a fire may occur.
(Since there seems to be no load control.)

The shaft of the linear rail may be damaged.

Before that, we won’t be able to form it properly…

If it happens in the Z axis…

Many people should verify the same thing.
If many people are able to reproduce the same problem, I think we should deal with it as soon as possible.

This will increase the credibility of Snapmaker.

Translated with (free version)

I forgot to write this.
All 5 modules cannot be synchronized?
Yes, all five linear rails are out of sync.
If you assemble two modules in a combination that minimizes the difference, you will get noise and vibration.

Here is a video with the differences

In this video, at 3.20, you press home. The we hear axis move, then we see the y axis move, then you wait a bit and we hear something else move.

What moves after the y? When I press home the y axis is the last to move.

EDIT: Oh, I see, you clicked home twice.

This is interesting because the rails are not aligned at their endstops even when powered off. I don’t think this is a case of the normal ‘different pitch in lead screw’

The reason I homed twice in the video was because I was operating the camera with my left hand and the touch panel with my right, so I accidentally pressed the homing button.

Did anyone else notice this in the video animation?
The width is shifted when you slide to the edge to begin with, so it’s shifted and shifted as it should be.

There is a microswitch inside the module, it could be that one is adjusted a bit further out than the other.

I wouldn’t recommend fiddling with it without support’s blessing though.