Snapmaker 2 A250 Stops randomly during print

I’ve gotten around to doing more tests on the machine and now it seems to be getting some of the base layers down properly but it stops randomly during the print. It stops at 6%, 8%, 14% or 20%. It’s completely random and just all of a sudden stops printing and goes to its home position for no reason.

There’s not error message that shows up or anything. It shows the temperatures cooling down as it’s going back to its home position and the only options available are the “pause” and “stop” functions. Either one of those does nothing. I can turn the printer off but when it comes back on there’s no “recover” mode or anything. I just lose the print.

I’ve tried 15 times and it always does this at a random percentage of the print. I’ve tried through a WiFi connection, through a USB stick and through the direct connection with my PC. It’s the same thing on all of the different connection issues.

Here’s a link to a video showing it. You can see it happening at the end of the video.

Try to generate export log file and upload it here if you can

Here are the logs:

The current temperature of the hotend dropped abruptly. Did the value of the temp drop when it froze?

The last try I did it didn’t even start the print but just prepped for it and the temperature of the nozzle went to 309 degrees for some reason even though it’s programmed for 205. It just lifted from the start position where it’s supposed to wait to heat up and when it reached the bed temp of 70 but also nozzle temp of 309 at the same time, it lifted higher and stopped there with a burnt plastic smell.

When it rose and froze there, the temperature started dropping after that but not before. It was the same thing in previous tests as well. The temperature was fine during printing and then when it would stop and home just like in the video, then the temperature would start to drop but not before.

Hello, I have the same problem. The head temperature and the bed temperature are ok . the printer head stops and I have no possibility to reset of to move. Either I don’t know to repare.
Greetings Christoph

Export the logs and post it here @Bombastino

The processing bar on the touchscreen is not 100%, but there is a sign of ‘complete’? And the temperature values of the nozzle and heated bed are remains ok. If the issue is like this, I think this is because the touchscreen failed to read the file.

Please format the USB disk to FAT32 and try to download just one file in it. Or you can change a USB disk.

Here is an image for your reference.

Edwin, I had this issue on Filament runout this morning…asked for more filament, installed it, went to restart but the handset app crashed and wouldn’t read the USB to continue printing. The head went down to the last spot then it went home and the screen said “complete” with 35% on the screen.

When I cleared the bed and went to restart everytime I tried to read the USB it would crash the App, it wasn’t until I unplugged and put the USB back in that the App wouldn’t crash and would read the USB…this is also the same USB provided when my machine came in.

I have a feeling that the USB is causing the software/app to crash, maybe its loosing communication.

I just had this same error at 76 hours in (36%). Bit sad about that one. Was printing beautifully then… nothing. I turned off and on said power outage would I like to resume? I said yes!! Then it went back to home and crushed the print onto the print bed…

Will flashing the machine work or did you try all this? I am still impressed with the machine and understand (due to computer background and job) that errors do occur.

What is the fix? And does SnapMaker protect its customer and help in this regard?

Snapmaker support is not super awesome by any means but they do a pretty good job, and their response rate has improved a lot in recent history

If nobody on the forum has any suggestions, I would say to

a.) make sure your firmware is up to date (or at least 1.9 as its the most stable from what is being said)
b.) send the print file to the machine over usb or wifi, but don’t run the job from luban. run it on the snapmaker itself
c.) email if you have any damaged components explaining the scenario and or ask them for what they think about this issue - and if you do please update us to the results.

someone else mentioned recently a paused job crashed for them when resuming on the cnc module. snapmaker needs to be aware this is happening to work on a fix, and while they do have a bit of presence on the forums, they probably wont notice.

1 Like

The same Happened to me with A150! Even when i run the print from SM2.0 on the USB. I Hope it’s just the Drive and not a processing issue in the touchscreen.

I suddenly am having this issue as well. I successfully have printed two things. Now it prints a few layers then just stops and goes to the home position. The first time, it pushed the printhead into the magnetic base and burned a little hole. I have the most current firmware, the machine is brand new! Being new to this, what should I be looking for? I’ve tried running it from USB, transfer over WiFi and the same thing happens.

Are you executing from the touchscreen or luban via usb

if luban via usb, if i had to fathom a guess, id say the filament runout switch isnt making a good contact and if the touch screen is not in charge it tends to just go home if it runs out as far as i know.

Has anyone made any progress on this problem? I got in contact with support and the person I got thinks it is the cables… So they are shipping me replacement cables. I have been moving the cables around while printing and there has been no effect. I do not believe that its fully a cable problem. Seems more software then anything.

it doesnt seem to be a particularly common issue so i dont think software is to blame, unless you are printing from luban instead of via the touch screen.

The reason for this topic is various. I found that one of my colleague likes to use cable ties to tie the cables together. When the machine is working and the printing module is moving, the movement can lead to poor terminal connection.
With the command “M2000 S0”, we found that the executor was lost during the printing process.

The machine works well after we plug the tool head cable correct and untie the cables.

1 Like

I left the files on the machine. I had transferred the latest from Luban via WiFi. I recalibrated/leveled the bed and then pulled the bulk of the filament the printed needed into the enclosure. It successfully completed the print. I’m now thinking that the tension on the filament while trying to pull into the enclosure is too great. I’ve tried orienting the spool on the holder every way possible, but still had the same results.

I am (at time of this response) printing a benchy with a different spool of filament and pulling excess into the enclosure and it’s going well. This is the exact same file load that failed before at 2%.

I havent done my enclosure yet, but i plan to keep the spool exterior actually likely in a drybox with teflon tube feeding down to it,

on a nice axle for little resistance

sorry i cant offer suggestions on a solution at this time.

without enclosure, i found the default spool mounting to be bad and downloaded a couple things to print to make it easier.

I have a same problem (((