Snapmaker A250 freezes at 1%

So for the past few weeks my snapmaker has been working wonderfully but now I tried to print a badge that I had previously printed twice before and it Freezes at 1%. The printer module raises up and the print bed slides out but the touchscreen continues to run as if the print is still going. Once you manually hit “stop” button the touchscreen freezes up as well and you have to turn the machine off and back on. Can anyone help with this problem? I have attached a link to video of the snapmaker after freezing.

Snapmaker Freeze

Hi! Welcome to the forums.

Could you post the gcode. I’m guessing right after the home command (G28) there’s an M109 and M190 that waits for temp. I’m wondering if it’s waiting forever for something.

As far as not being able to cancel, all the touchscreen can do is politely request the main controller stop. In an M109 and M190 wait, the main controller is completely unresponsive, the only options are a power cycle or wait for it to finish whatever it’s doing.

1 Like

Not sure how to post Gcode. I tried uploading the stl file but forum won’t allow me. Also the temp drops once the Snapmaker freezes While it was printing the nozzle was 230 and the bed was 60.

I’m encountering same problem.
My printer is A350.
While waiting temp goes up,suddenly Y axis starts to go up and destination temp becomes 0 and freeze.
On another gcode, several times freezed like this. After that it started, but it seemed to stop after 1 hour.

Please export the log files from the touchscreen and send me the file you failed to print.

Tell the time when this issue happens as well.

Email us at and you can get further help. The result will be posted here as well.