Random HELP - Ask here!

I’m having no luck in determining if I can use the Snapmaker 2.0 CNC router to route a piece of wood about 16" x 6" by 2" high. Something like a sign, where I only route half of the 16" dimension. The 16" dimension would extend beyond the bed of the Snapmaker, but the area that I would be routing would fall inside of the bed. In the videos I’ve seen, this seems like an option, just trying to confirm.

Also, are there any operating environment concerns to be aware of? My garage workshop gets well below freezing; can the Snapmaker tolerate the temperature changes?

Thanks for your assistance!

  • Karl

I just cannot print!
I’ve got SnapMakerjs 2.7.1 and have down loaded a file to print an “A”.
I’ve created a G code and my Mac is connected to my 3D 3in1.
The nozzle is at 200c and the bed at 50c.
What am I doing wrong??

With the A350 it shouldn’t be a problem to mill a piece of such size. the 16" side would stand out (best would be both ends) of the Y axis of the printer. with 6" wiede it shouldn’t be a problem to fix the piece to the wasteboard with the clamps.

For the temperature I’m not sure. I think the electronics can handle the temperatures (maybe ask the support for a that), but I would be more concerned about the dew point. (getting condensate in the electronics). For 3D printing you might also run into some troubles with such a low room temperature, but an heated enclosure might help you there.

Did you try to export the gcode and print it via the flash drive?

woo hoo - that worked! thank you SchnabsiX

1 Like

I haven’t used my snapmaker original for months. I wanted to laser engrave something today. The problem is that the laser isn’t turning on when it is supposed to. When I use jog mode on the front panel the laser goes on. When I get out of jog mode and click the button to turn on the laser it does not turn on. Also, when I run the gcode to engrave, the GUI shows the laser being activated, but the laser never goes on. What might I be doing wrong?

what are your settings in SnapmakerJS or Luban?

SnapmakerJS. Defaults. No change. Same as I used before. I am using the built-in text capability.

Are you hooked up to the computer?

yes, I am hooked up to the computer when I test this.

Hey, in my case you have to start the beam under the terminal before engraving/sending the gcode.
Hope this helps

Thanks for the suggestion, but that doesn’t help. I tried it again just now.

The GUI is showing the laser turning on and off properly as it runs its pattern. However, the actual beam never turns on.

I will try after my actual print in about 7h

This appears to be my issue.

I’ve requested instructions to run a diagnostic on ports 4 and 5.

1 Like

@tinjaw Sorry for that.
I remembered some problems i had, but with the latest version of snapmakerjs or Luban they disappear.
If i hit the “Power ON” Button, the light goes on.
If i send a gcode, the light goes on.
Sorry again.

New here and having some trouble. Help is appreciated.

  1. Trying to update firmware on SM2.0 A350. Downloaded file, copied to USB, inserted USB. No file shows up in the files app when I press the USB on the touch screen. Tried 3 different USB sticks.

  2. It seems crazy but I cannot figure out how to make a new post to this forum. I did htis as a reply but cannot seem to initiate anything.


1 Like

Hey @michaelelandry, have you exported the .bin to your drive with NO directory?
Here is the update video of sm original, i think the process is similar?

You have to look a bit around in the forum, there is a thread with defective cables, usb stick formatted to exfat or fat32 (instead of NTFS)
I have no SM2.0 yet, so sorry to could not give more advice.
Hope this helps.


Thanks. I got this figured out by using the UDB stick that came wth the machine. All other USB sticks I had did not work. Very strange. I placed the .bin file in the root directory.


I have met this issue before and that is very strange, and Snapmaker machine supports the FAT32. We cannot tell the difference between the USB disks now, but this issue still exists. We will pay attention to this issue. Have you formatted the other USB disk and just transfer the .bin file there and check again?


No USB stick that I have will work except the one provided. I’ve tried several different formats and reformatting.

I am also getting some USB errors. Every time I take the snapmaker USB stick to my computer, Wondows says there is an error with the USB drive that needs to be repaired. It seems to repair fine and then I cna load my g-code to it and print. However, the next time I do this, Windows tells me there is anothe error that needs to be repaired.

1 Like