Luban V4.9.0 Known Issues & Solutions

Hi Makers,

We’re collecting the issues you’ve encountered when using Luban V4.9.0 and trying to solve them asap. Please record the problems in this topic and I will sort them out and update the corresponding solutions (once we figure it out) in the main post. Also, you can search for similar issues and solutions in this thread first if you have problems with Luban V4.9.0.

Appreciate any feedback!

v4.9.1 Latest

Sep 27, 2023, v4.9.1

Note: Since this version of Luban fully supports inline mode on the laser, this requires SM 2.0 and Artisan to upgrade their firmware to the latest.

Bug Fixes

  • Fixed point engraving mode use of M4
  • Fixed wrong G-code flavor used in vector point engraving mode (for SM 2.0 and Snapmaker Artisan)
  • Fixed connection issue of Snapmaker Original
  • Fixed console does not reply “ok” when executing G-code


Last week, we released the Luban V4.9.0 software update, which includes significant enhancements to the laser vector feature. Check out the changelog here:

However, it is important to note that this feature requires the latest firmware version to function properly. Unfortunately, the current version of Luban does not support automatic detection and notification of firmware updates. As a result, some users may not be aware of the need to update their firmware to the latest version, leading to issues when using the laser function, such as inline function problems and unintended laser activation during the laser toolhead traveling (for Snapmaker 2.0 machines).

Please take note of the following:

  1. Ensure that Snapmaker 2.0/Artisan machines have been updated to the latest firmware version.

  2. We have received user feedback regarding the following issues, which have already been addressed: Artisan: occasional issues with vector engraving not producing laser output. Please update to the latest version v2.5.17_20230925.

  3. We are currently investigating the following reported issues. If you encounter any of these problems, please submit a support ticket as soon as possible. We will provide updates on the troubleshooting results in the community: Snapmaker 2.0: abnormal dot mode.

  4. Other known issues: For Snapmaker 2.0 with the Dual Extrusion 3D Printing Module, temperature control through Luban is only supported for the currently active extruder. To adjust the extruder temperature through Luban, please activate the corresponding extruder first.

We apologize for any inconvenience caused by these issues and appreciate your patience and understanding. Our team is working diligently to address all reported problems and provide the necessary solutions. If you have any questions or require further assistance, please don’t hesitate to reach out to our support team: Support Ticket Form


Thanks for the effort!
My issue: Console GCode commands do not echo output via network (did not try serial yet). Not even the “ok”.


Thanks Jade.

Just been playing. A350 is not outputting laser either. Process:

  1. Updated to 4.9.0 - Laser output not working via Workspace (not tested running locally on machine)
  2. Updated to latest firmware - Still no laser output
  3. Downgraded back to 4.8.2 - Laser output back to normal

Can manually control and turn on laser via workspace - just does not work during jobs.

1 Like

A350 The laser turns on while setting the origin and then does not turn on to cut.

1 Like

Seems a common issue!

In case you didn’t see - if needed you can downgrade to 4.8.2 to resolve for now:

I upgraded to 4.9.0 this morning and tried connecting to my Snapmaker Original via Serial.
After clicking connect I got the error message “The machine is not ready” and the connect button stayed disabled showing the loading circle.
I tried this a couple of times and even restarted my PC but to no avail.
I then downgraded to 4.8.2 and was able to connect again.

My setup in this case:

  • Snapmaker Original with 1.6W Laser module
  • USB for Serial connection
  • PC running Windows 11

Update to V4.9.0 this morning from 4.8.2.
No connection possible to Arisan (Laser) via W-Lan (see comment of @razorblade ).
Firmware update on Artisan, still not possible.
G-Code per USB to Artisan → Laser will keep running also when Enclosure is opened.
Traval speed of toolhead is significantly slower then normal.
Set back Luban and Firmware to old versions → works normal

Hi Jade,
I started after the update to recalibrate the dual extruder. I can go through the leveling and then the z offset calibration. But when i start the xy calibration print it starts with the first extruder. But when it switches to the second one, it starts the purge line and during that it will rise to about a cm above the bed and keeps printing too high from the bed.

Looking forward to hearing that all has been sorted so that maybe I can start to use my machine again once the quick release is here. Hopefully the software team is working all out to resolve the situation.

I have a Snapmaker 2.0 - 350 running 4.9.0 and the firmware is 1.17.17, with quick swap: The Laser 10W is not working. Please fix!!

Updatet Artisan to v2.5.17_20230925. Laser works so far, but new errors are:

  • Travel moves are now very slow. Jog Speed in Luban is set to 6000mm/min.
  • Laser turns on even when the door is open (while setting the work origin)

Thanks for reporting this issue. We will fix it in the next version of Luban.

1 Like

@REdS @Savoie Thanks for reporting the issues. It seems that these issues are firmware issues related. Please provide more info to our support team so that we can help you troubleshoot the problems. Submit a ticket here: Support Ticket Form

1 Like

Thanks for the efforts! Actually, i’m experience a quite creative way of translation in Luban as not all things should be translated when switching the language from English to German - is there a way to contribute on the translation process?


Little update, after fully resetting the machine also the second extruder is correct ( almost)
the almost is that since i have it it’s z height is always 0,15 higher than the first extruder.
So i set this in the print parameters, but is there any option to calibrate the z for both extruders better.
Or recalibrate the calibration as i mean.

People, Luban 4.9.1 is available. Check it out.

1 Like

Interesting… Let’s see how that goes. In the new version of Luban, instead of actually inputting a power control when the laser should be off, they’re now using G0 movement commands. Assuming the machine knows to turn the laser off on G0 moves instead of just leaving it at whatever it was at. I can’t wait to see the results.

For reference; this is a 10x10 square at 0,0 just as an engrave.

4.9.0 (and how GRBL would look, and indeed how the gcode that works on my machine looks);

G1 X0.00 Y10.00 S0 (Power off by S0)
G1 X10.00 S255 (power on max by S255)
G1 Y0.00
G1 X0.00
G1 Y10.00
G1 X5.00 Y5.00 S0 (S0 turns laser off before returning to the middle, still in G1)
M5 S0

4.9.1 (Should :tm: be proper Marlin inline?);

G0 X0.00 Y10.00 (Power off by G0)
G1 X10.00 S255 (Power on max by S255)
G1 Y0.00
G1 X0.00
G1 Y10.00
G0 X5.00 Y5.00 (no power setting, just a G0)
M5 S0

So… what happens if someone adjusts the power during a G0 movement? Is it now set with two different power levels like feedrate? Also note the M5 S0… the S0 here is useless, as M5 is just off, period. It does not accept options. Another note is by the Marlin documentation, when turning the laser on for the first time, it should use M3 S0 I wherein the I dictates inline mode on. Luban simply outputs M3 S0. Which is fine if you’re turning the laser off with S0. Maybe I’m just rambling though and over analyzing the gcode. :upside_down_face:

Feedrate is set different like this before the job begins;

G0 F3000 (non-cut moves)
G1 F800 (cut moves)

Wonder if adding M3 S# on the G0 line would make all non-cut moves turn on at that specific power. :thinking:


I don’t think you over analyzing the g-code at all. I really appreciate you taking time for this tho, it makes me think harder then I otherwise would’ve. Thanks lol
Question - do you have a feeling that there might be a confusion on the devs side - since they’ve altered the g-code from what Marlin used to be, and there is no good reference anymore - they just don’t know what to rely on?

I’m adding example from Lightburn - COnfig by @Skreelink

M3 ; laser on
G1 Y10 S229.5 F6000 ;90% power full speed 
G1 X10
G1 Y0
G1 X0
M5        ; laser off
G1 S0   ; not sure why but it dials down power again. Safety I guess?

Why Luban 4.9.1 does M5 S0 when M5 already means - Laser OFF…


Yeah, I really appreciate this sort of insight and analysis too. I love code in general, but surprisingly haven’t spent much time analyzing gcode beyond minor alterations (YET). So this was a good read, and peaked my interested. We’ll be burning tonight, so I’ll see how things go in 4.9.1

1 Like