Luban 4.4.0 not connecting

As of updating to 4.4.0 I can no longer connect to the SM2.0 A350. It says its already connected to another machine… i Only have 1 printer. And it never shows that a connect was attempted.

It does see the printer on the wifi list to choose what to connect to.

the Exact error is: Error Connection failed.The machine has been connected to other device.


I’ve exactly the same problem!!! I don’t get any other connection choices but it sees the A350 momentarily but then, when you try to connect, I get the same message as you.

Anyone got any ideas??

1 Like

Same issue here, at first i was getting a connection error then I get this error:

“Connection failed. The machine has been connected to other device.”

The connection issues with this machine are starting to mount up and it’s wasting a significant amount of time trying to solve these connection problems…

Has anyone figured this issue out yet?

same problem, connected twice now all i get is the same error message

Any clue as to how to fix the problem? It is doing the same thing for my sister.

I have the same issue. Now the only way I can send to the printer is with a direct connection.

Same problem here. Can we get the old software back?

Previous versions of Luban are available on the github. Maybe try downloading 4.3.2 and seeing if this fixes the issue?

Link: Release v4.3.2 · Snapmaker/Luban (

I received a response from SnapMaker.

"Resetting the touchscreen will resolve this problem.

To reset the touchscreen.
Please refer to the steps in the following link to reset the touchscreen.
Notion – The all-in-one workspace for your notes, tasks, wikis, and databases."

I will try this tonight.

1 Like

I’ve tried to everything the Support team suggested. Reset defaults and uploaded latest BIN files etc… on the controller and touchscreen via USB cable. Reinstall latest s/w. Double checked wifi addresses. Controller and touchscreen say it is connected to wifi. When I try to get PC to upload a file, however, non connection… Machine connected to other device. THERE IS NO OTHER DEVICE.


I also just updated from v4.2.2 to v4.4.0 by downloading it directly from the website. It wouldn’t update from the app itself even though it could check to see that there was an update. Now I have the same problem. Nothing I try is working. My snapmaker can’t connect to my computer via wifi. I hate this. The software is totally clumsy and non-intuitive and the product support is really lacking.

I have been unsuccessful printing anything, but do manage to connect. I tried a different workflow and attempted to connect without loading any files, and upon success I started working within the web viewer. I was able to load files from there.

Clunky as all hell, but I have a small test print working now. Had to recalibrate my bed as well. If it keeps me running until the Support un-buggers the software, I’ll take it.

Hope this helps someone.

Since I posted, I thought I would follow up.
The print and another have been successful without issue by going through the webviewer. The gui has a little difference than the client gui, but it’s usable.

Hope this helps someone.

Has anyone received a solution for this problem? I set up my SM2.0 250 yesterday, and it worked great and today, I am having this connection issue. I only have one SM and Luban 4.4.0 is only on my laptop.

1 Like

I have the same problem when upgrade to V4.4. It worked normally until I turned off the Printer and started a day later. After trying different ways, even resetting the Printer to factory, nothing works.
So, I decided to try with another Laptop and install a Luban, and It works this time. However, when I turn off the Printer again, the error reappears.
This time, I uninstall and reinstall Snapmaker-luban (both with V4.4 and V4.3.2), but still have the error.

Finally I found the way to fix it:

  • For Linux user, delete the folder: ~/.config/snapmaker-luban, then restart Snapmaker-luban.
  • For Window 10 user, delete the folder: C:/User/your_username/AppData/Roaming/snapmaker-luban then restart Snapmaker-luban.

Maybe delete the whole folder is not neccessary and finding the exact file to delete is better way, but this is the quick and easy fix. Hope this help.


I am continuously dealing with this issue, on both Windows and Mac. Please fix this Snapmaker. It’s an unacceptable bug.

1 Like

For Window, did you delete the folder:
For example, mine is:
Then open Snapmaker again. It works all the time for me.
Yes, this bug is super annoying.

Did not allow me to go into developer mode with the 5 taps and OK. Printer still bricked.

The same with me too. Exactly the same situation after a restart comes the same message and I can no longer print. Is there a trick on Mac’s?