"Snapmaker doesnt recognise your connected device"

I am surprised I am the first to report this. Brand new A350 all set up to work no problems. First project vector file sorted then suddenly cannot send it from my Mac to the Snapmaker. The MAc just can’t connect to it. There is no wifi button, just the above message (doesnt recognise your device…). Have reset everything, wifi connections to both machines work just fine, all on same network but Luban just doesnt find the printer.

Please help !! All I have managed so far is to laser cut the test box. I would like to achieve more !!


Are you connected via USB? If so, did you install the serial driver? snapmaker

No, never used USB. Just originally connected by wifi. That link/connection disappeared halfway through working on my first image conversion in Luban

You’ve tried refreshing the connection?

Share a screen grab of what Luban is showing you.


There is no connect to wifi option appearing anywhere in Luban

I have reinstalled it in case and it is the same

Try clicking on the little arrow to open up the window with the refresh and connection choices:
Screen Shot 2021-05-17 at 2.01.23 PM



WTF !!! That helped !! nicely hidden lol…thank you…I will try again tomorrow morning. Very grateful

1 Like

It seems that we need to optimize the user guide on Snapamker Luban software.

Sorry for the inconvenience.


Problem solved - it was as simple as being unaware that the little arrow on the left column of the screen opens up the wifi connection controls. !!! Thank you everyone, especially sdj544 for your help. I give it at least 10 minutes before I do something else wrong!!

1 Like