Wifi Connection Problems

so since a few days my A350 won’t connect via wifi and I even can not use the cura/snapmaker plugin for data transfer without Luban. when I want to connect Luban says it does not recognize the machine and then I have to select what I have but nothing happens does someone know what’s going on? Luban and the A350 software is up to date!

I know some people have reported connection problems with the new firmware.
I don’t have the new rotary module so I haven’t bothered to upgrade. Especially since new firmware always seems to break as many things as it fixes.
I did have problems with connecting last week though and rebooting my router fixed it.


1 Like

I dont have the rotary modul ether but the patch notes listed fixed and improved wifi connection thats the reason i updated

I have forwarded this issue to our software developer @Alan , will update the solutions here.

Sorry for the inconvenience.


1 Like

We need more information from you.

  • Can you start a print or control Snapmaker machine via the touchscreen?
  • Send me a screenshot of Luban when it shows the machine is not recognized. A photo of the touchscreen is also needed.
  • Can you connect the machine via the USB cable and control the machine?
  • Record your steps to connect the machine via WiFi so that we can reproduce it at our end.
  • You can export the log files from the touchscreen and send them to me for further analysis. Here is an image for your reference.

Looking forward to your reply.

i Exported the log.
but now the error doesn’t appear anymore. My router rebooted this morning and now it works again.

That’s fine. Thank you for your feedback.


1 Like

Some cases were reported that the machine cannot connect to Wi-Fi automatically after you reboot the machine.

Our software team has developed a beta version to improve the wifi connection.

Users who want to try this version, please send me some feedback.

Download link:


1 Like