Laser Module - Not Detected past firmware 9.0


I’ve had my Snapmaker 2.0 A350 for about 45 days, and have 3D printed a TON of things! I feel that I’ve gotten the “knack” for the print, and love the design of the snapmaker extruder compared to some others I’ve used/seen.

Finally being comfortable, I decided to switch to the laser module to try some cutting. “Toolhead not detected” errors began. I swapped the toolhead cable end-to-end, no dice. I swapped out the cable with the Z, the Y, etc. No dice. For giggles, I plugged the laser module into the X axis port on the controller, and we had light from the module! But, no dice when plugged into the toolhead port.

I swapped the laser module for the CNC module, and it recognized that, no problem. 3D printer module still gets recognized. The only thing I could come up with, is that I had upgraded to firmware 13.1 from whatever it shipped with, without having first gone through set up on all 3 modules. So, downgraded to 11.4, and still no laser module. Downgraded FURTHER to 9.0, and bam! Laser module works.

I calibrated ALL 3 modules, and upgraded to 12.0. 3D, CNC worked just fine (after “upgrading” the module firmware to 12.0 from USB). Laser module plugged in, I got the error that it was outdated, so I ran the firmware upgrade to 12.0 (again from USB), and then…nothing. No laser module again.

Thoughts? I mean, I can run 9.0 well enough, just wondering what happens when I go back to 3D printing and have mesh issues again! /cries

You need to contact Support for your issue. This is just the community forums.

I guess your laser head did not update well, have a look at this:

Thanks @xchrisd - I’ll give that a go again. I stepped from 13 down to 11, then up to 12, and then back down to 9 (relative firmware versions). Only the 9 recognized the Laser. When I went from 9 - 12, I followed those instructions and swapped out tool heads. I got the notice of the outdated firmware, and after it cycled through the laser tool head again, it wouldn’t recognize it. I’m guessing somewhere it’s just not pushing the laser module update, but…absent running it again and again, I’m just at a loss. I’ll report back once this print is finished!

If it still doesn’t work I would suggest contacting support. refer to this thread and detail the steps you’ve already undertaken so they have as much information as possible to speed up the process.

Looks like we’re on to support. I tried going from 9.0 to 12.0. I got the firmware out of date message, updated from USB, and the laser disappeared. I updated the other 2 toolheads, no problem. Went to 13.1, and the laser was still out of date, but wouldn’t update. Back to 9.0, and it’s working again, so…not sure.

Thank you all for the help! If we find a solution, I’ll update!