Horrible grinding noise on Y Axis after new LM Install

I just got the brand new quieter linear modules installed. First time went to calibrate the machine and got a really horrible grinding sound on the Y axis. Its like it doesnt know where the end-travel is. Video link below. Is this a support issue? Have I already damaged the linear module?

Yes. Probably haven’t damaged the module.

Thanks I opened a ticket. When jogging any of the modules by 10mm its actually moving about 35mm. This is not just true for Y, but for any of the axes.

I tried manually re-applying the fw update via USB and it had no effect. Is there a way to force a fw update of the linear modules?

Maybe the controller hasn’t detected the new LMs?

Have you checked that the right modules are in the right place? And that the cabling is correct right the way through?

Yes double and triple checked. 20mm lead is Y and X axis (bed and toolhead). 8mm lead is Z axis (up from table).

You can check in Luban that the modules have been recognised by the controller.

Connect via USB and issue M92 in the console and the steps should be 160 for X and Y and 400 for Z

The original linear modules will show 400 for each of the modules.


Check your cables !
I have had exactly the same terrible sound after upgrading the firmware. However after quite some tests with support, it turned out that one of my cables was defect. After replacing the cable everything was fine again.

Okay I think the issue is that I have calibrated my extruder and that overrides whatever values are auto-detected for the linear modules. Output from M92:

echo: M92 X400.00 Y400.00 Z400.00 B888.89 E222.42

The E value is one that I have customized based on testing. So I guess it should be

echo: M92 X160.00 Y160.00 Z400.00 B888.89 E222.42

What is the B value for?

@scyto lmao come in here


1 Like

Rotary module (Botary module? Bed Rotation?, don’t know where the B comes from, but it’s for the rotary module)

A is a rotary axis around X, B is a rotary axis around Y

1 Like

Thanks brent. You’re always a wealth of knowledge here.

M502/M500 then a reboot seems to have fixed the jogging issue. Waiting for bed to heat to try a calibration now.

During the first calibration attempt the print head went deep into the bed. Hoping the toolhead wasnt damaged!

1 Like

I forgot they have not released a new firmware bundle since fixing the issue scyto originally reported. It was so long ago that I thought your symptoms were something else :roll_eyes:

Glad that was an easy fix.

Good luck on the next thing.

Looks like you have the answer, B axis on the rotary module, seems to be present even when the module is not installed. Incidentally, I don’t send the whole line to M92 e.g.
M92 E266.07

Hello same problem support had to replace my Y axis modules two times to get it right. Works fine now.
Unfortunately parts have to come from China.
I have about 150 hours on my 350 now no more issues.

@eacmen I had the same issue, below are the videos to prove it. I opened a ticket with support and after a couple days of back and forth I got to the root of the issue:

When you upgrade to the new linear modules, the modules apparently default to inches rather than
metric. Here’s a link to a PDF printing my support ticket, while I expect the back & forth will equally frustrate you, the top/most recent directions solve the problem and I have now been 3D printing and using my 10W laser without issue. The new linear modules perform 10x better for me (quieter, more exact, easier to calibrate, better print outcomes):

Solution: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Details Attached to support ticket:

Does anyone have the instructions? I just got my upgraded rails and this seems to be the issue I am having after upgrade. Looks like the one drive file that explained the solution of switching from inches to metric is missing.


@WareWolf are you referring to my links above to OneDrive from my post on Feb. 11? I just tried the links again and confirmed they are working, so let me know if you have trouble accessing.

To give more specific directions, attached is a MS Word doc of my Zendesk ticket with support which explain step-by-step instructions. The forum does not allow me to upload PDFs so I had to convert from Adobe to MS Word and some of the formatting may be off, but the instructions are on the first page and the ticket reads backwards (last page was my original request to Snapmaker).

Zendesk ID 102459.Linear Modules making Horrible Noise.docx (30.2 KB)

Let me know if you have any issues or trouble accessing.

1 Like

It allows zip files, FYI

1 Like

Just an FYI the new firmware does not seem to address this issue still. Thank you all for having this thread, it took me a while to find it though.