Firmware won't update

I have had my SM 2.0 A350T for over two years without any major issues, while attempting to perform the latest firmware update, I make it to where I’m supposed to download the firmware and it does not highlight the download button and will not respond to my touch.
https://1drv.ms/f/s!AoL6UdkmmJ0fg49ux73crnGLrRzz6g?e=IB3Q5H

u

1 Like

Had the same - no idea why, most likely a botched download link or so. Just did the update via USB stick, no bother.

Just tested, had to download the firmware and update via USB as well like @Hauke.

Free up space on your drive or use the usb.

I think that version starts the ‘auto delete files for updates’ so it doesn’t confuse you.

That i certainly not the root cause here - I’ve plenty of space (Gigabytes!) free on my touchscreen device.

I had same issue but I used a different method to transfer the firmware. I dloaded the file from snapmaker page, then imported into Luban workspace. Connected to my a350 and sent it like it was a gcode. On A350 using touch screen I swiped to the left opened files folder and selected the firmware .bin file and A350 updated firmware.

Maybe someone can tell me if that help/firmware tool in Luban is still relevant. I used it first to process the firmware file and the file it created crashed the machine when I ran it. Maybe it used to serve a function but if not needed now they should remove it. Glad I didnt brick my machine.

Has anyone found the fix for this problem. I have an A350 and an A250 and neither will download new firmware.

Using the USB method did the job but I would like to regain the convinience of direct download.

Hi,
Is there any update on this issue?
I’m facing the same and wonder if it will be solved at a time.
Thanks

Same issue for me - but I get it… SnapMaker is a new company, this might be the first firmware update they’ve ever released! I’m sure they’ll probably do better testing on the simple things like “can the firmware even be updated” in the next firmware update. :roll_eyes:

@hipcheck’s suggestion actually works pretty well… Connect to the SnapMaker in the WorkSpace and then click + G-code Files and change filetype to any * to be able to select the .bin file. It will ask if you want to start the job and show you what a firmware update looks like when translated into toolhead movements :astonished: but you can just click cancel and then Send to Device to send it, after which you can go over to your device and find the bin file in “Files” to start the update.

There, now you don’t have to go find a thumb drive.

1 Like

Hi Pete,
Can you please send the link to the relevant .bin file?
Going thru Github folders but not finding…
Thxs

The newest version is always in this thread: Snapmaker 2.0 Firmware Updates and Downloads

1 Like