Filament reload... Wait, it's not out of filament

When the filament error occurs and i do the M119 i get the result “open” in all answers.

(including FILAMENT: OPEN)

Yes. That means the sensor has tripped and not recognizing that filament is loaded in the tool head.

1 Like

I have sucessfully followed the instructions above and got rid of the filament reload issue, at least I made a full 10 hour print without problem yesterday and now this morning I have printed another model without issues for a full hour. I have high hopes this will stay stabile. Thanks a lot!

If you make a video describing how to fix this, dont forget to mention how to losen the fan that covers the parts you are supposed to fix the screws on. It took a while before I was ablet find the area.

I have a new problem though Im not sure its related. The pause/continue-function does not work any more. Neither if i pause the project and turn off/on, or if i turn off the power and hope for it to auto-continue.
Is it something with the code we have been using above that overrides this?

Video for disassembling the sideboard and the fan:

1 Like

Which version of firmware you are using now? Does this issue happen repeatedly?

Happened the last three times i have tried.

I´m now updating to the latest firmware to see if the problem still applies.
(BTW, the link on the download page leads to the old firmware, not the latest, so I have probably used an old firmware for 2 weeks without beeng aware).

Update: I have now updated the firmware and the pause and continue triggers again!

1 Like

Glad to know that. I am not sure what is the cause of the dysfunction. Given that you can use the function in the new firmware, we are not going to test it in firmware, which may be something pointless.



  2. Remove fan:
  1. Repair filament switch:
  1. Profit?

I will contact the users in this thread, sorry for the inconvenience.

1 Like

I went through the process of checking to see if the switch was tight and found it was. I then checked on the switch and found that the reed switch was not working effectively. It needed to be bent further back so it reacted when the filament was put through the eyelet. I did this very carefully using two of the hex drivers and it has been working like a dream ever since.


Hi there,

is this really the only solution? Even if this screws on the switch were not loose? Because i have the same problems, that the message “filament runout recovery” appears so often.
I tried to connect my PC via USB with the Snapmaker, but Luban wasnt able to find the serial port.
So i couldnt check the M-Codes. Is there any reason for not finding the port? Btw it works with others PC`s (stationary Desktop PC) but of course not with the one (Notebook) that i want to use for it.

@zwecke version of Luban? - have you tried the latest from forum?

The switch is normally open, you could check if the problem comes from the electronic or the switch itself, - by unplugging the switch from the pcb (I am no snapmaker staff).

Do you hear the click? It may be you will need to very slightly bend the little curve… I don’t work for snapmaker ask snapmaker support to avoid voiding your warranty

I have not been contacted yet about the warranty.


is it possible to set the M412 S0 as standard setting? Because now every time, even before it start the printing, it comes up with the “filament reload recovery”-message. During night i switch off my machine, but if i switch it on, the setting is (of course) back at M412 S1. Therefore i have to connect every time a pc to the machine - thats annoying!

With the side and fan removed, when you insert filament do you hear a click?

Did you save your change with M500 command?

I used the M500 command, but when i turn it off and on again, it is still the same at M412 S1 - so it still check the filament runout. :confused: