A350 printing "into thin air", no filament extruded

Unfortunately, another print job and another failure…
The first approx. 24h of the print went OK, no issues at all.
But when I checked in on the printer now, I found it to be printing “into thin air”.
The head was moving as usual, following the g-code, but no filament was being extruded.
And no filament had been extruded for quite a while, basically many layers are missing.
I checked if the filament is properly inside the head and if the extrusion works; no problems there.

So 2 questions:

  1. What’s going on here, why are all these layers missing? It doesn’t seem to be a problem with the nozzle, so why wasn’t the filament extruded?
  2. Is there a way to try and “continue” the print? I can’t really tell when the extrusion was interrupted for example with M503 or some other command… so can I somehow edit the g-code manually and re-print the layers?

Thanks in advance! :frowning_face:

So when you stopped the print and then heated up the nozzle and extruded some more with Gcode console it fed ok?

If so, then i wonder if there is a thermal cut out if the extruder gets too hot, or a thermal cut out to the stepper motor if it gets to hot. One of my newer Upbox’s has a thermal cutout on the extruder stepper motor if it get above 85deg C

Also thats a lot of infill… do you really need it like that is it to be mechanically stong. If not CURA (but Not sure if Lubandoes) supports variable density infill (basically starts of coarse but gets finer were needed so roofs print properly. Saves a LOT of print time and filament

1 Like

I paused the print and “loaded up” some more filament through the nozzle, the nozzle had remained at 205C the entire time. This worked fine, no problems at all.

@chazr33gtr, your idea of a thermal cut-out (or some other cut-out in general) makes perfect sense, especially given the long print duration; but I don’t know how I could check for this issue.
Perhaps someone from the Snapmaker team can advise?

I left the infill settings at a “normal” 15%; but I agree, there is no need for so much infill or mechanical strength; I will reduce the infill value.
I looked into a variable infill setting for Cura, but the articles I found made it sound pretty dodgy…

Overall, I’m OK with considering this a failed print and throwing away the part.
But I’d really like to understand why no filament was being extruded, I don’t want this to happen again.

I had the same issue.

I replaced the nozzle and cleaned the metal shaft that led to the nozzle it was almost blocked 100%. Afterwards it worked as intended.

Hey @SabinSnorlax, next time when you print in the air, open the extruder door and check if the extruder gear is rotating,- then you can see if the filament is grinded because of too much pressure in the nozzle.

If you want to resume such a failed print:

  • Messure the exact height of your print from the bed (Don´t remove the print from the bed)
  • Edit your gcode manually,- open your Model.gcode with a text editor and search for your build height. If your code is huge, you may need to download a coding editor like ATOM or something. (HINT to delete a lot of lines: mark your line, press and hold shift and navigate with the mouse with the control bar on the right side to the upper position, then select the line with a left-click.)

  • delete the lines above your build height, except your temp.-settings and your homing,- maybe you print your last layer twice,- be sure to watch the first layers of you resume print to not damage your machine. ATTENTION: your first move will be pretty fast, if you don´t give it a slower value like G0F600

  • If your gcode is prepared, i would suggest you to prime your extruder manually.

There are a lot of youtube videos and tutorials in the web, simply search for it, if needed.

Here is the start code, i have tested for now, you have to edit the temperatures:

M104 S225; Hotend Temp
M140 S30; Bed Temp
M109 S225;Wait for Hotend Temperature
M190 S30;Wait for Bed Temperature
G28 ;home
G90 ;absolute positioning
G0 F600; go slow to the following coordinates

I´m no Snapmaker-Staff, so no guarantee from my side.
Hope this helps!

1 Like

I can see how a blocked nozzle would cause this; but I would be surprised if this was the case here, as I’ve only had the A350 for around 2 weeks. So in my opinion it would be a pretty poor performance if after just a few prints the nozzle is already blocked…

Many thanks for these suggestions, @xchrisd!
Even if this doesn’t work out in the end, I think the exercise of re-starting a print job is worthwhile.

Just one question - what do you mean by:
“If your gcode is prepared, i would suggest you to prime your extruder manually”
Do you mean making sure the filament is coming out OK?

Yes :+1:
Priming is also possible with gcode but easier by hand.

1 Like

true but I got a a350 and had the same issue with a spare nozzle that wasnt older than your snapmaker. I mean if your nozzle is good ok I just removed the whole heating part put it in the oven at 260 C and cleaned it. since then no more problems

1 Like

In my first hotend was a loose piece of ptfe tube in the nozzle, since I put it out I had no problems anymore.

1 Like

exactly the same here

Very useful comments on checking the nozzle; I will do that this evening.
Hopefully no more issues with interrupted printing after this. :slightly_smiling_face:

Quick update on the “printing into thin air” situation.
I started a new print job, with a completely new hot end and a new spool of filament.
Just to make sure there is no influence from these sources…

After around 15h print time, I found the printer again printing into thin air…
I looked at the nozzle, all still OK there, no blockages.
Then I checked the mechanism feeding in the filament and realized it is not working properly!
When I simply pressed “Load filament”, nothing was being fed although the filament was inside.
When I gave it a proper push, then the filament started being extruded.

@xchrisd @realfire - any suggestions on how to proceed?
Are there some tweaks or repairs I can do or is this something Snapmaker warranty should cover?
Basically, to me it seems like the feeding mechanism is not working as it should, and so I’m considering to request a new printhead.
Many thanks in advance for any insights!

Was the extruder gear rotating?
What’s your print settings?
What filament did you use?

If you do many retractions on a small part there could be filament grinding by the extruder gear, - this could even happen if your extruder prints too cold.
This are normally Slicer settings and or issues.
The next thing is, where hangs your filament from, it is totally necessary to make it the extruder as easy as it could be pulling the filament. For example filament roll above the head is perfect.

Hope this gives you some understanding :wink:

1 Like

This sounds like user error. It is likely that your extruder gear is spinning as intended but the filament itself has had a groove ground into it by the gear.

This can be caused by a number of reasons as follows:

  • Printing at too low a temperature, if you do this there will be excess pressure in your hot end which wont allow the filament to be extruded at the proper rate. Your extruder gear then over time grinds a notch in the filament and no longer can grip it properly resulting in mid air printing with no extrusion.

  • Too much tension on your filament feed, where are you housing your filament spool? If there is too much tension on the line the filament wont feed properly and you will also result in a notch ground into it same as above. Generally people hang filament above the extruder and if possible do so on a holder that has a bearing ensuring minimal resistance.

  • Excessive retractions, if you retract too quickly or for too long a distance, over time you also have the chance of grinding a notch in the filament. If you are printing in PLA try a retraction distance of between 1-3mm at a rate of between 20-35mm/s

  • Finally, printing with too low a starting Z-offset. This is less likely to be the issue as you say that the failure occurs multiple hours into a print


@SabinSnorlax you describte exactly the problem I had. I did clean the hot end.
Removed nozzle and put everything in an oven 250C° then used a cleaner needle. After that everything worked perfect. I had a big chunk of unexplainable white plastic in the pipe above the nozzle

1 Like

Hi there,

What firmware do you have on your device?
Was this sliced with Luban, or with some 3rd party software?
If with Luban, with what version of it?

I’ve been seeing issues with this as well, twice today actually. Luckily for me it is occuring during my first layer so its not a huge waste of time/filament. I actually saw it ~3 weeks ago and then have had no issues until now. I can tell that the filament is getting ground by the gears when this happens but i cant figure out why it is sporadic. I haven’t played around with the retract settings at all so they are the same print to print.

Many thanks for the many replies and comments!

Background information:

  • Model sliced with Luban 3.7.0
  • Print settings “normal”, only change was from 15% down to 10% infill
  • White PLA filament from Snapmaker
  • “Fresh” roll, so I doubt moisture is a factor
  • Roll positioned on the normal holder above the print head
  • Nozzle temperature at the standard 205 °C

What happened:

  • Gears were rotating as usual
  • But the filament was not being pushed down toward the nozzle!
  • The nozzle itself worked fine, as when I gave the filament a “push” myself, the filament was extruded properly
  • I unfortunately failed to check if the filament had grooves ground into it by the gear

Regarding your comments:

  • I doubt temperature was a factor, as mentioned I used the standard 205 °C
  • I also doubt there is too much tension in the filament feed, the roll was on the usual position above the head
  • @C.Harris, @xchrisd I agree with your comments regarding retractions, this may have played a role in the gears grinding a groove; so I will check my settings for retraction distance and rate
  • @C.Harris Not sure about a too low starting Z-offset… I set the offset as indicated by Snapmaker. How would a too low offset cause the gears to grind a groove?
  • @realfire When you mention you put everything in an oven at 250 °C, which parts do you mean? As mentioned, I used a completely new hot end for the last job. And I didn’t notice any chunks of material in the pipe.

So I guess I will now check my retraction settings and the Z-offset and report back if this has solved the issue…

1 Like

I received an hotend factory new from snapmaker guys it was already clogged when I received it. I had to clean it afterworks it printed well for 30 prints and last week it died because of me wanting to much :rofl: