Filament reload

After roughly 1.5 YEARS after buying one of these snapmakers I finally got my 350 printer. I have to say I was impressed with the quality of the boxing, what came with it and the instructions. That said, I assembled everything and eagerly sought out a first print, loaded the filament to do my first print.

That has all come to a crashing end, I am no longer impressed. Because I cannot print a single thing. I currently have an expensive fancy looking paperweight and several feet of melted filament in the shape of failed prints laying around.

I get “Filament reload” warning and the system stops CONSTANTLY! I haven’t been able to go longer than 20mins of printing without an error. To say I am agitated is an understatement.

Not to be a total noob, I have done some homework before coming here. I found instructions related to this issue and directions on how “correct” this: It says to download pronterface, connected to the printer via the usb cable, entered the command “M412 S0” to turn off the filament sensor (says the command was accepted), connected through the software (used both snapmakerjs and snapmaker luban), uploaded a file to the printer. Start the print and it’ll go for a little while then suddenly I’ll notice no sound. It stopped. I’ll take what oozed out of the head, and restart. Few minuets later. I STILL GET THE ERROR! Even after turning off the filament sensor. WTH? I am on the verge of tearing into it and soldering that microswitch closed, but if the filament switch is supposedly “turned off” in the software what will doing that accomplish…

Stop me from destroying this thing…

EDIT: It stopped… again… and I ran the command codes… again… and restarted it… again… Here’s an image of the command script. (towards the bottom is where I unplugged it from my computer)

Did you save your code entry by M500?
If you want to, you could simply disconnect the filament switch from the print head pcb.
I had a loose contact at the connector which caused no runout´s anymore.

There was no mention of that in any of the instructions. I read, I will try that. Thank you for the information.

I’m not sure M412 is a value written to the firmware, so M500, while always a good idea, may not help here.

I double checked in the firmware that M412 is enabled and it looks like it is, so it’s weird it’s not acting like expected.

Only other thing I can think would be take the right side cover off, remove the 2 fan mount screws from the rear of the toolhead, and check the microswitch mount screws didn’t loosen in transit, that has been an issue a couple people have had.

It’s pretty ballsy on behalf of staff here that they have posted instructional videos of how to fix the issue and then said “don’t do this it’ll void your warranty”. For example here: Filament reload... Wait, it's not out of filament. And here: Filament reload... Wait, it's not out of filament.

Welcome to the forums, hope you can get your machine dialed in and working perfectly in short order.


1 Like

Thanks. I restarted it again in the morning. I ran the M500 code, let it rip and left for work. Hopefully it’ll still be going when I get home.
It’s entirely possible that I’m doing something wrong. Mechanically and a esthetically it’s absolutely beautiful. Once I get this issue straightened out I have no question it will be great. Some other printers come with 3d printed parts that looks like it was printed on a potato. Not a single 3d printed component in sight, which for me was the primary selling point.

1 Like

Well, I’m excited. It was still going after roughly 8 hrs of nonstop printing. Hearing that almost rhythmic digitalized like music of the motors working in unison at the door was a pleasant to say the least. And the print looks great so far. I don’t want to jinx myself but it seems the issue is at least temporarily resolved until I can get the printer head filament sensor corrected / fixed. Here’s hoping.

Thanks for the help.

Alright. I’m trying my second print and now it will not let me past filament out screen. I tap start to start the print and it just goes straight to the load filament screen, wait for it to heat up, load the filament that’s already in there, waste some filament as it just oozes it out, click continue, tap start, right back to filament out screen. I removed the filament and reloaded it. Same issue. I cannot find how to fix this.
I’m beginning to be come disillusioned with this device…

That’s unfortunate that issue is coming back. However it is somewhat fortunate it’s a fairly straightforward mechanism - just a single microswitch that checks the filament.

I don’t think you’ll be able to do much without taking the right cover off. Have you checked if the filament check switch is screwed down securely? It should only take about 10 minutes to disassemble and check, it’s quite a good design for the toolhead.

~ Brent

1 Like

Never mind, this pile of… you know what I mean. Well. it just broke.