F350 layer shift 3D print

Dear all

The F350 is new and was working for about half a spool pretty smooth. Firmware is up to date.
But now and suddenly, it shifts layers by about 45° to the right (Y-axis) every layer. It affects objects that print for more than about 3 hrs and rather round objects. Smaller print sessions do work fine [1].

Few users [2] have similar issues but none of the proposed solutions helped. I’ll try my luck with my own thread.

Print settings:
I do print between 30 and 40 mm/s (rather slow) and a Z hop retraction of 4 mm.
Tested workflows are

  • tinkercad → cura → octopi
  • tinkercad → cura → snapmaker (select file/ start)

What I have done so far:

  • manually put x and y linear drivers to the opposite side of the home position; let it drive to home
  • disassembled the print bed and aligned (manually) the drivers again; let it drive to home
    → the above two steps led to some improvements
  • exchanged the filament (PLA)

Any ideas where I could investigate any further?

Kind regards
n3

[1] (short duration) Test objects that print without no issues:

[2] Layer shifting issues

(new users cannot put more links. sorry …)

A bit more precise: it shifts in the Z axis only and I have also added fotos.


I am having the same issue and have found no solution. Mine also seems to be pushing the build plate slightly with the shift.

1 Like

Since no one else has had anything to say so far, I’ll offer some generic advice, some of which may repeat things you’ve already done: triple-check your assembly to make sure the bed and linear modules are all in their correct places (and make sure you got the correct linear module pair in the Z position, because on the F models, the Z modules have different lead screws from the others).

Then check the Y-axis linear modules to make sure they are both moving when commanded (you’ll need to remove the bed, then jog around)—sometimes one will fail while the other continues to work, but the Snapmaker won’t work properly that way.

Make sure the nozzle isn’t hitting the model (unlikely if you have Z-hop configured).

Are there any issues if you try the standard test prints (XYZ cube, Benchy, etc)?

And if you were trying to print all of those objects in your photos at the same time, try printing them one at a time—I’ve had prints fail spectacularly when there were multiple objects on the bed, but come out fine when they were sliced and printed individually.

1 Like

Thank you for leaning in.
Indeed, printing one by one might work - at least for the smaler items. But this can’t be a permanent solution. And usually stringing and or collisions are an issue with multiple items, but I have never seen layer shifting in that manner.

Meanwhile I installed und used luban. No change. I’ll investigate further on the hardware.

So far, I can tell, I can reduce the Y-shifting if I manually adjust the modules (remove bed; move Y axes up; switch on; drive home). And I also recognized, that after longer prints, the right hand module travels about 6 mm further to the front side edge than the left hand driver.


I have observed a noise (“Blonk”) if the direction changes quickly on the y-axis. And I also think thats when a shift happens.

I have carefully assembled the device and it was working fine for a few longer prints at the beginning. But certainly, the modules could be mixed up: is there a way to distinguish the modules?

Yes, my test print is fine. Its probably too quick. I haven’t tried to print Benchy nor the cube. I might give it a try with the cube.

… or I might just return the device…

@BZBarkery this might be a solution for you:

  • switch of the device
  • unscrew the heat bed
  • manually and gently move the both drivers of the Y axis to the back side
  • manually and gently move the print head driver to the right side
  • switch on the device
  • let all modules move to their position of origin
    → any better?
    → also make sure tha heat bed cable can move freely from the back to the front

There are some photos in Power Module / 3D Printer Module /Linear Module that show the linear module labelling. Note the bit below the words “Linear Module” where it says “Lead ## mm Stroke 264 mm”. The modules with “Lead 08 mm” are the Z-axis modules and shouldn’t be used in other positions.

If you’re pushing each module individually to the end with the bed off, it probably isn’t simple module misalignment. A broken endstop switch doesn’t seem likely either.

Another possibility is that you have a broken linear module, and while parts of the innards are user-serviceable by determined tinkerers, you’ll want to contact support before opening anything so that you don’t void your warranty. At least one person has received modules with damaged bearings.

Also, here’s an old thread in which a former Snapmaker support person describes a simple test for linear modules that aren’t operating at the same speeds: "Bump" in Y-axis - #44 by Edwin

1 Like

Hi, I had similar issues in the past which were solved by dialing down the acceleration settings. I did this using Cura rather than making changes directly on the machine, but you can also adjust the settings on the machine too. I am using an acceleration speed of 750 and that has transformed the quality of my prints On my A350. Worth exploring this and the Jerk settings too.

Check out this article for more information - How to Get the Perfect Jerk & Acceleration Setting – 3D Printerly

Thank you @ElloryJaye, I couldn’t see the labels in the light I had! :slight_smile:
Its a pitty, that the modules aren’t labeled in the middle part: it would make it much easier to read them when the device is assembled.

@rotormouth Thank you too for the link. I’ll use that for later printings.

I have made an interesting test with luban default:

  • unscrew the heat bed from the right module:
    → on every layer there is a shift of aprox. 1 mm towards the devices front side
  • unscrew the heat bed from the left module:
    → prints very well

Conclusion: right hand side module is somehow gone.
I’ll contact support… :-/