Discussion of Snapmaker 2.0 Firmware Updates

Well after a powercycle and running the XY calibration it seems that everything is fine. :+1:

Newest Firmware runs into issues with 10W Laser model. There is an endless loop of safety instructions for the laser and the success screen. (selecting “Got it” will only switch between these two screens, without the option of escaping this endless loop!)
I had to reboot without the laser module to roll back the firmware!

Did you reach out to support?
https://snapmaker.formcrafts.com/support-ticket

yes, submitted the ticket just now…

1 Like

Please keep us updated. Anyone other has Same Problem? Don’t want to Update before clarification.

I got the latest, will try laser and CNC Tomorrow, will see.

Hello,
it would be nice if in the selection “quick swap installed” could select head, bed or both.

I use e.g. only the system for the head and can not select the option because then the head is 15mm too high.

1 Like

I am missing the vibration compensation firmware, the machine is so much noisier with the V1.17.17 firmware. Quick swap needs to go in the vibration compensation firmware.

There is a separate topic for vibration compensation, I wish they did it right away- https://forum.snapmaker.com/t/now-compatible-with-8-lead-vibration-compensation-beta-firmware-for-2-0-series-stable-print-quality-at-higher-speed/

But it’s best to send a ticket for any future requests - Support Ticket Form

Of this I am fully aware and have posted in there before. My main chat was about the quick swap and it would be nice if the vibration compensation worked with it too, converging topics if you will.

Hi. Is it?
I recently installed my head mount on my a150. This is officially not supported, but all my heads now have the quickswap plate, so I mount head mount there too. I was able to print with my dual extruder EXACTLY as before. So I just unmounted dual extruder, mounted head plate to it and head mount to the X axis, swapped the head in and started my print. Same Z-offset as before and it printed perfectly. Because of that I thought the quickswap do not change the position of the heads?

How to do this with the offset I know you just set the y offset high but it would be nice if in the firmware that would also be adjustable or would give a choice

Hi, no. I did not changed anything between Quickswap and directly mounted and do not have to change Z OFfset. So I think the head does not have a 15mm offset with quick swap. How you detected the offset?

BUG: 1.17.17, 10W laser, Rotary attached: After booting the machine, you get “Safety Instructions” → Got it → “Congratulations - initial setup finished” → Got it → “Safety instructions” → Got it → … Never ending loop.

Disconnect Rotary: “New Module attached → Camera calibration?” → No → OK, can continue.

Revert to 1.16.7, Rotary attached: “Safety Instructions” → Got it → “Congratulations - initial setup finished” → Got it → Can continue, all OK and works.

sigh Please, please, please Snapmaker: test your software before giving it to us… THANKS!!!

Will create a ticket.

2 Likes

…and here’s the reply by Snapmaker support:

Currently this may be a local parameter reading issue, we will fix it in the next firmware version.

You can connect the 1.6W laser module and the rotary module and go through the wizard steps, and then reconnect the 10W laser module and the rotary module. At this time, the 10W laser module will not cycle through the wizard page.
After passing the wizard steps for the 1.6W laser module and the rotary module, there is no need to go through the wizard steps for the 10W laser module.
Then you can use the 10W laser module and rotary module normally.

2 Likes

Hi,

I’m running the latest firmware (V1.17.17) and Luban version (V4.9.1) and I’ve notice that whilst using the 10W laser, the previous settings I used (e.g. 11% power at 100% speed) are almost useless. I’ve had to up the power to 30% and drop the speed to 70%. Is this the case for anyone else? I’m contemplating rolling back to the previous firmware/software. Does anyone have any experience of this please?

Any help would be much appreciated!

I’m running 1.17.17 but with lightburn. Been using the same parameters.

PEOPLE, did you see the latest update on firmware with print job management refactoring?
Sounds like it’s finally does the thing :slight_smile:

It would be nice if the touchscreen had the same XYZ Axis Offset that is in the Luban control panel having options for 10, 1, .1, and 0.05mm. Instead of omitting the 0.05mm option on the touchscreen.

It would also be nice if the terminology for the M8/M9 control for the air pump was corrected to reflect conventional electrical terms.

The M8 command to turn the pump “on” returns the status “set air pump switch: open” which normally would be an electrical reference to “off”

The M9 command to turn the pump “off” returns the status “set air pump switch: closed” which normally would be an electrical reference to “on”

M8
M8
ok
others < set air pump switch: open
ok
M9
M9
ok
others < set air pump switch: close
ok

1 Like

Getting a pause every time it does a G2 i think. Latest firmware, printing a prusaslicer 2.7-alpha1 generated gcode file with G2/G3 enabled. Sent to the machine via luban, printed from touchscreen.
In the middle of the model it appears to stop but now I believe its a G2 move causing the appearance of stopping. I think it was the inner walls not outer which seemed to run at normal speed without pausing.
@parachvte is this known bug?
Can you try printing this on an A350 with PETG:
Frame and Vent Assembly27_0.2mm_PETG_A350_5h6m.zip (1.4 MB)


An example line from file:
G2 X186.82 Y226.366 I.037 J-.212 E33.22049

Also raised an issue with PrusaSlicer for the leading zeros missing which may throw off legacy marlin machines. 2.7-alpha1 skips leading zero on G2 J/I parameters for legacy marlin machines (Snapmaker A350) · Issue #11620 · prusa3d/PrusaSlicer · GitHub