Discussion of Snapmaker 2.0 Firmware Updates

I’m having an issue updating the firmware using the USB drive (Wi-Fi isn’t working correctly) I keep trying to update to 1.12 from 1.10 and it doesn’t seem to be working. It shows the firmware update screen and says that it’s successful, but when I got to firmware screen on the touchscreen it shows 1.10 instead of 1.12

Why is this?

My Snapmaker 2 A350 is running 1.12 and doesn’t seem to see the update to 1.12.1 as being available over wifi. I was able to successfully update it using a USB drive though. /anecdote

I installed the latest firmware and immediately started having prints that have failed in catastrophic ways. Finding the whole print bed shifted and a huge blob of plastic on the hot end. This has been with PETG and PLA+. And in most cases I had just checked on the print at about the 14-hour mark, walked away for 30 -45 minutes and came back to it failed. I suspect that the bed level function is not performing as expected. That said, I have no doubt that my bed is not flat and I also just replaced that about a dozen prints ago. I also have the original bed frame, suspect that is contributing to my issues, but I was getting successful prints prior to the update. Before I could get it dialed in and just start prints and walk away for several prints, normally didn’t have to mess with it again until I swapped out the filament, now I will get one print that is sucefull and the very next one will not stick to the bed.

For troubleshooting: I have swapped where the rails were, due to noting that one of my Z rails would allow the Y-axis to drop at least 1mm. Verified twice now that everything is put together right. Performed several auto levels, and I use a feeler gauge for getting the correct distance from the nozzle. I have even attempted a manual level. The last fail destroyed the hot end cause I thought it was sticking to the bed and went to bed, woke up to the hot end bing in a huge blob of plastic that melted the insulation off the wires. I was really lucky I didn’t have a fire. I just replaced that (which kudos to snapmaker for making that 100x easier than it is on the 1.0 version) and am in the process of rolling the firmware back now. Anyone else experience this or am I one off?

Sorry for the problem you ran into. As you checked the print when the machine worked for 14 hour, I have to say that this issue had nothing to do with the heated bed.

  • Which version of the firmware did you use?
  • Send me the G-code file that you failed to finish.
  • Did you complete the work before?
  • Do you have some photos of the failed model?
  • You can export the log files from the touchscreen and send them to me for further analysis. Here is an image for your reference.
    image

I did allready once updated the printer to 1.12.1 via wifi on the touchscreen. This was with the 3d head connected. When i connected the laser head it said i needed to update the module. So i went back to the firmware on the touchscreen but there i get the error that it is allready installed. So i downloaded it from the website. running this from the usb gave an erro that it couldn’t not read the update file.
Downloaded 1.12.0 from the forum and ran that from the usb and that went fine.
I then went back to the firmware on the touchscreen to update it again to 1.12.1 but that gave the same error as trying to install 1.12.1 via the usb. Also a read error in the 1.12.1 bin file. Is there something wrong with the file on the server from snapmaker??

I recommend you use the USB flash drive to update V1.12.1.

How to Update Firmware

  • Via a USB flash drive
    • Put the firmware update file Snapmaker2_V{version}.bin in your USB flash drive.
    • Plug the drive into the Controller.
    • On the Touchscreen, tap Files > USB > Snapmaker2_V{version}.bin .

You need to update three tool-heads separately, which means you need to update the firmware when every tool-head is mounted, and update the firmware three times.

For the laser module, plug it on and then update the firmware.

Switch to the 3DP module, update the firmware once again.

The same to the CNC module.

3 Likes

Are there any known major issues with 1.12.1? I’m still on 1.9 because of all the issues with anything beyond that. But if there’s no major issues I’m going to go ahead and update it, since my rotary module should be shipping in the next month.

Updated my firmware to 1.12.1 via wifi with laser module attached and the machine no longer has the Enclosure listed on the touch scree. I then attempted to update via the USB stick and same issue. Any ideas?

This happened only one time to me and a power cycle helped to get the enclosure back to system.

Same here. I usually update firmware when I receive a device, but in this case the new firmware was purportedly causing Wifi problems so I held back. Looking at the changes, there is nothing all that compelling, so I have been delaying the upgrade for fear of bugs. I was going to upgrade the firmware this morning, but after reading about the workflow changes and the need to do every tool head, I’ll wait until I’ve actually used the other toolheads.

Were your axis and extruder steps (M92) calibrated prior to your update? An issue that I ran into with V12 was it reset my calibrations, and wouldn’t let me save them afterwards. You may want to check that out. It’s an issue that is supposed to be fixed in one of the upcoming versions. Until then, I’m on v11.4.

It does this with any firmware update, I didn’t have any problems saving the recalibration afterward though. Strange.

I know it does it for each update. My issue was it would reset it after every power cycle. Did you update to 12.0 or 12.1? It may have been fixed by now.

@BluegrassBlaster Just been looking at the GitHub updates that have been committed for what I think will be the next release and I can’t see one for your problem. Might be worth giving them a prompt.

@BluegrassBlaster i updated to 1.12.1

1.12.1 does have WiFi issues, I just toggle WiFi off and then back on and it continues to work. Others report having to renter password, I don’t have to do that (as I dont reselect the SSID) Just do the toggle. I got annoyed enough to dig out long usb extension cable.

I keep seeing this mentioned. For whatever reason mine has no problem connecting to it automatically. I wonder if it’s because of the close proximity it has to my WiFi router. It’s only 30 feet away.

I suspect this is wifi system dependent, i have found many weird issues with embedded controllers and even pi on some systems re-acquiring the station. I am pretty certain there is a bunch of dodgy code out there on many embedded systems - but folks rarely have traced it down. I statically addresses the pi’s having the issue and the thermostat having the issue I had to use a WRT based router deicated just to it. I am, hoping this is just a simple bug in the FreeRTOS like maybe this one Marvell: fix WiFi reconnect issue by AniruddhaKanhere · Pull Request #3267 · aws/amazon-freertos (github.com) or somesuch.

Out of interest do you use regular DHCP or do you set a reservation on your DHCP server?

@scyto If anything, the security on my router is a whole lot more discriminatory of what it will allow to connect, including custom dhcp. That actually makes me wonder if it’s the touchscreen thinking the WiFi isn’t secure, it is an android after all, so it may have embedded security instruction to not connect if it thinks it’s not secure. Right after turning it on, it probably tries to connect before all command lines have finished loading that would recognize it as a familiar and safe connection. Similar concept to how Windows shows errors in event viewer because it tried to do something before everything finished loading.

But I also don’t know where the WiFi chip is located, whether it’s in the touchscreen or the controller.

My Snapmaker looses the password all the time after 1.12.1 and I now only use Octoprint for printing. It was fine before the last update and it’s a right pain for CNC and Laser as I used to just use “file send to” via Wifi and now have to mess about with USB. The printer is in the garage 5m away from a mesh node, the mesh has 18 other wireless devices connected to it as I type this, They are all over the house and garden and I have no problems with anything other than Snapmaker.
I am hoping the next firmware update will fix this as there has been so much noise about it but as it’s a touch screen function and the haven’t published the source code or any changes they are working on it’s anybody’s guess.