Discussion of Snapmaker 2.0 Firmware Updates

Hi xchrisd,

P100 should be 100% as we define in M1010, I will follow this issue and test it later, thanks for the feedback.

And the “infinite echo” issue, I think maybe it causes by the controller, will pass to my colleague to check out what’s going on.

Sorry for the inconveniences.

Regards,
Alan

1 Like

I have experienced the same. By the first sight the interior lightning was dimmer to me, then I was able to see spinning of the CNC motor spindle and the exhaust FAN blades (probably the PWM frequency is interfere with those RPMs?)

There is a pending pull request on the public GitHub for this, looks like it will be fixed pretty soon. Nice

I’m experiencing a very consistent bug after the upgrade to firmware v1.12.0_20210331: after successfully getting a “File Transfer Successful” and hit the “Got It” button the touchscreen freeze and become unresponsive. The only thing that works is the “Disconnect” button, but after hitting that and going to the file option the file does not appear to be there.
Only after rebooting the unit the file becomes available for printing.

Before this firmware upgrade my workflow was:
connect my OSX Luban to the snapmaker
send the file to the snapmaker
file transfer successful
start the printing on the snapmaker

now is
connect my OSX Luban to the snapmaker (always fail at first)
send the file to the snapmaker
file transfer successful
hit the “Got it” button
disconnect the snapmaker
reboot the snapmaker
find the file
start the printing on the snapmaker

I’m noticing my A350 runs a lot quieter following the v1.12.0 update.

Also noticing that the response times are slower. When I hit the ‘Go’ button, it can take up to 30 seconds to actually start the job. Same for the pause and quit, should I need to interrupt the job.

Could this be due to code related to the Emergency Stop button? (I need to get one of those…)

Downgraded to V1.11.4 and my A350 is behaving a lot better…

See here and here - would wish they’d do a better firmware QC and also a clearer communication of changes in advance…

Oh yeah, and there’s that.
Lame I had to figure out by myself it is better to stick to 1.11.14…
I will know better next time.

I find this situation truly ridiculous…

After I installed v1.12.0, my enclosure lights are dim and my enclosure fan speed is low. Is this a bug, or is there an adjustment I need to make?

This is a known issue, wait for an update.
Workaround is possible by manually switching on with terminal.

I’m having an issue updating the firmware using the USB drive (Wi-Fi isn’t working correctly) I keep trying to update to 1.12 from 1.10 and it doesn’t seem to be working. It shows the firmware update screen and says that it’s successful, but when I got to firmware screen on the touchscreen it shows 1.10 instead of 1.12

Why is this?

My Snapmaker 2 A350 is running 1.12 and doesn’t seem to see the update to 1.12.1 as being available over wifi. I was able to successfully update it using a USB drive though. /anecdote

I installed the latest firmware and immediately started having prints that have failed in catastrophic ways. Finding the whole print bed shifted and a huge blob of plastic on the hot end. This has been with PETG and PLA+. And in most cases I had just checked on the print at about the 14-hour mark, walked away for 30 -45 minutes and came back to it failed. I suspect that the bed level function is not performing as expected. That said, I have no doubt that my bed is not flat and I also just replaced that about a dozen prints ago. I also have the original bed frame, suspect that is contributing to my issues, but I was getting successful prints prior to the update. Before I could get it dialed in and just start prints and walk away for several prints, normally didn’t have to mess with it again until I swapped out the filament, now I will get one print that is sucefull and the very next one will not stick to the bed.

For troubleshooting: I have swapped where the rails were, due to noting that one of my Z rails would allow the Y-axis to drop at least 1mm. Verified twice now that everything is put together right. Performed several auto levels, and I use a feeler gauge for getting the correct distance from the nozzle. I have even attempted a manual level. The last fail destroyed the hot end cause I thought it was sticking to the bed and went to bed, woke up to the hot end bing in a huge blob of plastic that melted the insulation off the wires. I was really lucky I didn’t have a fire. I just replaced that (which kudos to snapmaker for making that 100x easier than it is on the 1.0 version) and am in the process of rolling the firmware back now. Anyone else experience this or am I one off?

Sorry for the problem you ran into. As you checked the print when the machine worked for 14 hour, I have to say that this issue had nothing to do with the heated bed.

  • Which version of the firmware did you use?
  • Send me the G-code file that you failed to finish.
  • Did you complete the work before?
  • Do you have some photos of the failed model?
  • You can export the log files from the touchscreen and send them to me for further analysis. Here is an image for your reference.
    image

I did allready once updated the printer to 1.12.1 via wifi on the touchscreen. This was with the 3d head connected. When i connected the laser head it said i needed to update the module. So i went back to the firmware on the touchscreen but there i get the error that it is allready installed. So i downloaded it from the website. running this from the usb gave an erro that it couldn’t not read the update file.
Downloaded 1.12.0 from the forum and ran that from the usb and that went fine.
I then went back to the firmware on the touchscreen to update it again to 1.12.1 but that gave the same error as trying to install 1.12.1 via the usb. Also a read error in the 1.12.1 bin file. Is there something wrong with the file on the server from snapmaker??

I recommend you use the USB flash drive to update V1.12.1.

How to Update Firmware

  • Via a USB flash drive
    • Put the firmware update file Snapmaker2_V{version}.bin in your USB flash drive.
    • Plug the drive into the Controller.
    • On the Touchscreen, tap Files > USB > Snapmaker2_V{version}.bin .

You need to update three tool-heads separately, which means you need to update the firmware when every tool-head is mounted, and update the firmware three times.

For the laser module, plug it on and then update the firmware.

Switch to the 3DP module, update the firmware once again.

The same to the CNC module.

2 Likes

Are there any known major issues with 1.12.1? I’m still on 1.9 because of all the issues with anything beyond that. But if there’s no major issues I’m going to go ahead and update it, since my rotary module should be shipping in the next month.

Updated my firmware to 1.12.1 via wifi with laser module attached and the machine no longer has the Enclosure listed on the touch scree. I then attempted to update via the USB stick and same issue. Any ideas?

This happened only one time to me and a power cycle helped to get the enclosure back to system.