Camera preview and G-code always in top right quadrant instead of middle

This file runs ok in Camotics and is not displaced by the quadrant issue. It was set up to have a central origin in Carbide Create. This is a 37mm square with a 1mm depth tool cutting a pocket

[for Edwin.nc|attachment]

(upload://jYd5ZB8NTTpY0MXrbs8wIUqziZB.nc) (334 Bytes)

@Edwin
I think the original question was about using camera preview for laser work. As you say the camera shows the machine work area in the top right hand quadrant of design space in Luban. The problem is that when the file is sent to the SM the machine assumes a work origin in the centre of the bed whereas the code has an origin of 0,0 in the design space i.e the front left of the bed. Its easy enough to jog the machine to the front lefthand corner of the bed and set a new work origin but its tedious to have to do it everytime and its also easy to forget to do it. If you don’t do it, everything is offset to the back right of the bed.

2 Likes

I have the the same issue. I set my material in the middle of the bed and start camera capture. Then the camera preview shows up in the upper right corner. Because my uploaded picture is in the center of the luban workspace, i have to drag the picture to the captured picture in the upper right corner. If i do then the “run boundary”, to check if my image suits the piece, it runs the boundary in the upper right position of the bed, so far away from my piece, instead of the middle of the bed and the origin of my piece i want to laser at. Is that understandable?
(It works, if i just hit play and dont check the boundary, but then i cant check if the boundary is fine - and mostly it is not fine because of any misalignment with the camera due to the height of the material i guess…)

@zwecke

When using camera capture feature, it is using the machine coordinate instead of workpiece coordinate. Camera capture should be considered as an automated way which using the machine coordinate which is being set by the endstops. So you don’t need to set it manually. By default is in left-bottom corner. You shouldn’t try to set origin by yourself. You should using Camera Captrue by using Luban to control SM2 directly. Please check below links out.

  1. https://support.snapmaker.com/hc/en-us/articles/360052352433-How-to-Use-the-Laser-via-Camera-Capture
  2. https://support.snapmaker.com/hc/en-us/articles/360052352413-How-to-Use-the-Laser-via-Work-Origin

Hi,
ok. but what about I don’t like to keep Luban open and connected to the printer all time? When I’m just like to use the camera feature, align my cuts/engravings, generate code and transfer it to the machine (usb or wifi) ? At the machine, I choose the file and check with run boundaries. which are then totally off… will it still print correctly? Why not keeping ONE origin all time for all features ???

1 Like

Thanks for your reply. When I’m 3D printing I have no problem sending the file via WiFi and then running the job from the touchscreen - two advantages, don’t have to rely on a WiFi connection when running the job and once the file is sent to the SM running it multiple times from the touchscreen makes for a far more efficient way of carrying out repetitive work. Having to run a camera capture laser job over WiFi is an inconsistency in Luban. You might argue that if one is using the camera to aid placement of the work it is necessary to re-capture every time, not the case if a jig is being used.

i am a little confused :thinking: when i first got the machine and used camera capture (using laser) - i just dropped the image and moved it to someplace in the camera capture area.
after update of the firmware, the camera capture is in the top right, so i put my work piece on the camera capture area - but when i run boundary - it moved from the centre of the plate going top right? , i moved everything from the screen capture area to the centre (and it worked)… this is a pain, as i have to calculate the work area.

is there a way of moving the screen capture to the centre??

My workaround is to move the machine work origin to the front lefthand corner to align with the Luban origin.
The official response is to run the job from Luban and the origin will be right, I’ve not tried that myself as my WiFi connection is not stable enough.

1 Like

hi, thought i would give a follow up , the problem was not me but the software, found out by starting another thread.
@albutch hit the nail on the head (gave the right info) but being completely new to this - i didn’t quite understand what he was saying :smiley: totally my fault, as i thought it was another reason. big thankyou to albutch - he was able to cut through what i described to get to the actual problem.

apparently (haven’t tried it yet) using camera capture the origin gets lost when you “send to device via wifi” but if you run it via the computer it works, (rather defeats the purpose)
going forward, i will use albutch suggestion until they fix the problem

if interested like @Galduron 1 st post - to give your support to the updates he suggests (it must have taken a bit to put it together :smiley:

2 Likes

Hi @ Edwin,

I assume the Laser File Generator and the CNC file generator as the same, correct?

Can you clarify with respect to the CNC File generator, whether I put the text dead center, top right, bottom left, the preview on the touch screen always displays the image in the top right quadrant and as a result, cuts of the image when cutting it out. Can you please advice how to fix, see attached screenshots for reference.

thank you,
Dan

hi @Edwin first of all, welcome to the forum - there are some excellent people here that are very knowledgeable (beginner myself and they helped me out tremendously)

this took me a while to work out, so it is excellent that i can pass on the info (what i now do).
i started with cnc so this confused the heck out of me.

camera capture is a brilliant idea but there is a problem with the firmware (the makers are aware), this caused me to stop using camera capture

i now put everything in the top right corner and manually mark the origin in the bottom left of the wood. the software is meant to put everything in the top right (because that is the work area) - hope this helps.

here is a hint i had to work out, tried to do a picture - unlike cnc the laser preview gives you exactly what you will get at the end of the job, an image in greyscale will be sometimes be black and white - but it is nothing to do with making the image lighter. i found best results with the density changed to 3 instead of 7 (if density is too close, it will make the image black), look at photo’s below

If the right upper quadrant of the platform is the “working area” of the machine, why does the camera take a picture of the whole bed?
When you use the scanned image to overlay a design, why do you then have to reset the origin to get the image to burned onto the object that you had secured to the bed.
When I secured an object in the center of the bed, and then used camera capture, and it shows up in the center of the right upper quadrant, and then wants to burn the image in the right upper quadrant, so I have to move my object, or reset the origin (or both), there has to be something wrong with that implementation of the software. It renders the camera capture next to useless (it wasn’t totally useless in that sizing of the object was facilitated, but I could do that with the grid in the software.)

The center of the Workspace in Luban (the center of the cross, the middle of the 4 quadrants), is your work origin.- It’s the starting point of your job.
Get your picture where you want to be the work origin.
You need to set your work origin in the machine as well.

Why not line up all of the tool head systems and camera capture coordinate systems the same? All of them should have 0,0,0 in the center of the print, cnc, laser bed with camera capture showing up in the center.

i.e. Is there a good reason for them not to share the same coordinate system or is it leftover from a design decision that should be reconsidered?

3d printing is clear, the origin is in the front left, this is every time the same, and the space of the buildplate is clear.

If I laser or cnc, I have to set the work origin I like.
In some cases it is easier to engrave when I set a specific origin.
I guess, you will see in the future.

Then, when the program loads, the red region should be centered on the screen and the other quadrants should not exist (You can’t print to them) so new people aren’t confused why their print is sitting in what looks to them is the upper right of thier print bed.

Thank you for your post. I have to say the Luban software behaves correctly.

The right quadrant in the workplace represents the actual working area of the machine.

Edwin

I guess I’ve been wrong. I always thought that the whole bed was the work area, not just the right upper quadrant.

If I center my object to laser engraver dead center of the bed, the camera shows the whole bed in the right upper quadrant, which you say is normal. If I overlay the image, the sizing is correct. But, I cannot burn the image from the g-code created without either changing the origin or moving the object(or both), or apparently doing it from the console (which I don’t want to do, because my desktop is upstairs and my A350 is in the basement). That is asinine. I should be able to generate the g-code and burn the image from the flash drive without having to do it from the console.

I can see that Edwin, the confusion lies in where the work origin is. If you run the job directly from Luban its at 0,0 on the screen grid, front left of the machine bed. If you transfer the file to the machine and run from the touchscreen the origin is the middle of the machine bed. You might have the view that this is OK, running form the touchscreen means you have to take of the work origin yourself but this perceived inconsistency has confused many, many of your customers, witnessed by the number of posts there are on this subject. I used to answer them when I saw them but I’ve got tired of saying the same thing over and over again.

BTW I think its great that you are so active on the forum again, much appreciated!

@albutch
Find out where the engraving/cutting will take place by setting the Work Origin. The Work Origin corresponds to the (0, 0) coordinate origin in the software.

I wrote an article here.

Edwin