Camera aid background position and work origin

Hi,

I’m trying to work with the camera aid for laser engraving. However, the bottom left of the background always lines up with the work origin (0,0,0). Snapmaker device itself always defaults the work origin to the center of the plate.

How can I line those two up? Am I missing something?

Thanks!

It works like that. The background picture should be on the second quadrant. You don’t have to line up those two dots. You can also check out this video tutorial on the Snapmaker YouTube Channel.

Thanks for answering, however, I don’t think my question was clear.

The tutorial shows the capture in the second quadrant. After which there is no speak of setting the work origin.

My experience with this:

  • Capture camera background

  • This is placed in the second quadrant, with bottom left of image on position 0, 0

  • I generate G-Code and send it over to SM2

  • Now I HAVE to set the work origin on my Snapmaker to the most front left point of the platform, by default it’s the middle of the platform.

Apart from the fact that it is tedious to do this every time, wouldn’t it make more sense to place the background image of the camera capture so that it actually is what you see is what you get?

Not sure if I explained myself clearly enough. I can make videos and screencasts if needed?

Cheers,

Kees.

Never could get this to work. Same kind of problem as OP has. So many things in Luban have to be entered and re-entered multiple times. It’s maddening and a waste of time. We need some preferences, or some way of having things stick, reverting to the most recently used settings, etc. All in all, I feel it’s unreliable, with countless hangs, exceptions and inconsistencies. Also, some key steps – which probably seem so obvious to, and already internalized by, engineers – are missing, again and again. The OP’s problem is typical. So far, I’ve been disappointed by this purchase and it’s cast me a lot of stress. Can’t understand how you guys can’t stabilize this software AND get the help of someone who really knows how to write instruction manuals in English, in the proper flow and sense.
The Capture Camera situation is ludicrous, even if I could get it to work, it’s not possible to zoom in or see any details. Etc., etc.

I too find this problem annoying, any answers?

When using camera capture to place the image in the workspace, the work origin is in the top right quadrant, that’s fine.

After generating gcode and loading it onto the workspace I then set the machine to workspace origin of 0,0.

If the job is controlled by Luban over Wi-Fi everything works as expected but if I send the job to the machines local storage and then run it from the touchscreen, the work origin is reset to the centre of the workspace, which means that unless I jog the machine to 0,0 and set workspace origin, the image is misplaced. This is tedious.

I think the fix could be in firmware, either don’t reset work origin automatically or give us a button on the touchscreen to move the macine coords to 0,0 at the front left.

Thanks.

The solution is as simple as changing the capture code to put the image in the centre of the bed. Either that, or ALL the code modules need to change to put the origin at the front left corner. I’m seeing a distinct lack of configuration control here. Some code uses the centre of the bed, some uses the bottom left corner.