Offset Y problem

hello everyone
i have a problem on my A350 snapmaker.
when I print I have a Y offset and it is random. I have printed the same part 3 times and I have a Y offset never in the same place. do you have a solution
thank you

Give us some pictures to understand your problem, please.

Please share your gcode with us.
It seems your y-axis linear module´s do not match, read on in this thread:

When I use the laser i don’t have the problem

Share your gcode please.

May you have a look while printing, what happens when it is going to shift? (Do you hear a clicking sound, is your filament wrapped around somewhere or tensioned because of a blocked spool or something else?)

No sound and no problem with filament.
I print other piece and the same probleme at different level Z.
i send gcode after sorry

MY Gcode
Piè (3.3 MB)

Nobody had this problem


Sry, I lost your topic and had no time to check your code.
It wouldnt be lost if you @xchrisd me.
I guess i will check your code the following days.

ok I wait and i thank for you

I took a look. I don’t like how that sliced. What is this intended to be? Just looking at how it sliced I don’t think it’ll print well. It’s going to have poor layer adhesion and be very weak and likely to break. Also the center column is not attached and tall thin single-wall extrusions don’t work.

That is a bad gap fill in yellow:

I’m assuming you didn’t enable z-hop, something knocked the nozzle and broke, causing a jam and the resulting layer shift. The fix is first to fix the model so it’s readily printable with 3DP - not everything can be printed. Short of that you’ll need to significantly adjust the slicer settings to make this printable. This is not going to be printable with Luban, you’ll need more control than it offers.

1 Like

Ok I understand , I test with cura tomorow

@Nicolasm i had a look at your file.- Is this sliced with luban?
I guess the main problem of Luban is the 4 outlines,- try to set it to two outlines and 30% infill (or what you need) and try it again.

The orange circle in the inside, is sure quite interesting, is the support for the top of the bolt.- I guess.
For others who maybe watch, here is a pic of the whole thing:

+1: Maybe your bed is not perfect leveled so it easier knock the print off?
+2: Try to print it a bit slower “;work_speed(mm/minute): 3000” means it prints with 50mm/s, i would suggest, at the beginning of your 3d experience, to print such small parts with maximum 30mm/sec to avoid other or multiple problems.

Yes I slice with Luban and orahne it’s the support exactly.
Tomorrow I test slowly my part

i have always the problem. I reduce feed but i have the same problem

Share your settings and your gcode pls.

Cendrier.gcode (2.9 MB)