About the Reboot Screen (White Screen)


#1

Many users run into this problem lately: the printer works fine when suddenly the touch screen shows the white screen with the Snapmaker logo and just freezes. Now we have a theory of this problem and we need your help to verify it.

We think this happens because of the static electricity generated between the modules. This happens more often in winter than in summer because of the dry weather.

Please try the following steps and see if the touch screen freezes again:

  1. Unplug the cable from the heated bed.
  2. When you generate G-code using Snapmaker3D, deselect the following checkbox to disable the printer from heating the heated bed.
    image
  3. Click Preview to generate G-code and then start printing as you did before.

Share your results with us under this thread. When the problem is verified, we will be able to provide solutions to the problems caused by it. Thank you for your help!


Startup failure
"Snapmaker" splash a few minutes after starting a print
#2

I have tried. I had to change filament so that I could attempt this. The heated bed is not plugged in. Using the control panel on the screen. Same symptoms, printer reboots and freezes.

The temperature displayed doesn’t increase.

Monitoring via the USB cable I get
echo:enqueueing "M104 S200.0"
Error:Heating failed, system stopped! Heater_ID: 0
Error:Printer halted. kill() called!

Edit #1:
I have got my multimeter out.

The resistance of the thermistor is 0.12 megaohms. I bought 3 thermistor cables - I have one that is 0.12 megaohms and two that are 0.14 megaohms. So that seems okay.

The resistance of the heater is in the region of 1.6 megaohms - which seems way too high to me - I bought some heater cables yesterday - two are 6 ohms one is 5 ohms. That’s what I would expect.

I suggest that, in my case at least, the heater cable is faulty somewhere.

A bit tricky to replace as I couldn’t find anything close to the plug for that but will keep looking. I may be able to extract the pins and reuse the nylon part.

Edit #2:
I can extract the pins but I don’t think I can reuse them. I also don’t have pins that are compatible. Please can you tell me where I can get the connector from?

Edit #3:
I’m pretty sure they are “sourcingmap® VH3.96-2P 3.96mm Pin Pitch Connector” - I have ordered some… but could take a month to get here.

Edit #4:
Got some pins that were compatible. I have temperature but too much of it. I bought 40w heaters. Just ordered 30w ones. It is such a shame I am having to take guesses with this and that I have received no support as yet.


#4

Hi David, this information is very important to our diagnosis. Could you please take a picture of the reading on the multimeter and where you are getting this reading from?

Look forward to your reply! Thank you!

Best regards,
Rainie


Bug Reports and Feedback for Snapmaker-GD32Base-1.2
Troubleshooting
#5

I have removed the heater from the printer and the pins from its plug. Measuring the resistance from the pins this morning I get just under 1 megaohm.

If I measure the reading from the crimp under the tubing it is 18 ohms (wish I’d have done that earlier - it would have told me the power rating - I’ve just ordered the third set of heaters after taking this reading!).

I have also included the control to test my multimeter which is a piece of jumper wire which reads 0 ohms (as you would expect).

Interestingly, the first reading occasionally went to 0 (on the 2 megaohm scale) suggesting an intermittent connection. Given the tightness of the curve to bend the heater into the block I suspect a mechanical failure of the crimps.

Harry.


#6

@Rainie
I can make an Input for this too but from a different side:
If the Printer/Controller is NOT connected to power and USB (so no physical Connection to any ind of external electrical power) and you move one axis by hand (of course very gentle) the stepper Motor will generate enough electricity to poert up the Display.
I think you should make a redesign of the controller board containing a few more diodes on the Output connectors to prevent these currents from flowing.


#7

I can not deselect the checkbox in snapmaker3D. The software won’t respond when i try to click the checkbox.


#8

Got the heater installed and all is working!! Hurrah!!

All I have to do now is go back to working out how to get the prints to stick again… the first thing to design are some caps for the print head so that the wires are enclosed without being bent too tight.

Over £40 out of pocket to get this sorted - people you need to buy 24V 40W heaters and find 3.96mm pitch plugs and pins.

The irony of this is that I bet this voids my warranty such that it is.


#9

Ok i worked it out and did as you asked, however this scenario does not work for me…

Please try the following steps and see if the touch screen freezes again:
Unplug the cable from the heated bed.
When you generate G-code using Snapmaker3D, deselect the following checkbox to disable the printer from heating the heated bed.
image
Click Preview to generate G-code and then start printing as you did before.

What other options do we have? Hopefully i will be able to print something soon i guess :disappointed:


#10

Hi,

Could you please tell me why it is not possible for you? Do you mean the touch screen still freezes after the above steps?

Look forward to your reply. Thank you!

Best regards,
Rainie


#11

My printer reboots / white screen. The nozzle and the bed are able to reach their commanded temperatures and it will start to print and then reboot freeze at the white screen after tens of layers. I don’t think static buildup is the problem unless just sitting there causes it too. My printer was fine for 8 prints, then failed on the 9th print after 70 layers. It froze on the white screen. The second time it froze I removed the memory key, turned it on, went to the jog axis screen, verified it responded and let it sit. 10 minutes later I came back and tried to jog the axis, the printer was frozen / unresponsive. I turned it off and let it sit longer. Did the same thing all over again.

So no, I don’t think it is related to the heated bed. It freezes up just sitting there at the jog screen.

Edit: I see further down that others are getting further with this. Since my unit locks up with the heated bed off, I like the suspect of the energy generated by the motors. I moved the z axis by hand a little when I was changing filament. If the controller / driver circuitry isn’t reverse current protected / isolated property I see this as being a problem. The z axis moves down very easily when you’re trying to squeeze that hard spring loaded button and push filament in.

My controller froze on the second print after changing the filament from pla to petg. I got one really great petg print out of my printer before the controller crapped out. The only other thing I can point to was that for pla I was running a 50 degree bed and the nozzle temperature was a little lower. For petg I was running a 70 degree bed and 235 degree nozzle temperature. (So, that material with higher heat / higher power being the only difference from the first 8 print jobs.) I’ll reread the thread on a computer tomorrow and see if there are any measurements I can take with my multimeter to add info. My printer has been dead for more than 3 weeks now. I really hope this gets sorted quickly.


#12

Hi,

Yes i followed the 3 steps and the snap maker won’t initiate any printing. After about a minute the screen goes white and doesn’t respond.


#13

same here. im offering to send you my 3d head and controller in trade for new tested working ones to help mitigate the issue with those effected. it seems there is no way to run datalogs to help find solutions to these problems. i also cannot even confirm what firmware is truely on my printer which i think would be helpful in finding problems.

i also feel the 180 day warranty should be extended for early buyers and those with issues like me. mine arrived around december 27th and i have not gotten a single print from my machine as of yet. that is disappointing that i have had this issue since the 1st week of january and have not been able to use it yet due to the issue at hand. please work with me.


#14

What I did to initially identify the fault was try to print from the thumb drive while monitoring what was being sent down the serial link.
Download putty - just search for it - and start it up. Connect to Serial at 115200. Change the serial line to whatever your computer decided to allocate. Click on open.
Then try to print something.
You should get some messages about what is happening.
Pretty much nailed it for me - then of course I had to get the screwdriver and multimeter out.


#15

Hi Harry,

It’s our fault that led you to spend extra money to fix the problem. We should compensate you for your loss and your warranty shouldn’t be voided.
Before refunding you the money, could you please send us a photo of the heater you are using now? We would like to make sure the heater is compatible with the 3D Printing Module.

Look forward to your reply. Thank you!

Best regards,
Rainie


#16

The heater that turned out to be the correct sort was this:

I also ordered a couple of 12V ones (30W and 40W) - which are wrong, it’s 24V (which I would have spotted if I had looked at the power supply). Also tried various connectors to try and plug it in before finding ones that were compatible. Hopefully the proper correct ones will turn up sometime soon. If I’d have figured out the correct parts earlier I would have spent less than £10 - and wouldn’t have a bunch of parts that I have carefully labelled as “Do not use”! :slight_smile: I do have three spare thermistors though now - those should outlast me!

It’s all printing again well now.

Harry.


#17

Hello,

Any idea how to fix my printer yet?


#18

As I didn’t want to have the wire to the heater bent too tightly (that is my diagnosis of the cause) I had a choice of either leaving the wires exposed or fabricating some sort of extension. If only I had something that could do that…


#19

Hi @Cruznbaby85

In the email, you said, "After about a minute the screen goes white and doesn’t respond."
Do you mean the screen goes white about 1 minute after you start the printing? If so, please try again, take a video of the touch screen after you start the print and send the video to support@snapmaker.com. We need to see how the temperature on the touch screen changes.
Also, when the screen goes white again, please check the LED on the controller. How is it flashing and what is the color?

Look forward to your reply. Thank you!

Best regards,
Rainie


#20

Hello,

Email sent.

Thanks for your reply.


#21

why are my posts gone ignored? i really want to get my printer fixed but without help i cannot use it at all. zero complete prints and only one partial print as of now.