Snapmaker original firmware update problem

I’ve had my Snapmaker original for a while and never updated the firmware.
It started acting up recently by ‘freezing’ when the print job was long.
It would freeze after about 5-8 hours.
Short prints still went fine.

A few days later, it freezes after about an hour.
When it freezes the screen just stays on the white Snapmaker loading image & the fan runs.

Figured I should update the firmware.
I tried the following firmware updates:


They all started loading (blue light flashing) But then they all changed to a solid red light on the controller.
The screen also went from reading the temps to saying NA for all the readouts on the screen.

Is there anyway to revert back to the original firmware?
Not sure what to try next?

Any help would be great.

Never had the controller showing a red light…
If you used the same USB stick which corrupts your prints, I would try some other sticks (USB 2.0, Fat32, max. 16GB) and try again.
Unfortunately you will have to contact support if this was no help.

What was your previous firmware, and what does have now? All of the firmware upgrade versions are available at Downloads and Updates for Firmware . I’ve been running 2.11 for over a year without issue.

I recently discovered that there are early beta models that do not have upgradable firmware. Those models don’t have a USB drive, they have an SD card.

When it freezes, it’s the boot screen, not the printing screen? Previous posters have had some issues with power stability causing the controller to reboot in the middle of a print. But that usually reboots the controller, leaving it at the on-but-not-printing screen. Getting stuck on the boot screen could be a power supply issue (under voltage), but it’s more likely to be a controller issue.

Not sure on what the previous firmware was? It was original from when I got it.
I’ve tried updating the firmware to all available updates from the website, with no luck.
After each update attempt, the LED light turns solid Red color.
My printer does have the USB drive.

I will check the power supply.

On the controller, what does the Settings > About screen say you’re running? It’s the first line, mine is Snapmaker-GD32Base-2.11.

I finally started to play with the Kickstarter Snapmaker Original. Luban doesn’t connect to the printer, the firmware update doesn’t work, in the sense that the blue LED doesn’t start blinking.
I found out by luck that SnapmakerJS 2.5.1 does connect to the printer, which might??? mean the controller module is OK?
However, I just bought the enclosure, and then door switches don’t work either.

I wouldn’t mind for a cheap charlie machine, but the Snapmaker is not, and I am very disappointed.

I guess I wait a bit longer to see if the support people can come up with some ideas, before ditching the thing in the trash bin and go for a better brand. I was thinking about buying the A350 but with this kind of support and malfunctions I’m afraid I’ll walk away.


When and where did you purchase this machine? From the Kickstarter campaign?

After you power the machine, the LED behind the controller starts flashing quickly. In order to test the controller, you need to check if you control the machine via the control panel in SnapamakerJS.
You can try the Laser module or CNC module, and see if the machine can work sucessfully.

hi Edwin,

Yes I bought it from the Kickstarter Campaign, then didn’t really use it when I received it, then let it stay in the corner of the workshop, now started it up, just to find out Luban doesn’t connect.
By sheer luck I downloaded an old SnapmakerJS (2.5.1 randomly picked) and found that is connecting to the machine.

I tried to connect without success, running Luban 3.14 on a

  1. MacBook Pro 2012 with macOS (Catalina 10.15.7)
  2. MacBook Pro 2012 with Windows 10
    (This is the same laptop)
  3. Hewlett Packard laptop with Windows 10
  4. Mac mini 2012 (Catalina 10.15.7)
  5. Mac mini 2020 with M1 processor (Big Sur)

I tried to update the firmware which I downloaded from your website

I copied the file on the USB disk, switched off the Snapmaker Original, inserted the disk, switched on the Snapmaker Original, nothing happens (no blinking blue LED.)

so basically the machine is useless if I cannot use it with Luban, apart from 3D printing.

how can I see what is the firmware?
why can I not upload newer firmware?
how can I see the controller is OK?

Do you have a list of M-codes to use in the Console of SnapmakerJS?

I can control the X,Y and Z movements, so in that sense the controller seems to be OK.

As well as the 3D printing from g-code read from the inserted USB micro disk works fine, so in that sense it does seem OK.

I just cannot connect to Luban, with several different computers, Mac and PC, but managed to get the SnapmakerJS to connect.
Door switch of enclosure cannot be selected in that version of SnapmakerJS, in the sense it doesn’t stay on “ON”.

Since you can connect the machine with a PC via SnapmakerJS 2.5.1, you can use the commands to control the door detection.

M1010 Check the status
M1010 S1 Enable door detection
M1010 S0 Disenable door detection

Did you install the CH34X driver on your PC?

Yes, I did install the drivers.
I even checked if they were properly installed, deleted them via the Terminal command as described in the README-file, and reinstall them just to make sure they are the correct one.

Funny thing is that in SnapmakerJS it does connect to the very same port 1420 as where in Luban is states ‘machine not ready’ - and yes, I use one (1) program at the time.

Regrettably, this doesn’t work: on all three commands I get reply : OK