Where is support?

My Snap maker arrived today and i assembled it. Leveled the bed. Loaded the Filament that came with, downloaded a Benchy onto the provided usb stick and went to print and after 15-20 seconds the control module goes to the white screen and the dots at the bottom cycle and it never stops. I power cycled it and tried again with the same thing. I think the 3d Print head is broken already…It does the same thing anytime the print head heats up. updated firmware and it lasts longer now before it white screens on me but thats it. There is no clear spot here for support with general issues…If a Mod can move this to the correct spot or direct me to the proper location i may be ready for a refund lol.

Cannot speak for their support. They got back to me on a support issue within 4 days, however I know they had a month long vacation due to Chinese New Year so they may be backed up now.

It sounds like you have a bad power supply or something is drawing too much current. Basically when you start printing you have the heated bed at temp, the hotend at temp, and all the motors running. In other words your printer is drawing a lot of power. If the power supply is faulty the voltage could drop below an acceptable level. If something is drawing too much power the power supply will not be able to keep up and the voltage could drop below an acceptable level.

I moved this thread here (Hardware/Controller) as you’re more likely to get a response from the support folks.

1 Like

Here are some steps trying to locate your problem:

  1. power off the printer and disconnect the touch screen from the controller. Connect the computer to print a print that needs more than 12 hours. If the print is successful, the touch screen is defective.

  2. Make sure the thermistor is correctly positioned in the heated block like the picture shows. Detach the left side cover and check out the connecting of thermistor and heating tube’s terminals (in the green box). thermistor%20position

  3. If the problem persists after following the above steps, please apply for a request on the site: https://www.snapmaker.com/repair, and fill in the warranty request with more details, and snapmaker support team will deal with it then.

1 Like

Hi sgtwtf,

I got my Snapmaker on Friday. Easy assembly, calibration went smooth. Created a custom Cura profile to improve print/bed adhesion. then started a 10+ hour print to test the performance.

All looks great the first 4 hours. But some time in the 5th hour the printer just froze. No response from the controller. When I touched the screen, the button animation show, but nothing happen. Power cycle to make it respond again. Clear off the failed print (which looked great). Checked all the connections and restarted the print. This time it froze after just 10 minutes. Didn’t even finish the first layer.

Come Saturday, I Decided to check for any firmware updates. Got the latest from 2017-12-19 flashed. This seemed to make it even worse. Now it would freeze at random just siting on the desk doing nothing. Some times with the normal screen, other times with the boot screen.
I noticed that some times the temperature would report as “NA”, so I opened up the print head to check for loose connectors or bad solder joints. All was fine. Had a look inside the controller, all fine there too. Leave the printer alone on the healing bench partly disassembled. It is in this state things some times magically decide to work for no good reason.
Today is Sunday, I had a good nights rest. This morning, while enjoying breakfast this idea came to me. Maybe the cable from the controller to the print head could be replaced with an Ethernet cable. Indeed it could. Switched it out for the shortest one I had. It was 1 meter, so it is ridiculously long. It will be replaced with a much shorter cable eventually. The printer has been going for 2+ hours now, I will update tonight with the results. But it is looking good, going from random freezing within minutes of turning it on to actual printing for hours.


So the printer froze again, and almost exactly at the same place as last time. I recon it made it about two layers further the first time I tried this print. But that was on a different firmware.
I have now detached the screen from the controller and will be testing it from my desktop PC. At this point I suspect bad crimping of the RJ45:s. Both the one for the print head but also the one to the screen. Unfortunately the one on the screen is not so easily replaced. If I can find my crimping tools and connectors, I shall replace the connector on the screen.
I will be back once I have more results to report on.


It seems the issue is solved. Yesterday I replaced the RJ45 connector on the display cable. Then I started the same 10+ hour print. It ran over night and was ready by morning. I can’t say for sure it wont freeze again. Only time will tell. But I’ve gone from printing for 3+ hours, to random freeze/reboot, to 3+ hour printing, and now finally 10+ hour printing.



Here are the befor/after pictures of the RJ45:s. Most notably, in the after picture, you can see how the connector pins has pierced the wires.




1 Like

That is so great of you. Hope everything goes well now. Your experience teaches us a lesson about this issue.
There might be some defects with the processing craft of cable’s connector in the factory.
Wait for your further update about your printing and sharing.
Have fun here,

1 Like