A350 will not connect after an interrupted firmware update

I was updating the firmware of an A350 when I suffered a power failure. When starting up the printer it starts to load, but then advises the the printer is not connected. This two options yes or no, no clears the message and then nothing loads, yes just loops back to the same message. I have tried connecting via Luban, but neither wifi or serial will connect. I assume that the power failure has corrupted the firmware. Is there any way to restore to a default firmware and if not what part of the printer do I have to replace to get a working printer.
I have tried to get an answer from Snapmaker support, but have not received any useful answers


Have you tried updating the firmware again? From a flash drive?

Or have you tried a factory reset and then updating firmware?


I have tried various methods suggested on the snapmaker websites, but none of them allow access. When I try using the Luban Software with the printer started and still displaying the touchpad message that the printer is disconnected. Wifi tries to connect it has the correct IP address but gives the message that the machine or toolhead cannot be recognised. If I try with a USB 2 cable Luban shows com5 but will not connect. Using the monitor in Luban allows me to enter commands but no response from the printer. I have logged a ticket with Snapmaker support but all they have suggested is to reload the firmware, but they are slow to respond.

Sorry missed out one thing if I try to reconnect using the touchpad it loops back to the same message. If I take option not to reconnect then the wifi still shows the printer, but the usb connection does not show the priner or com port, neither of these connections allow the software to connect