Touchscreen and computer won’t connect to Snapmaker 2.0

I just got the A350 a couple of days ago and set it up last night with enclosure. When finally powered on I got the message “the machine is not connected, would you like to reconnect” on the touchscreen.
I followed the steps noted here: and it seems the breathing light is blinking normally. I tried to connect via usb to my pc but Snapmaker Luban software does not recognize that a machine is connected and I am unable to control the machine that way. I tried to update the firmware with the usb drive but since it appears that you must open the firmware file through the touchscreen which isn’t working, I can’t do that either. I have sent an email to support but any tips would be appreciated!

Make sure the touchscreen is plugged all the way in.
It does a little last click before it’s all the way seated. It’s easy to think it’s plugged in properly when it isn’t. (Make sure none of the plugs are interfering)

Some computers need drivers installed or they won’t see the SM.