3D Printer Calibration fails with "Something went wrong" error message

We are new to 3D printing and have a Snapmaker A350. The initial calibration went fine and we were able to do 2 successful prints and one failed print (no biggie there). We were prompted to update the firmware when we turned it on today and after the firmware update the calibration fails on every attempt with the error “Something went wrong with calibration. Please try again.”. We tap retry and the we keep getting the same error. We tried turning it off and on again and we’re still getting the same error. Has anyone else encountered this issue? Any thoughts or ideas would be greatly appreciated.

I had the same issue after a firmware update.
Went down a rabbit hole of trying to revert firmware versions, with no success. Turned out it was, I think, an issue of the y axis being out of calibration range. steps I took to resolve (not sure if some are redundant… suspect so)

updated to the latest firmware: 1.14.2
powered off
removed the y and z axis connectors and switched them round (have a feeling this is not needed, though perhaps unplugging at the controller would help make the machine realize needs a reset?)
performed ‘homing’ by clicking into Control on the touchscreen
re-ran calcibartion (worked fine this time)

note - when calibration wasnt working, going into Control did not ask me to perform homing, but, could see that the y axis coordinates were wrong and the jog control only worked intermitently)

ps if there are any logs I can upload / send to support let me know

Thanks for your reply! We turned on our Snapmaker the other night and were again presented with the message that our firmware was outdated. Except this time we were able to successfully perform the calibration. We’re not exactly inclined to update the firmware again just yet. If we run into this again, I’ll try what you did. It’s the boot log that support requested. I can send you the information on how to obtain the boot log if you’d like. You have to plug your computer into the Snapmaker with the USB cable with the mini USB end on it. If you look at the bar that all the plugs plug into, it’s on the bottom. I had to use a flashlight to see it as the lighting in our house is terrible.

It may be caused by the wrong wiring of the Y and Z axes, try to exchange the two wirings.

Hi Cypress. The printer had been working and we didn’t change any of the wiring. However, in an effort to troubleshoot it, we did swap the Y and Z axes with no change in results.

It doesn’t sound like the problem I’m having. I reversed the Y and Z axis cables before, which caused the same problem as you. If your previous calibration is normal, no wiring has been changed. Maybe a version issue, consider upgrading to the latest version? SM has released version V1.14.2. Hope that solves your problem.

If your machine cannot detect the latest version when connected to wifi, it is likely that the axis is connected incorrectly.

I’ve only used my only A350 a couple of times and all was fine, printing OK etc then before powering it off an update was available so I decided to that and then powered it off. The next time I went to use the 3D printer I’m now getting this same error. I have just updated to another version (Snapmaker2_V1.18.1 260) via USB drive but the calibration is still doing throwing this error. I doubt its the cables the wrong way as it was previously working fine and nobody used it since. Any other ideas as I’m running out of patience :expressionless:?

Did you knew your old firmware version?
Before dual extruder release, the bed calibration got no error if you modified the build plate.
Is your machine original mounted?

It worked fine and printed 2-3 items before no problem, so I would assume then that everything is connected and mounted properly. The issue only occurred when a firmware update happened but I don’t know the previous firmware version unfortunately :expressionless:

I’ve contacted support and been advised to check step 6 of this article:

Which I will try later after work !

It seems you are using the single extruder tool head.
I guess this was your firmware before update:

Older firmware like this was more tolerant to modifications to the heated bed. As written before is your bed original mounted?

Nothing is modified, its all original equipment and I have only ever used it 2 times, I wouldn’t even know how to modify it.

Check your proximity sensor does it light up when actuated?