Z-offset is not calibrating

I was using the laser engrave and wanted to set the work table height up for a thicker object. Something happened to where now it recognizes the Z-offset 20 mm higher than it should and every print job the focal length is too high. How I do reset the z-offset?

You can see in the photos the z-offset shows 41.5. And on the control it is showing the machine coordinates for the Z-axis at 24mm when it is actually at 4mm

Edit: I was only able to upload the second photo.(new users can only post one photo) So when I said you can see the 41.5 offset, that’s not true until I can post the next photo

I’ve had a few z height issues, and fixed a few issues, but I’m not sure they are the same issues you’re having.

My understanding of how this works is when the machine boots with the laser module on it switches from G53 native space into a G54 work offset with the last saved work offset read from EEPROM. Additionally the laser focal length is stored in the toolhead’s memory and read at boot.

If you start a print from the touchscreen is usually (but sometimes doesn’t) reset the work offset in G54 to X/2, Y/2, and Z=laser focal length as saved in the touchscreen.

I’m not really sure what exactly you have tried already. Maybe try adjusting the laser focal length in the touchscreen so that it’s re-written in the toolhead, then going through the touchscreen wizard to start a job from the touchscreen. At the “set work origin” part if it looks right you can back out and power cycle the machine, as that should be saved in the EEPROM.

If it doesn’t look right, sometimes I’ve had luck power cycling the machine and trying again.

I see you’re playing around with G92, and I’ve also tried that and haven’t really had luck with that as a permanent fix as the touchscreen just ignores it and resets the work offset at every job start.